summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2020-05-19 20:47:55 -0700
committerManoj Srivastava <srivasta@debian.org>2020-05-19 21:28:21 -0700
commit50ca5b27f2f7c51d062b3a89d334f7243f467078 (patch)
tree3af98da9dd271527231241fa5b5dc43055bc0c14
parent0664966ad710d299c3ab43a8fe06d141306a0e68 (diff)
upgrade(new git snapshot): Ack NMUs and refresh fromn github
Signed-off-by: Manoj Srivastava <srivasta@debian.org>
-rwxr-xr-xbin/packinit.SH2
-rw-r--r--debian/changelog31
-rw-r--r--debian/compat1
-rw-r--r--debian/control12
-rw-r--r--debian/dist.postinst4
-rwxr-xr-xdebian/rules15
-rw-r--r--dist.man4
-rw-r--r--jmake/jmake.man2
-rw-r--r--mcon/U/d_fast_assert.U85
-rwxr-xr-xmcon/man/mconfig.SH2
-rwxr-xr-xmcon/mconfig.SH2
-rwxr-xr-xmcon/mxref.SH2
-rw-r--r--pat/pat.man2
-rw-r--r--revision.h2
14 files changed, 146 insertions, 20 deletions
diff --git a/bin/packinit.SH b/bin/packinit.SH
index cfe14e5..4a5a38d 100755
--- a/bin/packinit.SH
+++ b/bin/packinit.SH
@@ -16,7 +16,7 @@ case "$0" in
esac
echo "Extracting bin/packinit (with variable substitutions)"
cat >packinit <<!GROK!THIS!
-#! /usr/bin/perl
+#!/usr/bin/perl
# feed this into perl
eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
diff --git a/debian/changelog b/debian/changelog
index a2d300b..c394f08 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,34 @@
+dist (1:3.5-236-1) unstable; urgency=medium
+
+ * New upstream git snapshot
+ * Ack NMUs
+ * Update VCS-* headers in control
+ * Move to standards version 4.3.0 (no changes were needed).
+
+ -- Manoj Srivastava <srivasta@debian.org> Tue, 19 May 2020 20:46:55 -0700
+
+dist (1:3.5-236-0.2) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * debian/dist.postinst: Fix wrong direction form.
+ (Closes: #908187)
+ * debian/rules: Explicitly provide tool path to avoid usrmerge
+ differences and make package reproducible. (Closes: #915910)
+ * debian/rules: Avoid manually setting DEB_HOST_MULTIARCH, use
+ /usr/share/dpkg/architecture.mk instead. (lintian warning)
+
+ -- Boyuan Yang <byang@debian.org> Sun, 23 Feb 2020 17:37:44 -0500
+
+dist (1:3.5-236-0.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * New upstream snapshot (Closes: #898955)
+ * Fix some syntax errors in various scripts (Closes: #899207)
+ * Restore missing dependency libperl4-corelibs-perl
+ * Fix Lintian error by removing Build-Depends-Indep: dpkg-dev
+
+ -- Dominic Hargreaves <dom@earth.li> Sun, 20 May 2018 22:35:58 +0200
+
dist (1:3.5-36.0001-3) unstable; urgency=medium
[ Helmut Grohne ]
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec63514..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index 592e5c8..bdfb310 100644
--- a/debian/control
+++ b/debian/control
@@ -1,17 +1,17 @@
Source: dist
-VCS-Git: https://anonscm.debian.org/git/users/srivasta/debian/dist.git
-VCS-Browser: http://anonscm.debian.org/git/users/srivasta/debian/dist.git
+VCS-Git: https://salsa.debian.org/srivasta/dist.git
+VCS-Browser: https://salsa.debian.org/srivasta/dist
Section: devel
Priority: optional
Maintainer: Manoj Srivastava <srivasta@debian.org>
-Standards-Version: 4.1.3
-Build-Depends-Indep: debhelper (>= 11), sharutils, po-debconf,
- gettext, dpkg-dev
+Standards-Version: 4.3.0
+Build-Depends: debhelper-compat (=12)
+Build-Depends-Indep: sharutils, po-debconf, gettext
Package: dist
Architecture: all
Multi-Arch: foreign
-Depends: perl, debconf (>= 1.2.0) | debconf-2.0,
+Depends: perl, libperl4-corelibs-perl, debconf (>= 1.2.0) | debconf-2.0,
${misc:Depends}
Description: Tools for developing, maintaining and distributing software
The dist package is a set of tools meant to ease the construction
diff --git a/debian/dist.postinst b/debian/dist.postinst
index 7043cce..3e8da16 100644
--- a/debian/dist.postinst
+++ b/debian/dist.postinst
@@ -288,7 +288,7 @@ EOH
set_org_perms () {
chown root /etc/news/organization
- if grep news /etc/group 2>&1 >/dev/null ; then
+ if grep news /etc/group > /dev/null 2>&1 ; then
chgrp news /etc/news/organization
else
chgrp root /etc/news/organization
@@ -397,7 +397,7 @@ case "$1" in
if test ! -d /etc/news ; then
mkdir /etc/news
chown root /etc/news
- if grep news /etc/group 2>&1 >/dev/null ; then
+ if grep news /etc/group > /dev/null 2>&1 ; then
chgrp news /etc/news
else
echo "darn, you do not have news in /etc/group"
diff --git a/debian/rules b/debian/rules
index a70d8c6..a4abf3d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,8 +23,8 @@ PAT_EXEC = patcil patdiff patbase patlog patmake patsend \
patnotify patpost patftp patname patsnap patcol \
patclean patindex
-DPKG_ARCH := dpkg-architecture
-export DEB_HOST_MULTIARCH := $(shell $(DPKG_ARCH) $(ha) -qDEB_HOST_MULTIARCH)
+# For DEB_HOST_MULTIARCH
+include /usr/share/dpkg/architecture.mk
%:
dh $@
@@ -35,15 +35,19 @@ override_dh_auto_configure:
touch .config/nomail && \
sh ./Configure \
-de \
- -D prefix=$(PREFIX) \
+ -D prefix=/usr \
-D orgname=/etc/news/organization \
-D myhostname=localhost \
-D mydomain=localdomain \
-D defeditor=/usr/ae \
- -D privlib=/usr/share/$(package) \
+ -D privlib=/usr/share/$(package) \
-D pager=/bin/more \
-D mansrc=/usr/share/man/ \
-D cf_email='$(email)' \
+ -D grep=/bin/grep \
+ -D sed=/bin/sed \
+ -D cat=/bin/cat \
+ -D zcat=/bin/zcat \
-D d_berknames='define'
@@ -57,6 +61,9 @@ override_dh_auto_build:
override_dh_install:
test -d $(MAN1DIR) || $(make_directory) $(MAN1DIR)
$(MAKE) install
+ for script in $(TMPTOP)/usr/bin/*; do \
+ test `head -1 $$script` = '#!/usr/bin/perl' && perl -c $$script ;\
+ done
$(MAKE) install.man
$(make_directory) $(MAN7DIR)
(cd $(MAN1DIR); for file in $(PAT_EXEC) ; do \
diff --git a/dist.man b/dist.man
index d28da1b..250b862 100644
--- a/dist.man
+++ b/dist.man
@@ -1,7 +1,7 @@
.\" $Id$
.\"
.\" Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
-.\"
+.\"
.\" You may redistribute only under the terms of the Artistic Licence,
.\" as specified in the README file that comes with the distribution.
.\" You may reuse parts of this distribution only within the terms of
@@ -31,7 +31,7 @@
.\" Revision 3.0 1993/08/18 12:04:07 ram
.\" Baseline for dist 3.0 netwide release.
.\"
-.\"
+.\"
.de Ex \" Start of Example
.sp
.in +5
diff --git a/jmake/jmake.man b/jmake/jmake.man
index 1c5832a..dd6de0d 100644
--- a/jmake/jmake.man
+++ b/jmake/jmake.man
@@ -1,7 +1,7 @@
.\" $Id$
.\"
.\" Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
-.\"
+.\"
.\" You may redistribute only under the terms of the Artistic Licence,
.\" as specified in the README file that comes with the distribution.
.\" You may reuse parts of this distribution only within the terms of
diff --git a/mcon/U/d_fast_assert.U b/mcon/U/d_fast_assert.U
new file mode 100644
index 0000000..dba5132
--- /dev/null
+++ b/mcon/U/d_fast_assert.U
@@ -0,0 +1,85 @@
+?RCS: $Id$
+?RCS:
+?RCS: Copyright (c) 2006, Christian Biere
+?RCS:
+?RCS: You may redistribute only under the terms of the Artistic License,
+?RCS: as specified in the README file that comes with the distribution.
+?RCS: You may reuse parts of this distribution only within the terms of
+?RCS: that same Artistic License; a copy of which may be found at the root
+?RCS: of the source tree for dist 4.0.
+?RCS:
+?MAKE:d_fast_assert: Myread Setvar cat gccversion spackage \
+ sed +ccflags +cc +ldflags +optimize
+?MAKE: -pick add $@ %<
+?S:d_fast_assert:
+?S: This variable conditionally defines FAST_ASSERTIONS.
+?S:.
+?C:FAST_ASSERTIONS:
+?C: This symbol, when defined, indicates that the program should make
+?C: use of its own asserting and failure reporting code, instead of
+?C: the one from GLib.
+?C:.
+?H:#$d_fast_assert FAST_ASSERTIONS /**/
+?H:.
+?F:!try.c !try
+?LINT:set d_fast_assert
+?LINT:change ccflags
+: determine whether to enable fast assertions
+echo " "
+case "$d_fast_assert" in
+"$undef")
+ dflt=n;;
+*)
+ dflt=y;;
+esac
+$cat <<EOM
+$spackage contains code called "fast assertions" which are lightweight
+assertions in terms of code space used. They use much less code than
+their GLib counterpart, and therefore should be more efficient.
+
+EOM
+rp='Shall I enable "fast assertions"'
+. ./myread
+case "$ans" in
+y) val="$define";;
+*) val="$undef";;
+esac
+set d_fast_assert
+eval $setvar
+?X: When gcc is used, see whether we can use -momit-leaf-frame-pointer
+?X: This is useful for tail routines containing assertions if they use
+?X: "fast assertions", given that the code is not calling any routine.
+case "$gccversion" in
+'') ;;
+*)
+ case "$d_fast_assert" in
+ "$define")
+ $cat >try.c <<'EOC'
+int main()
+{
+ return 0;
+}
+EOC
+ if $cc $ccflags -momit-leaf-frame-pointer $ldflags -o try try.c >/dev/null 2>&1
+ then
+ case "$ccflags $optimize" in
+ *-momit-leaf-frame-pointer*) ;;
+ *-O0*) ;;
+ *-O*)
+ ccflags="-momit-leaf-frame-pointer $ccflags"
+ echo "Added -momit-leaf-frame-pointer to the cc flags." >&4
+ ;;
+ esac
+ else
+ case "$ccflags" in
+ *-momit-leaf-frame-pointer*)
+ echo "Stripping -momit-leaf-frame-pointer from cc flags." >&4
+ ccflags=`echo $ccflags | $sed 's/ *-momit-leaf-frame-pointer//'`
+ ;;
+ esac
+ fi
+ ;;
+ esac
+;;
+esac
+
diff --git a/mcon/man/mconfig.SH b/mcon/man/mconfig.SH
index 1dd8a97..112c6f1 100755
--- a/mcon/man/mconfig.SH
+++ b/mcon/man/mconfig.SH
@@ -23,7 +23,7 @@ $spitshell >metaconfig.$manext <<!GROK!THIS!
.\" $Id$
.\"
.\" Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
-.\"
+.\"
.\" You may redistribute only under the terms of the Artistic Licence,
.\" as specified in the README file that comes with the distribution.
.\" You may reuse parts of this distribution only within the terms of
diff --git a/mcon/mconfig.SH b/mcon/mconfig.SH
index 42a3dc1..ee17057 100755
--- a/mcon/mconfig.SH
+++ b/mcon/mconfig.SH
@@ -70,6 +70,8 @@ chop($date = `date`);
use Getopt::Std;
&usage unless getopts("dhkmostvwGMVL:X:");
+my %excluded_symbol;
+read_exclusions($opt_X);
$MC = $opt_L if $opt_L; # May override public library path
$MC = &tilda_expand($MC); # ~name expansion
chop($WD = `pwd`); # Working directory
diff --git a/mcon/mxref.SH b/mcon/mxref.SH
index fa9e44e..439aef8 100755
--- a/mcon/mxref.SH
+++ b/mcon/mxref.SH
@@ -64,6 +64,8 @@ use Getopt::Std;
chop($date = `date`);
chop($WD = `pwd`); # Working directory
+my %excluded_symbol;
+read_exclusions($opt_X);
$MC = $opt_L if $opt_L; # May override library path
$MC = &tilda_expand($MC); # ~name expansion
chdir $MC || die "Can't chdir to $MC: $!\n";
diff --git a/pat/pat.man b/pat/pat.man
index c5d29c4..32181f8 100644
--- a/pat/pat.man
+++ b/pat/pat.man
@@ -2,7 +2,7 @@
.\" $Id$
.\"
.\" Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
-.\"
+.\"
.\" You may redistribute only under the terms of the Artistic Licence,
.\" as specified in the README file that comes with the distribution.
.\" You may reuse parts of this distribution only within the terms of
diff --git a/revision.h b/revision.h
index 6dc6209..a7b6f0e 100644
--- a/revision.h
+++ b/revision.h
@@ -1,7 +1,7 @@
/*
* THIS FILE IS AUTOMATICALLY GENERATED -- DO NOT EDIT
*
- * Generated by ./bin/svn-revision.
+ * Generated by bin/svn-revision.
*/
#define REVISION "$Revision: 236 $"