summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrmanfredi <rmanfredi@2592e710-e01b-42a5-8df0-11608a6cc53d>2014-04-08 10:42:18 +0000
committerrmanfredi <rmanfredi@2592e710-e01b-42a5-8df0-11608a6cc53d>2014-04-08 10:42:18 +0000
commit23abf3aa9a6400ac468d296658638c3150c41729 (patch)
tree39b1481b1748d42c4899eca1904a08809f6bee42
parenta8943af6d4b91cc5d3c2d4d391f4d6927ac295b6 (diff)
Always regenerate the Glossary file.
git-svn-id: svn://svn.code.sf.net/p/dist/code/trunk/dist@177 2592e710-e01b-42a5-8df0-11608a6cc53d
-rw-r--r--mcon/Jmakefile4
-rwxr-xr-xmcon/Makefile.SH12
2 files changed, 11 insertions, 5 deletions
diff --git a/mcon/Jmakefile b/mcon/Jmakefile
index 4c2955e..36b6d1f 100644
--- a/mcon/Jmakefile
+++ b/mcon/Jmakefile
@@ -32,7 +32,9 @@
SetSubdirs(man)
AllTarget(Glossary)
-Glossary: makegloss
+.FORCE:
+
+Glossary: .FORCE
chmod +x makegloss
./makegloss
diff --git a/mcon/Makefile.SH b/mcon/Makefile.SH
index 6559d5a..17922d7 100755
--- a/mcon/Makefile.SH
+++ b/mcon/Makefile.SH
@@ -1,5 +1,5 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5-43]
-: $X-Id: Jmake.tmpl 47 2010-11-28 22:23:13Z rmanfredi $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5-174]
+: $X-Id: Jmake.tmpl 156 2012-12-19 16:44:39Z rmanfredi $
case $CONFIG in
'')
@@ -58,7 +58,7 @@ BIN = metaconfig metalint metaxref
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules 18 2006-12-27 10:35:09Z rmanfredi $
+# $X-Id: Jmake.rules 174 2014-04-05 08:19:48Z rmanfredi $
########################################################################
# Start of Jmakefile
@@ -95,7 +95,9 @@ all:: Glossary
local_realclean::
$(RM) Glossary
-Glossary: makegloss
+.FORCE:
+
+Glossary: .FORCE
chmod +x makegloss
./makegloss
@@ -297,6 +299,8 @@ local_clobber:: local_realclean
$(RM) Makefile config.sh
install:: local_install sub_install
+ @exit 0
+
install.man:: maybe_install.man sub_install.man
deinstall:: sub_deinstall local_deinstall
deinstall.man:: sub_deinstall.man maybe_deinstall.man