summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrmanfredi <rmanfredi@2592e710-e01b-42a5-8df0-11608a6cc53d>2012-02-07 17:47:33 +0000
committerrmanfredi <rmanfredi@2592e710-e01b-42a5-8df0-11608a6cc53d>2012-02-07 17:47:33 +0000
commit3cf664800f9de6424bd7dc7d123ce7ae6ba79c77 (patch)
treed993d57d3baee8207f3f12ffe04dfa7c0d45a5aa
parentfb770085ce9b54451589585b1d4be253dc982c43 (diff)
Regenerated.
git-svn-id: svn://svn.code.sf.net/p/dist/code/trunk/dist@123 2592e710-e01b-42a5-8df0-11608a6cc53d
-rwxr-xr-xConfigure39
-rwxr-xr-xMakefile.SH8
2 files changed, 29 insertions, 18 deletions
diff --git a/Configure b/Configure
index 40a8eee..9ce7ad1 100755
--- a/Configure
+++ b/Configure
@@ -18,7 +18,7 @@
# $Id: Head.U 41 2010-11-28 00:21:26Z rmanfredi $
#
-# Generated on Sun Jan 29 22:26:48 CET 2012 [metaconfig 3.5-116]
+# Generated on Tue Feb 7 18:38:00 RST 2012 [metaconfig 3.5-119]
cat >c1$$ <<EOF
ARGGGHHHH!!!!!
@@ -250,6 +250,7 @@ uname=''
uniq=''
uuname=''
vi=''
+wc=''
xgettext=''
zcat=''
zip=''
@@ -450,7 +451,7 @@ case "$sh" in
$me: Fatal Error: I can't find a Bourne Shell anywhere.
Usually it's in /bin/sh. How did you even get this far?
-Please contact me (Raphael Manfredi) at Raphael_Manfredi@grenoble.hp.com and
+Please contact me (Raphael Manfredi) at Raphael_Manfredi@pobox.com and
we'll try to straighten this all out.
EOM
exit 1
@@ -720,7 +721,7 @@ while test $# -gt 0; do
esac
shift
;;
- -V) echo "$me generated by metaconfig 3.5-116." >&2
+ -V) echo "$me generated by metaconfig 3.5-119." >&2
exit 0;;
--) break;;
-*) echo "$me: unknown option $1" >&2; shift; error=true;;
@@ -897,6 +898,7 @@ esac
cat >extract <<EOS
CONFIG=true
SRC="$src"
+TOP=`cd ..; pwd 2>/dev/null`
EOS
cat >>extract <<'EOS'
echo "Doing variable substitutions on .SH files..."
@@ -1019,7 +1021,7 @@ THIS PACKAGE SEEMS TO BE INCOMPLETE.
You have the option of continuing the configuration process, despite the
distinct possibility that your kit is damaged, by typing 'y'es. If you
do, don't blame me if something goes wrong. I advise you to type 'n'o
-and contact the author (Raphael_Manfredi@grenoble.hp.com).
+and contact the author (Raphael_Manfredi@pobox.com).
EOM
echo $n "Continue? [n] $c" >&4
@@ -1248,7 +1250,7 @@ Much effort has been expended to ensure that this shell script will run on any
Unix system. If despite that it blows up on yours, your best bet is to edit
Configure and run it again. If you can't run Configure for some reason,
you'll have to generate a config.sh file by hand. Whatever problems you
-have, let me (Raphael_Manfredi@grenoble.hp.com) know how I blew it.
+have, let me (Raphael_Manfredi@pobox.com) know how I blew it.
This installation script affects things in two ways:
@@ -1372,6 +1374,7 @@ smail
test
uname
vi
+wc
zcat
"
pth=`echo $PATH | sed -e "s/$p_/ /g"`
@@ -1390,7 +1393,7 @@ for file in $loclist; do
'') xxx=`./loc $file $file $pth`;;
*) xxx=`./loc $xxx $xxx $pth`;;
esac
- eval $file=$xxx$_exe
+ eval $file=$xxx
eval _$file=$xxx
case "$xxx" in
/*)
@@ -1423,7 +1426,7 @@ for file in $trylist; do
'') xxx=`./loc $file $file $pth`;;
*) xxx=`./loc $xxx $xxx $pth`;;
esac
- eval $file=$xxx$_exe
+ eval $file=$xxx
eval _$file=$xxx
case "$xxx" in
/*)
@@ -1439,21 +1442,21 @@ for file in $trylist; do
esac
done
case "$egrep" in
-egrep$_exe)
+egrep$_exe|egrep)
echo "Substituting grep for egrep."
egrep=$grep
_egrep=$_grep
;;
esac
case "$ln" in
-ln$_exe)
+ln$_exe|ln)
echo "Substituting cp for ln."
ln=$cp
_ln=$_cp
;;
esac
case "$make" in
-make$_exe)
+make$_exe|make)
case "$gmake" in
gmake)
echo "I can't find make or gmake, and my life depends on it." >&4
@@ -1464,7 +1467,7 @@ make$_exe)
;;
esac
case "$gmake" in
-gmake$_exe) ;;
+gmake$_exe|gmake) ;;
*)
if test -f "/system/gnu_library/bin/ar.pm"; then
: Stratus VOS
@@ -1846,7 +1849,7 @@ $test -f "$uname" && has_uname=y
: Guessing of the OS name -- half the following guesses are probably wrong...
: If you have better tests or hints, please send them to the metaconfig
-: authors and to Raphael_Manfredi@grenoble.hp.com
+: authors and to Raphael_Manfredi@pobox.com
$test -f /irix && osname=irix
$test -f /xenix && osname=sco_xenix
$test -f /dynix && osname=dynix
@@ -2185,7 +2188,7 @@ $test "$override" && . ./optdef.sh
: Restore computed paths
for file in $loclist $trylist; do
- eval $file="\$_$file"$_exe
+ eval $file="\$_$file"
done
osname="$saved_osname"
@@ -2863,7 +2866,7 @@ case "$_o" in
esac
: set the base revision
-baserev=3.0
+baserev=3.5
: make some quick guesses about what we are up against
echo " "
@@ -3980,7 +3983,12 @@ EOS
creatdir="$prog -d"
fi
(ls -l d/try >try.ls; ls -l d/try.ns >tryno.ls) 2>/dev/null
- if (cmp -s d/try try && cmp -s d/try.ns try.ns && \
+ try_wc=`$wc -c try | $awk '{ print $1}' 2>/dev/null`
+ tryns_wc=`$wc -c try.ns | $awk '{ print $1}' 2>/dev/null`
+ d_try_wc=`$wc -c d/try | $awk '{ print $1}' 2>/dev/null`
+ d_tryns_wc=`$wc -c d/try.ns | $awk '{ print $1}' 2>/dev/null`
+ if ($test "X$try_wc" = "X$d_try_wc" && \
+ $test "X$tryns_wc" = "X$d_tryns_wc" && \
$contains 'rwxrw-r--' tryno.ls && \
$contains 'rw-r---w-' try.ls) >/dev/null 2>&1
then
@@ -4575,6 +4583,7 @@ usecrosscompile='$usecrosscompile'
usrinc='$usrinc'
uuname='$uuname'
vi='$vi'
+wc='$wc'
xgettext='$xgettext'
xlibpth='$xlibpth'
zcat='$zcat'
diff --git a/Makefile.SH b/Makefile.SH
index 6dfeac7..3d204eb 100755
--- a/Makefile.SH
+++ b/Makefile.SH
@@ -1,5 +1,5 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5-43]
-: $X-Id: Jmake.tmpl 47 2010-11-28 22:23:13Z rmanfredi $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5-119]
+: $X-Id: Jmake.tmpl 69 2011-01-09 13:57:07Z rmanfredi $
case $CONFIG in
'')
@@ -56,7 +56,7 @@ SUBDIRS = bin mcon jmake pat kit lib
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules 18 2006-12-27 10:35:09Z rmanfredi $
+# $X-Id: Jmake.rules 106 2011-11-25 20:36:12Z rmanfredi $
########################################################################
# Start of Jmakefile
@@ -135,6 +135,8 @@ local_clobber:: local_realclean
$(RM) Makefile
install:: local_install sub_install
+ @exit 0
+
install.man:: maybe_install.man sub_install.man
deinstall:: sub_deinstall local_deinstall
deinstall.man:: sub_deinstall.man maybe_deinstall.man