summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2008-11-25 18:15:37 -0600
committerManoj Srivastava <srivasta@debian.org>2008-11-25 18:15:37 -0600
commit9a759673f29d628f0cf171e7b5e9e86e4c37f706 (patch)
tree1c7e5c6fff528173299af0ef04dbccab71889298
parentfcfe3f145944eb93270f8c4d301313364e1f30b2 (diff)
parente9b2c62292c460d7b8561931d051fe34e2240061 (diff)
Merge branch 'upstream' into topic--debian
-rwxr-xr-xConfigure6
-rwxr-xr-xMakefile.SH2
-rwxr-xr-xbin/perload2
-rw-r--r--mcon/U/Instruct.U2
-rw-r--r--mcon/U/ccflags.U2
-rw-r--r--mcon/U/gccvers.U32
-rw-r--r--revision.h4
7 files changed, 22 insertions, 28 deletions
diff --git a/Configure b/Configure
index 1fb9e5f..cd1dd35 100755
--- a/Configure
+++ b/Configure
@@ -16,9 +16,9 @@
# The dist package (which contains metaconfig) is available via SVN:
# svn co https://svn.sourceforge.net/svnroot/dist/trunk/dist
-# $Id: Head.U 6 2006-08-25 22:21:46Z rmanfredi $
+# $Id: Head.U 25 2008-05-28 11:19:25Z rmanfredi $
#
-# Generated on Wed May 28 13:11:20 CEST 2008 [metaconfig 3.5-17]
+# Generated on Wed May 28 13:22:26 CEST 2008 [metaconfig 3.5-25]
cat >c1$$ <<EOF
ARGGGHHHH!!!!!
@@ -715,7 +715,7 @@ while test $# -gt 0; do
esac
shift
;;
- -V) echo "$me generated by metaconfig 3.5-17." >&2
+ -V) echo "$me generated by metaconfig 3.5-25." >&2
exit 0;;
--) break;;
-*) echo "$me: unknown option $1" >&2; shift; error=true;;
diff --git a/Makefile.SH b/Makefile.SH
index 29cd11c..4915130 100755
--- a/Makefile.SH
+++ b/Makefile.SH
@@ -61,7 +61,7 @@ $spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Start of Jmakefile
-# $X-Id: Jmakefile 9 2006-08-25 22:31:50Z rmanfredi $
+# $X-Id: Jmakefile 25 2008-05-28 11:19:25Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/bin/perload b/bin/perload
index 7ef7137..5e8a4f4 100755
--- a/bin/perload
+++ b/bin/perload
@@ -117,6 +117,8 @@ while (<>) {
$fn_package = $current_package;
$fn_basename = $function;
}
+ die "line $.: duplicate routine ${fn_package}::$fn_basename\n"
+ if $Seen{"${fn_package}::$fn_basename"}++;
# Keep leading function comment
foreach (@Comment) {
push(@Data, $_) unless $autoload;
diff --git a/mcon/U/Instruct.U b/mcon/U/Instruct.U
index deccaf8..37d8afe 100644
--- a/mcon/U/Instruct.U
+++ b/mcon/U/Instruct.U
@@ -27,7 +27,7 @@
?X: isn't going to go shooting off the top of the screen, and we don't want
?X: to panic them yet.
?X:
-?MAKE:Instruct: Myread Configdir contains
+?MAKE:Instruct: Begin Myread Configdir contains
?MAKE: -pick wipe $@ %<
?T:user needman firsttime
: general instructions
diff --git a/mcon/U/ccflags.U b/mcon/U/ccflags.U
index 0deb0c3..b00a557 100644
--- a/mcon/U/ccflags.U
+++ b/mcon/U/ccflags.U
@@ -197,7 +197,7 @@ else
fi
case "$hint" in
-default|recommended) dflt="$ccflags $dflt" ;;
+default|recommended) dflt="$dflt $ccflags" ;;
*) dflt="$ccflags";;
esac
diff --git a/mcon/U/gccvers.U b/mcon/U/gccvers.U
index b7b42fa..6d05184 100644
--- a/mcon/U/gccvers.U
+++ b/mcon/U/gccvers.U
@@ -11,7 +11,7 @@
?RCS: Copyright (c) 2000, Jarkko Hietaniemi
?RCS:
?MAKE:gccversion gccosandvers: cat cpp rm +cc \
- Myread Guess Options Oldconfig Loc osname osvers grep run ccname
+ Myread Guess Options Oldconfig Loc osname osvers grep ccname
?MAKE: -pick add $@ %<
?S:gccversion:
?S: If GNU cc (gcc) is used, this variable holds '1' or '3' (for instance)
@@ -31,20 +31,21 @@
echo " "
echo "Checking for GNU cc in disguise and/or its version number..." >&4
$cat >try.c <<EOM
-#include <stdio.h>
-int main() {
+int main(void) {
#ifdef __GNUC__
-#ifdef __VERSION__
- printf("%s\n", __VERSION__);
-#else
- printf("%s\n", "1");
+gcc_version_major __GNUC__
+#ifdef __GNUC_MINOR__
+gcc_version_minor __GNUC__
+#endif
+#ifdef __GNUC_PATCHLEVEL__
+gcc_version_patchlevel __GNUC_PATCHLEVEL__
#endif
#endif
- exit(0);
}
EOM
-if $cc -o try $ccflags $ldflags try.c >/dev/null 2>&1; then
- gccversion=`$run ./try`
+if $cc -E try.c > try 2>&1
+then
+ gccversion=`sed -n 's/^gcc_version_major[^0-9]*//p' try`
case "$gccversion" in
'') echo "You are not using GNU cc." ;;
*) echo "You are using GNU cc $gccversion."
@@ -52,16 +53,7 @@ if $cc -o try $ccflags $ldflags try.c >/dev/null 2>&1; then
;;
esac
else
- echo " "
- echo "*** WHOA THERE!!! ***" >&4
- echo " Your C compiler \"$cc\" doesn't seem to be working!" >&4
-?X: using -K will prevent aborting--maybe they're cross compiling?
- case "$knowitall" in
- '')
- echo " You'd better start hunting for one and let me know about it." >&4
- exit 1
- ;;
- esac
+ gccversion=''
fi
$rm -f try try.*
case "$gccversion" in
diff --git a/revision.h b/revision.h
index 20f4e73..cab2847 100644
--- a/revision.h
+++ b/revision.h
@@ -1,7 +1,7 @@
/*
- * THIS FILE IS AUTOMATICALLY GENERATED -- DO NOT EDIT ME
+ * THIS FILE IS AUTOMATICALLY GENERATED -- DO NOT EDIT
*
* Generated by ./bin/svn-revision.
*/
-#define REVISION 17
+#define REVISION 25