summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorrmanfredi <rmanfredi@190e5f8e-a817-0410-acf6-e9863daed9af>2006-08-25 22:33:07 +0000
committerrmanfredi <rmanfredi@190e5f8e-a817-0410-acf6-e9863daed9af>2006-08-25 22:33:07 +0000
commit8f97ec1bee96946278ff76ee310af87056ca4240 (patch)
treec3bab7965963b1f281a06d91123b3b372e627e7a /lib
parent98b357f62a88c07f297ba5ad9dd47172531d488b (diff)
Regenerated all Makefile.SH files.
git-svn-id: https://dist.svn.sourceforge.net/svnroot/dist/trunk/dist@10 190e5f8e-a817-0410-acf6-e9863daed9af
Diffstat (limited to 'lib')
-rwxr-xr-xlib/C/Makefile.SH61
-rwxr-xr-xlib/C/fake/Makefile.SH58
-rwxr-xr-xlib/Makefile.SH81
3 files changed, 133 insertions, 67 deletions
diff --git a/lib/C/Makefile.SH b/lib/C/Makefile.SH
index 764aa48..f72cdfc 100755
--- a/lib/C/Makefile.SH
+++ b/lib/C/Makefile.SH
@@ -1,5 +1,5 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.0 PL44]
-: $X-Id: Jmake.tmpl,v 3.0.1.1 1993/08/20 07:36:36 ram Exp ram $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5 PL0]
+: $X-Id: Jmake.tmpl 8 2006-08-25 22:27:18Z rmanfredi $
case $CONFIG in
'')
@@ -37,7 +37,7 @@ DIR = $DIR
# Parameters set by Configure -- edit config.sh if changes are needed
CTAGS = ctags
-MAKE = make
+JCPPFLAGS = $cppflags
MV = $mv
RM = $rm -f
@@ -50,15 +50,15 @@ SUBDIRS = fake
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules,v 3.0.1.1 1994/10/29 15:46:30 ram Exp ram $
+# $X-Id: Jmake.rules 8 2006-08-25 22:27:18Z rmanfredi $
########################################################################
# Start of Jmakefile
-# $X-Id: Jmakefile,v 3.0.1.1 1994/01/24 13:43:38 ram Exp ram $
+# $X-Id: Jmakefile 3 2006-08-25 21:39:07Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
-#
+#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
@@ -73,20 +73,32 @@ $spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Common rules for all Makefiles -- do not edit
-emptyrule::
+all::
clean: sub_clean local_clean
realclean: sub_realclean local_realclean
clobber: sub_clobber local_clobber
local_clean::
- $(RM) core *~ *.o
+ if test -f core; then $(RM) core; fi
+ $(RM) *~ *.o
local_realclean:: local_clean
local_clobber:: local_realclean
$(RM) Makefile config.sh
+install:: local_install sub_install
+install.man:: maybe_install.man sub_install.man
+deinstall:: sub_deinstall local_deinstall
+deinstall.man:: sub_deinstall.man maybe_deinstall.man
+
+install.man-no:
+deinstall.man-no:
+
+maybe_install.man: install.man-no
+maybe_deinstall.man: deinstall.man-no
+
Makefile.SH: Jmakefile
-@if test -f $(TOP)/.package; then \
if test -f Makefile.SH; then \
@@ -95,7 +107,7 @@ Makefile.SH: Jmakefile
fi; \
echo " $(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT)" ; \
$(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT) ; \
- else touch $@; exit 0; fi
+ else touch $@; fi
Makefile: Makefile.SH
/bin/sh Makefile.SH
@@ -115,20 +127,22 @@ subdirs:
for i in $(SUBDIRS) ;\
do \
(cd $$i ; echo $(VERB) "in $(DIR)$$i..."; \
- $(MAKE) $(MFLAGS) $(FLAGS) $(TARGET)); \
+ $(MAKE) $(MFLAGS) $(FLAGS) $(TARGET)) || exit 1; \
done
-install::
+sub_install::
@$(MAKE) subdirs TARGET=install VERB="Installing" FLAGS=
-deinstall::
+sub_deinstall::
@$(MAKE) subdirs TARGET=deinstall VERB="Deinstalling" FLAGS=
+ @echo "Back to $(CURRENT) for "deinstall...
-install.man::
+sub_install.man::
@$(MAKE) subdirs TARGET=install.man VERB="Installing man pages" FLAGS=
-deinstall.man::
+sub_deinstall.man::
@$(MAKE) subdirs TARGET=deinstall.man VERB="Deinstalling man pages" FLAGS=
+ @echo "Back to $(CURRENT) for "deinstall.man...
sub_clean::
@$(MAKE) subdirs TARGET=clean VERB="Cleaning" FLAGS=
@@ -147,7 +161,7 @@ tag::
for i in $(SUBDIRS) ;\
do \
(cd $$i ; echo "Tagging" "in $(DIR)$$i..."; \
- $(MAKE) $(MFLAGS) tag); \
+ $(MAKE) $(MFLAGS) tag) || exit 1; \
done
Makefiles::
@@ -157,7 +171,7 @@ Makefiles::
echo "Making "Makefiles" in $(DIR)$$i..."; \
(cd $$i || exit 1; \
if test ! -f Makefile; then /bin/sh Makefile.SH; fi; \
- $(MAKE) $(MFLAGS) Makefiles) \
+ $(MAKE) $(MFLAGS) Makefiles) || exit 1;\
done
Makefiles.SH:: Makefile.SH
@@ -174,14 +188,23 @@ Makefiles.SH:: Makefile.SH
/*) newtop="$(TOP)" ;; \
esac; \
echo "Making Makefiles.SH in $(DIR)$$i..."; \
- (cd $$i || exit 1; $(MAKE) $(MFLAGS) -f ../Makefile \
- Makefile TOP=$$newtop CURRENT=$(DIR)$$i;\
- $(MAKE) $(MFLAGS) Makefiles.SH) \
+ (cd $$i || exit 1; \
+ if test -f Jmakefile; then \
+ $(MAKE) $(MFLAGS) -f ../Makefile \
+ Makefile TOP=$$newtop CURRENT=$(DIR)$$i && \
+ $(MAKE) $(MFLAGS) Makefiles.SH; \
+ fi; \
+ ) || exit 1; \
done
all::
@$(MAKE) subdirs TARGET=all VERB="Making all" FLAGS=
+local_install::
+local_deinstall::
+local_install.man::
+local_deinstall.man::
+
!NO!SUBS!
chmod 644 Makefile
$eunicefix Makefile
diff --git a/lib/C/fake/Makefile.SH b/lib/C/fake/Makefile.SH
index 6030d62..ad637ae 100755
--- a/lib/C/fake/Makefile.SH
+++ b/lib/C/fake/Makefile.SH
@@ -1,5 +1,5 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.0 PL44]
-: $X-Id: Jmake.tmpl,v 3.0.1.1 1993/08/20 07:36:36 ram Exp ram $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5 PL0]
+: $X-Id: Jmake.tmpl 8 2006-08-25 22:27:18Z rmanfredi $
case $CONFIG in
'')
@@ -41,7 +41,7 @@ INSTALLDIR = $INSTALLDIR
# Parameters set by Configure -- edit config.sh if changes are needed
CTAGS = ctags
-MAKE = make
+JCPPFLAGS = $cppflags
MV = $mv
PRIVLIB = $installprivlib
RM = $rm -f
@@ -50,15 +50,15 @@ RM = $rm -f
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules,v 3.0.1.1 1994/10/29 15:46:30 ram Exp ram $
+# $X-Id: Jmake.rules 8 2006-08-25 22:27:18Z rmanfredi $
########################################################################
# Start of Jmakefile
-# $X-Id: Jmakefile,v 3.0.1.1 1994/01/24 13:43:44 ram Exp ram $
+# $X-Id: Jmakefile 9 2006-08-25 22:31:50Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
-#
+#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
@@ -77,40 +77,56 @@ INSTALLFLAGS = -m 444
all::
install::
- @for dir in $(PRIVLIB)/lib/C/fake; do \
- case '${MFLAGS}' in *[i]*) set +e;; esac; \
- (set -x; test -d $$dir || $(INSTALLDIR) $$dir); \
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ for dir in $(PRIVLIB)/lib/C/fake; do \
+ (set -x; test -d $$dir || $(INSTALLDIR) $$dir) || \
+ exit 1; \
done
-install:: $(FILES)
- @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+local_install:: $(FILES)
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ (set -x; test -d $(INSTALL_PREFIX)$(PRIVLIB)/lib/C/fake || \
+ $(INSTALLDIR) $(INSTALL_PREFIX)$(PRIVLIB)/lib/C/fake); \
for i in $(FILES); do \
- (set -x; $(INSTALL) -c $(INSTALLFLAGS) $$i $(PRIVLIB)/lib/C/fake); \
+ (set -x; $(INSTALL) -c $(INSTALLFLAGS) \
+ $$i $(INSTALL_PREFIX)$(PRIVLIB)/lib/C/fake) || exit 1;\
done
-deinstall::
+local_deinstall::
@case '${MFLAGS}' in *[i]*) set +e;; esac; \
for i in $(FILES); do \
- (set -x; $(RM) $(PRIVLIB)/lib/C/fake/$$i); \
+ (set -x; $(RM) $(INSTALL_PREFIX)$(PRIVLIB)/lib/C/fake/$$i); \
done
########################################################################
# Common rules for all Makefiles -- do not edit
-emptyrule::
+all::
clean: local_clean
realclean: local_realclean
clobber: local_clobber
local_clean::
- $(RM) core *~ *.o
+ if test -f core; then $(RM) core; fi
+ $(RM) *~ *.o
local_realclean:: local_clean
local_clobber:: local_realclean
$(RM) Makefile config.sh
+install:: local_install
+install.man:: maybe_install.man
+deinstall:: local_deinstall
+deinstall.man:: maybe_deinstall.man
+
+install.man-no:
+deinstall.man-no:
+
+maybe_install.man: install.man-no
+maybe_deinstall.man: deinstall.man-no
+
Makefile.SH: Jmakefile
-@if test -f $(TOP)/.package; then \
if test -f Makefile.SH; then \
@@ -119,7 +135,7 @@ Makefile.SH: Jmakefile
fi; \
echo " $(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT)" ; \
$(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT) ; \
- else touch $@; exit 0; fi
+ else touch $@; fi
Makefile: Makefile.SH
/bin/sh Makefile.SH
@@ -134,16 +150,16 @@ local_clobber::
########################################################################
# Empty rules for directories with no sub-directories -- do not edit
-install::
+local_install::
@echo "install in $(CURRENT) done."
-deinstall::
+local_deinstall::
@echo "deinstall in $(CURRENT) done."
-install.man::
+local_install.man::
@echo "install.man in $(CURRENT) done."
-deinstall.man::
+local_deinstall.man::
@echo "deinstall.man in $(CURRENT) done."
Makefiles::
diff --git a/lib/Makefile.SH b/lib/Makefile.SH
index 02e4528..9988b2f 100755
--- a/lib/Makefile.SH
+++ b/lib/Makefile.SH
@@ -1,5 +1,5 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.0 PL44]
-: $X-Id: Jmake.tmpl,v 3.0.1.1 1993/08/20 07:36:36 ram Exp ram $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5 PL0]
+: $X-Id: Jmake.tmpl 8 2006-08-25 22:27:18Z rmanfredi $
case $CONFIG in
'')
@@ -41,7 +41,7 @@ INSTALLDIR = $INSTALLDIR
# Parameters set by Configure -- edit config.sh if changes are needed
CTAGS = ctags
-MAKE = make
+JCPPFLAGS = $cppflags
MV = $mv
PRIVLIB = $installprivlib
RM = $rm -f
@@ -55,15 +55,15 @@ SUBDIRS = C
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules,v 3.0.1.1 1994/10/29 15:46:30 ram Exp ram $
+# $X-Id: Jmake.rules 8 2006-08-25 22:27:18Z rmanfredi $
########################################################################
# Start of Jmakefile
-# $X-Id: Jmakefile,v 3.0.1.1 1994/01/24 13:43:31 ram Exp ram $
+# $X-Id: Jmakefile 5 2006-08-25 22:09:39Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
-#
+#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
@@ -86,21 +86,25 @@ INSTALLFLAGS = -m 444
all::
install::
- @for dir in $(PRIVLIB)/lib; do \
- case '${MFLAGS}' in *[i]*) set +e;; esac; \
- (set -x; test -d $$dir || $(INSTALLDIR) $$dir); \
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ for dir in $(PRIVLIB)/lib; do \
+ (set -x; test -d $$dir || $(INSTALLDIR) $$dir) || \
+ exit 1; \
done
-install:: $(FILES)
- @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+local_install:: $(FILES)
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ (set -x; test -d $(INSTALL_PREFIX)$(PRIVLIB)/lib || \
+ $(INSTALLDIR) $(INSTALL_PREFIX)$(PRIVLIB)/lib); \
for i in $(FILES); do \
- (set -x; $(INSTALL) -c $(INSTALLFLAGS) $$i $(PRIVLIB)/lib); \
+ (set -x; $(INSTALL) -c $(INSTALLFLAGS) \
+ $$i $(INSTALL_PREFIX)$(PRIVLIB)/lib) || exit 1;\
done
-deinstall::
+local_deinstall::
@case '${MFLAGS}' in *[i]*) set +e;; esac; \
for i in $(FILES); do \
- (set -x; $(RM) $(PRIVLIB)/lib/$$i); \
+ (set -x; $(RM) $(INSTALL_PREFIX)$(PRIVLIB)/lib/$$i); \
done
@@ -131,20 +135,32 @@ deinstall::
########################################################################
# Common rules for all Makefiles -- do not edit
-emptyrule::
+all::
clean: sub_clean local_clean
realclean: sub_realclean local_realclean
clobber: sub_clobber local_clobber
local_clean::
- $(RM) core *~ *.o
+ if test -f core; then $(RM) core; fi
+ $(RM) *~ *.o
local_realclean:: local_clean
local_clobber:: local_realclean
$(RM) Makefile config.sh
+install:: local_install sub_install
+install.man:: maybe_install.man sub_install.man
+deinstall:: sub_deinstall local_deinstall
+deinstall.man:: sub_deinstall.man maybe_deinstall.man
+
+install.man-no:
+deinstall.man-no:
+
+maybe_install.man: install.man-no
+maybe_deinstall.man: deinstall.man-no
+
Makefile.SH: Jmakefile
-@if test -f $(TOP)/.package; then \
if test -f Makefile.SH; then \
@@ -153,7 +169,7 @@ Makefile.SH: Jmakefile
fi; \
echo " $(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT)" ; \
$(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT) ; \
- else touch $@; exit 0; fi
+ else touch $@; fi
Makefile: Makefile.SH
/bin/sh Makefile.SH
@@ -173,20 +189,22 @@ subdirs:
for i in $(SUBDIRS) ;\
do \
(cd $$i ; echo $(VERB) "in $(DIR)$$i..."; \
- $(MAKE) $(MFLAGS) $(FLAGS) $(TARGET)); \
+ $(MAKE) $(MFLAGS) $(FLAGS) $(TARGET)) || exit 1; \
done
-install::
+sub_install::
@$(MAKE) subdirs TARGET=install VERB="Installing" FLAGS=
-deinstall::
+sub_deinstall::
@$(MAKE) subdirs TARGET=deinstall VERB="Deinstalling" FLAGS=
+ @echo "Back to $(CURRENT) for "deinstall...
-install.man::
+sub_install.man::
@$(MAKE) subdirs TARGET=install.man VERB="Installing man pages" FLAGS=
-deinstall.man::
+sub_deinstall.man::
@$(MAKE) subdirs TARGET=deinstall.man VERB="Deinstalling man pages" FLAGS=
+ @echo "Back to $(CURRENT) for "deinstall.man...
sub_clean::
@$(MAKE) subdirs TARGET=clean VERB="Cleaning" FLAGS=
@@ -205,7 +223,7 @@ tag::
for i in $(SUBDIRS) ;\
do \
(cd $$i ; echo "Tagging" "in $(DIR)$$i..."; \
- $(MAKE) $(MFLAGS) tag); \
+ $(MAKE) $(MFLAGS) tag) || exit 1; \
done
Makefiles::
@@ -215,7 +233,7 @@ Makefiles::
echo "Making "Makefiles" in $(DIR)$$i..."; \
(cd $$i || exit 1; \
if test ! -f Makefile; then /bin/sh Makefile.SH; fi; \
- $(MAKE) $(MFLAGS) Makefiles) \
+ $(MAKE) $(MFLAGS) Makefiles) || exit 1;\
done
Makefiles.SH:: Makefile.SH
@@ -232,14 +250,23 @@ Makefiles.SH:: Makefile.SH
/*) newtop="$(TOP)" ;; \
esac; \
echo "Making Makefiles.SH in $(DIR)$$i..."; \
- (cd $$i || exit 1; $(MAKE) $(MFLAGS) -f ../Makefile \
- Makefile TOP=$$newtop CURRENT=$(DIR)$$i;\
- $(MAKE) $(MFLAGS) Makefiles.SH) \
+ (cd $$i || exit 1; \
+ if test -f Jmakefile; then \
+ $(MAKE) $(MFLAGS) -f ../Makefile \
+ Makefile TOP=$$newtop CURRENT=$(DIR)$$i && \
+ $(MAKE) $(MFLAGS) Makefiles.SH; \
+ fi; \
+ ) || exit 1; \
done
all::
@$(MAKE) subdirs TARGET=all VERB="Making all" FLAGS=
+local_install::
+local_deinstall::
+local_install.man::
+local_deinstall.man::
+
!NO!SUBS!
chmod 644 Makefile
$eunicefix Makefile