summaryrefslogtreecommitdiff
path: root/mcon/Makefile.SH
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@golden-gryphon.com>2014-04-27 18:05:39 -0700
committerManoj Srivastava <srivasta@golden-gryphon.com>2014-04-27 18:05:39 -0700
commit7d4c02d5c9108aa413fbb0ffa1dc8a39bc5f54a1 (patch)
tree2abb9ad01d397bc1e208f57f528c1ec529761392 /mcon/Makefile.SH
parent5c913c35c09a82eead2c07534baa709a5dead3e7 (diff)
parent8f5e5726134ce5b4bd436b16f367796d851df553 (diff)
Merge branch 'upstream'
Signed-off-by: Manoj Srivastava <srivasta@golden-gryphon.com> Conflicts: jmake/jmake.man
Diffstat (limited to 'mcon/Makefile.SH')
-rwxr-xr-xmcon/Makefile.SH28
1 files changed, 22 insertions, 6 deletions
diff --git a/mcon/Makefile.SH b/mcon/Makefile.SH
index c27f901..54a10b6 100755
--- a/mcon/Makefile.SH
+++ b/mcon/Makefile.SH
@@ -1,5 +1,5 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5 PL0]
-: $X-Id: Jmake.tmpl 8 2006-08-25 22:27:18Z rmanfredi $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5-174]
+: $X-Id: Jmake.tmpl 156 2012-12-19 16:44:39Z rmanfredi $
case $CONFIG in
'')
@@ -58,12 +58,12 @@ BIN = metaconfig metalint metaxref
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules 8 2006-08-25 22:27:18Z rmanfredi $
+# $X-Id: Jmake.rules 174 2014-04-05 08:19:48Z rmanfredi $
########################################################################
# Start of Jmakefile
-# $X-Id: Jmakefile 9 2006-08-25 22:31:50Z rmanfredi $
+# $X-Id: Jmakefile 177 2014-04-08 10:42:18Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
@@ -95,7 +95,9 @@ all:: Glossary
local_realclean::
$(RM) Glossary
-Glossary: makegloss
+.FORCE:
+
+Glossary: .FORCE
chmod +x makegloss
./makegloss
@@ -266,7 +268,8 @@ BINSH = \
mlint.SH \
mxref.SH
-depend::
+depend:: local_depend
+local_depend::
($(SED) '/^# DO NOT DELETE/q' Makefile && \
grep '^\$$grep' $(BINSH) | \
$(SED) -e "s/^.*' \([^ ]*\) >>\([^ ]*\)/\2: \1/" \
@@ -275,6 +278,8 @@ depend::
cp Makefile.new Makefile
$(RM) Makefile.new
+mconfig mlint mxref: $(TOP)/revision.h
+
########################################################################
# Common rules for all Makefiles -- do not edit
@@ -294,6 +299,8 @@ local_clobber:: local_realclean
$(RM) Makefile config.sh
install:: local_install sub_install
+ @exit 0
+
install.man:: maybe_install.man sub_install.man
deinstall:: sub_deinstall local_deinstall
deinstall.man:: sub_deinstall.man maybe_deinstall.man
@@ -324,6 +331,8 @@ tags::
local_clobber::
$(RM) tags
+depend::
+
########################################################################
# Rules for building in sub-directories -- do not edit
@@ -410,6 +419,13 @@ local_deinstall::
local_install.man::
local_deinstall.man::
+########################################################################
+# Dependencies generated by make depend
+# DO NOT DELETE THIS LINE -- make depend relies on it
+
+# Put nothing here or make depend will gobble it up
+.FORCE_DEPEND::
+ @echo "You must run 'make depend' in $(TOP) first."; exit 1
!NO!SUBS!
chmod 644 Makefile
$eunicefix Makefile