summaryrefslogtreecommitdiff
path: root/pat
diff options
context:
space:
mode:
authorrmanfredi <rmanfredi@190e5f8e-a817-0410-acf6-e9863daed9af>2006-08-25 22:33:07 +0000
committerrmanfredi <rmanfredi@190e5f8e-a817-0410-acf6-e9863daed9af>2006-08-25 22:33:07 +0000
commit8f97ec1bee96946278ff76ee310af87056ca4240 (patch)
treec3bab7965963b1f281a06d91123b3b372e627e7a /pat
parent98b357f62a88c07f297ba5ad9dd47172531d488b (diff)
Regenerated all Makefile.SH files.
git-svn-id: https://dist.svn.sourceforge.net/svnroot/dist/trunk/dist@10 190e5f8e-a817-0410-acf6-e9863daed9af
Diffstat (limited to 'pat')
-rwxr-xr-xpat/Makefile.SH102
1 files changed, 60 insertions, 42 deletions
diff --git a/pat/Makefile.SH b/pat/Makefile.SH
index 8424f98..d6a7a10 100755
--- a/pat/Makefile.SH
+++ b/pat/Makefile.SH
@@ -1,5 +1,6 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.0 PL55]
-: $X-Id: Jmake.tmpl,v 3.0.1.2 1995/01/11 14:50:21 ram Exp ram $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5 PL0]
+: $X-Id: Jmake.tmpl 8 2006-08-25 22:27:18Z rmanfredi $
+
case $CONFIG in
'')
if test -f config.sh; then TOP=.;
@@ -21,6 +22,7 @@ DIR=`echo $CURRENT/ | sed -e 's/\.\///g'`
echo "Extracting ${DIR}Makefile (with variable substitutions)"
INSTALL=`echo $install | sed -e 's,\./i,\$(TOP)/i,'`
+INSTALLDIR=`echo $installdir | sed -e 's,\./i,\$(TOP)/i,'`
DATE=`date`
$spitshell >Makefile <<!GROK!THIS!
@@ -33,15 +35,15 @@ TOP = ..
CURRENT = $CURRENT
DIR = $DIR
INSTALL = $INSTALL
+INSTALLDIR = $INSTALLDIR
########################################################################
# Parameters set by Configure -- edit config.sh if changes are needed
CTAGS = ctags
+JCPPFLAGS = $cppflags
L = $manext
MANSRC = $installmansrc
-MAKE = make
-MKDEP = $mkdep \$(DPFLAGS) --
MV = $mv
RM = $rm -f
SCRIPTDIR = $installscript
@@ -51,21 +53,15 @@ SED = $sed
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules,v 3.0.1.3 1995/03/21 08:35:28 ram Exp ram $
-########################################################################
-# Force 'make depend' to be performed first -- do not edit
-
-.FORCE_DEPEND::
-
-all:: .FORCE_DEPEND
+# $X-Id: Jmake.rules 8 2006-08-25 22:27:18Z rmanfredi $
########################################################################
# Start of Jmakefile
-# $X-Id: Jmakefile,v 3.0.1.3 1995/07/24 09:57:21 ram Exp ram $
+# $X-Id: Jmakefile 9 2006-08-25 22:31:50Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
-#
+#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
@@ -157,23 +153,29 @@ patlog: patlog.SH
/bin/sh patlog.SH
-install:: $(PAT)
- @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+local_install:: $(PAT)
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ (set -x; test -d $(INSTALL_PREFIX)$(SCRIPTDIR) || \
+ $(INSTALLDIR) $(INSTALL_PREFIX)$(SCRIPTDIR)); \
for i in $(PAT); do \
- (set -x; $(INSTALL) -c -m 555 $$i $(SCRIPTDIR)); \
+ (set -x; $(INSTALL) -c -m 555 \
+ $$i $(INSTALL_PREFIX)$(SCRIPTDIR)) || exit 1;\
done
-deinstall::
+local_deinstall::
@case '${MFLAGS}' in *[i]*) set +e;; esac; \
for i in $(PAT); do \
- (set -x; $(RM) $(SCRIPTDIR)/$$i); \
+ (set -x; $(RM) $(INSTALL_PREFIX)$(SCRIPTDIR)/$$i); \
done
-install.man:: pat.man
- $(INSTALL) -c -m 444 pat.man $(MANSRC)/pat.$(L)
+local_install.man:: pat.man
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ (set -x; test -d $(INSTALL_PREFIX)$(MANSRC) || \
+ $(INSTALLDIR) $(INSTALL_PREFIX)$(MANSRC)); \
+ $(INSTALL) -c -m 444 pat.man $(INSTALL_PREFIX)$(MANSRC)/pat.$(L)
-deinstall.man::
- $(RM) $(MANSRC)/pat.$(L)
+local_deinstall.man::
+ $(RM) $(INSTALL_PREFIX)$(MANSRC)/pat.$(L)
PATSH = \
pat.SH \
@@ -204,29 +206,51 @@ depend::
########################################################################
# Common rules for all Makefiles -- do not edit
-emptyrule::
+all::
clean: local_clean
realclean: local_realclean
clobber: local_clobber
local_clean::
- $(RM) core *~ *.o
+ if test -f core; then $(RM) core; fi
+ $(RM) *~ *.o
local_realclean:: local_clean
local_clobber:: local_realclean
$(RM) Makefile config.sh
+install:: local_install
+install.man:: maybe_install.man
+deinstall:: local_deinstall
+deinstall.man:: maybe_deinstall.man
+
+install.man-yes: local_install.man
+install.man-no:
+deinstall.man-yes: local_deinstall.man
+deinstall.man-no:
+
+!NO!SUBS!
+case "$installmansrc" in
+'') man=no;;
+*) man=yes;;
+esac
+$spitshell >>Makefile <<!GROK!THIS!
+maybe_install.man: install.man-$man
+maybe_deinstall.man: deinstall.man-$man
+!GROK!THIS!
+$spitshell >>Makefile <<'!NO!SUBS!'
+
Makefile.SH: Jmakefile
-@if test -f $(TOP)/.package; then \
- if test -f Makefile.SH; then \
- echo " $(RM) Makefile.SH~; $(MV) Makefile.SH Makefile.SH~"; \
- $(RM) Makefile.SH~; $(MV) Makefile.SH Makefile.SH~; \
- fi; \
- echo " $(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT)" ; \
- $(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT) ; \
- else touch $@; exit 0; fi
+ if test -f Makefile.SH; then \
+ echo " $(RM) Makefile.SH~; $(MV) Makefile.SH Makefile.SH~"; \
+ $(RM) Makefile.SH~; $(MV) Makefile.SH Makefile.SH~; \
+ fi; \
+ echo " $(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT)" ; \
+ $(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT) ; \
+ else touch $@; fi
Makefile: Makefile.SH
/bin/sh Makefile.SH
@@ -241,28 +265,22 @@ local_clobber::
########################################################################
# Empty rules for directories with no sub-directories -- do not edit
-install::
+local_install::
@echo "install in $(CURRENT) done."
-deinstall::
+local_deinstall::
@echo "deinstall in $(CURRENT) done."
-install.man::
+local_install.man::
@echo "install.man in $(CURRENT) done."
-deinstall.man::
+local_deinstall.man::
@echo "deinstall.man in $(CURRENT) done."
+
Makefiles::
Makefiles.SH::
-########################################################################
-# Dependencies generated by make depend
-# DO NOT DELETE THIS LINE -- make depend relies on it
-
-# Put nothing here or make depend will gobble it up
-.FORCE_DEPEND::
- @echo "You must run 'make depend' in $(TOP) first."; exit 1
!NO!SUBS!
chmod 644 Makefile
$eunicefix Makefile