summaryrefslogtreecommitdiff
path: root/kit/Makefile.SH
diff options
context:
space:
mode:
Diffstat (limited to 'kit/Makefile.SH')
-rwxr-xr-x[-rw-r--r--]kit/Makefile.SH137
1 files changed, 79 insertions, 58 deletions
diff --git a/kit/Makefile.SH b/kit/Makefile.SH
index f1e5209..eacff2c 100644..100755
--- a/kit/Makefile.SH
+++ b/kit/Makefile.SH
@@ -1,5 +1,5 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.0 PL44]
-: $X-Id: Jmake.tmpl,v 3.0.1.1 1993/08/20 07:36:36 ram Exp ram $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5 PL0]
+: $X-Id: Jmake.tmpl 8 2006-08-25 22:27:18Z rmanfredi $
case $CONFIG in
'')
@@ -22,6 +22,7 @@ DIR=`echo $CURRENT/ | sed -e 's/\.\///g'`
echo "Extracting ${DIR}Makefile (with variable substitutions)"
INSTALL=`echo $install | sed -e 's,\./i,\$(TOP)/i,'`
+INSTALLDIR=`echo $installdir | sed -e 's,\./i,\$(TOP)/i,'`
DATE=`date`
$spitshell >Makefile <<!GROK!THIS!
@@ -34,15 +35,15 @@ TOP = ..
CURRENT = $CURRENT
DIR = $DIR
INSTALL = $INSTALL
+INSTALLDIR = $INSTALLDIR
########################################################################
# Parameters set by Configure -- edit config.sh if changes are needed
CTAGS = ctags
+JCPPFLAGS = $cppflags
L = $manext
MANSRC = $installmansrc
-MAKE = make
-MKDEP = $mkdep \$(DPFLAGS) --
MV = $mv
RM = $rm -f
SCRIPTDIR = $installscript
@@ -57,27 +58,20 @@ SCRIPTS = \$(SCRIPT)
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules,v 3.0.1.1 1994/10/29 15:46:30 ram Exp ram $
-
-########################################################################
-# Force 'make depend' to be performed first -- do not edit
-
-.FORCE_DEPEND::
-
-all:: .FORCE_DEPEND
+# $X-Id: Jmake.rules 8 2006-08-25 22:27:18Z rmanfredi $
########################################################################
# Start of Jmakefile
-# $X-Id: Jmakefile,v 3.0.1.2 1994/04/22 09:35:35 ram Exp ram $
+# $X-Id: Jmakefile 9 2006-08-25 22:31:50Z rmanfredi $
+#
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
-# Copyright (c) 1991-1993, Raphael Manfredi
-#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# $X-Log: Jmakefile,v $
# Revision 3.0.1.2 1994/04/22 09:35:35 ram
@@ -110,46 +104,58 @@ kitpost: kitpost.SH
/bin/sh kitpost.SH
-install:: $(SCRIPTS) $(LSCRIPTS)
- @for file in $(SCRIPTS) $(LSCRIPTS); do \
- case '${MFLAGS}' in *[i]*) set +e;; esac; \
- (set -x; $(INSTALL) -c -m 555 $$file $(SCRIPTDIR)); \
+local_install:: $(SCRIPTS) $(LSCRIPTS)
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ (set -x; test -d $(INSTALL_PREFIX)$(SCRIPTDIR) || \
+ $(INSTALLDIR) $(INSTALL_PREFIX)$(SCRIPTDIR)); \
+ for file in $(SCRIPTS) $(LSCRIPTS); do \
+ (set -x; \
+ $(INSTALL) -c -m 555 $$file $(INSTALL_PREFIX)$(SCRIPTDIR)) || \
+ exit 1; \
done
-deinstall::
+local_deinstall::
@for file in $(SCRIPTS) $(LSCRIPTS); do \
case '${MFLAGS}' in *[i]*) set +e;; esac; \
- (set -x; $(RM) $(SCRIPTDIR)/$$file); \
+ (set -x; $(RM) $(INSTALL_PREFIX)$(SCRIPTDIR)/$$file); \
done
-install.man::
- @if test "$(MANSRC)"; then \
- case '${MFLAGS}' in *[i]*) set +e;; esac; \
- for file in $(SCRIPTS); do \
+local_install.man::
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ (set -x; test -d $(INSTALL_PREFIX)$(MANSRC) || \
+ $(INSTALLDIR) $(INSTALL_PREFIX)$(MANSRC)); \
+ for file in $(SCRIPTS); do \
+ if test -f $$file.man; then \
(set -x; \
- $(INSTALL) -c -m 444 $$file.man $(MANSRC)/$$file.$(L)); \
- done; \
- else exit 0; fi
+ $(INSTALL) -c -m 444 $$file.man \
+ $(INSTALL_PREFIX)$(MANSRC)/$$file.$(L)) || \
+ exit 1; \
+ fi; \
+ done
-deinstall.man::
- @if test "$(MANSRC)"; then \
- case '${MFLAGS}' in *[i]*) set +e;; esac; \
- for file in $(SCRIPTS); do \
- (set -x; $(RM) $(MANSRC)/$$file.$(L)); \
- done; \
- else exit 0; fi
+local_deinstall.man::
+ case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ for file in $(SCRIPTS); do \
+ (set -x; $(RM) $(INSTALL_PREFIX)$(MANSRC)/$$file.$(L)); \
+ done
-install:: makeSH
- $(INSTALL) -c -m 555 makeSH $(SCRIPTDIR)
+local_install:: makeSH
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ (set -x; test -d $(INSTALL_PREFIX)$(SCRIPTDIR) || \
+ $(INSTALLDIR) $(INSTALL_PREFIX)$(SCRIPTDIR)); \
+ $(INSTALL) -c -m 555 makeSH $(INSTALL_PREFIX)$(SCRIPTDIR)
-deinstall::
- $(RM) $(SCRIPTDIR)/makeSH
+local_deinstall::
+ $(RM) $(INSTALL_PREFIX)$(SCRIPTDIR)/makeSH
-install.man:: makeSH.man
- $(INSTALL) -c -m 444 makeSH.man $(MANSRC)/makeSH.$(L)
+local_install.man:: makeSH.man
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ (set -x; test -d $(INSTALL_PREFIX)$(MANSRC) || \
+ $(INSTALLDIR) $(INSTALL_PREFIX)$(MANSRC)); \
+ $(INSTALL) -c -m 444 makeSH.man $(INSTALL_PREFIX)$(MANSRC)/makeSH.$(L)
-deinstall.man::
- $(RM) $(MANSRC)/makeSH.$(L)
+local_deinstall.man::
+ $(RM) $(INSTALL_PREFIX)$(MANSRC)/makeSH.$(L)
SCRIPTSH = \
makedist.SH \
@@ -169,20 +175,42 @@ depend::
########################################################################
# Common rules for all Makefiles -- do not edit
-emptyrule::
+all::
clean: local_clean
realclean: local_realclean
clobber: local_clobber
local_clean::
- $(RM) core *~ *.o
+ if test -f core; then $(RM) core; fi
+ $(RM) *~ *.o
local_realclean:: local_clean
local_clobber:: local_realclean
$(RM) Makefile config.sh
+install:: local_install
+install.man:: maybe_install.man
+deinstall:: local_deinstall
+deinstall.man:: maybe_deinstall.man
+
+install.man-yes: local_install.man
+install.man-no:
+deinstall.man-yes: local_deinstall.man
+deinstall.man-no:
+
+!NO!SUBS!
+case "$installmansrc" in
+'') man=no;;
+*) man=yes;;
+esac
+$spitshell >>Makefile <<!GROK!THIS!
+maybe_install.man: install.man-$man
+maybe_deinstall.man: deinstall.man-$man
+!GROK!THIS!
+$spitshell >>Makefile <<'!NO!SUBS!'
+
Makefile.SH: Jmakefile
-@if test -f $(TOP)/.package; then \
if test -f Makefile.SH; then \
@@ -191,7 +219,7 @@ Makefile.SH: Jmakefile
fi; \
echo " $(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT)" ; \
$(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT) ; \
- else touch $@; exit 0; fi
+ else touch $@; fi
Makefile: Makefile.SH
/bin/sh Makefile.SH
@@ -206,29 +234,22 @@ local_clobber::
########################################################################
# Empty rules for directories with no sub-directories -- do not edit
-install::
+local_install::
@echo "install in $(CURRENT) done."
-deinstall::
+local_deinstall::
@echo "deinstall in $(CURRENT) done."
-install.man::
+local_install.man::
@echo "install.man in $(CURRENT) done."
-deinstall.man::
+local_deinstall.man::
@echo "deinstall.man in $(CURRENT) done."
Makefiles::
Makefiles.SH::
-########################################################################
-# Dependencies generated by make depend
-# DO NOT DELETE THIS LINE -- make depend relies on it
-
-# Put nothing here or make depend will gobble it up
-.FORCE_DEPEND::
- @echo "You must run 'make depend' in $(TOP) first."; exit 1
!NO!SUBS!
chmod 644 Makefile
$eunicefix Makefile