summaryrefslogtreecommitdiff
path: root/lib/C/Makefile.SH
diff options
context:
space:
mode:
Diffstat (limited to 'lib/C/Makefile.SH')
-rwxr-xr-x[-rw-r--r--]lib/C/Makefile.SH65
1 files changed, 44 insertions, 21 deletions
diff --git a/lib/C/Makefile.SH b/lib/C/Makefile.SH
index 13286b2..f72cdfc 100644..100755
--- a/lib/C/Makefile.SH
+++ b/lib/C/Makefile.SH
@@ -1,5 +1,5 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.0 PL44]
-: $X-Id: Jmake.tmpl,v 3.0.1.1 1993/08/20 07:36:36 ram Exp ram $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5 PL0]
+: $X-Id: Jmake.tmpl 8 2006-08-25 22:27:18Z rmanfredi $
case $CONFIG in
'')
@@ -37,7 +37,7 @@ DIR = $DIR
# Parameters set by Configure -- edit config.sh if changes are needed
CTAGS = ctags
-MAKE = make
+JCPPFLAGS = $cppflags
MV = $mv
RM = $rm -f
@@ -50,20 +50,20 @@ SUBDIRS = fake
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules,v 3.0.1.1 1994/10/29 15:46:30 ram Exp ram $
+# $X-Id: Jmake.rules 8 2006-08-25 22:27:18Z rmanfredi $
########################################################################
# Start of Jmakefile
-# $X-Id: Jmakefile,v 3.0.1.1 1994/01/24 13:43:38 ram Exp ram $
+# $X-Id: Jmakefile 3 2006-08-25 21:39:07Z rmanfredi $
+#
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
-# Copyright (c) 1991-1993, Raphael Manfredi
-#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# $X-Log: Jmakefile,v $
# Revision 3.0.1.1 1994/01/24 13:43:38 ram
@@ -73,20 +73,32 @@ $spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Common rules for all Makefiles -- do not edit
-emptyrule::
+all::
clean: sub_clean local_clean
realclean: sub_realclean local_realclean
clobber: sub_clobber local_clobber
local_clean::
- $(RM) core *~ *.o
+ if test -f core; then $(RM) core; fi
+ $(RM) *~ *.o
local_realclean:: local_clean
local_clobber:: local_realclean
$(RM) Makefile config.sh
+install:: local_install sub_install
+install.man:: maybe_install.man sub_install.man
+deinstall:: sub_deinstall local_deinstall
+deinstall.man:: sub_deinstall.man maybe_deinstall.man
+
+install.man-no:
+deinstall.man-no:
+
+maybe_install.man: install.man-no
+maybe_deinstall.man: deinstall.man-no
+
Makefile.SH: Jmakefile
-@if test -f $(TOP)/.package; then \
if test -f Makefile.SH; then \
@@ -95,7 +107,7 @@ Makefile.SH: Jmakefile
fi; \
echo " $(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT)" ; \
$(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT) ; \
- else touch $@; exit 0; fi
+ else touch $@; fi
Makefile: Makefile.SH
/bin/sh Makefile.SH
@@ -115,20 +127,22 @@ subdirs:
for i in $(SUBDIRS) ;\
do \
(cd $$i ; echo $(VERB) "in $(DIR)$$i..."; \
- $(MAKE) $(MFLAGS) $(FLAGS) $(TARGET)); \
+ $(MAKE) $(MFLAGS) $(FLAGS) $(TARGET)) || exit 1; \
done
-install::
+sub_install::
@$(MAKE) subdirs TARGET=install VERB="Installing" FLAGS=
-deinstall::
+sub_deinstall::
@$(MAKE) subdirs TARGET=deinstall VERB="Deinstalling" FLAGS=
+ @echo "Back to $(CURRENT) for "deinstall...
-install.man::
+sub_install.man::
@$(MAKE) subdirs TARGET=install.man VERB="Installing man pages" FLAGS=
-deinstall.man::
+sub_deinstall.man::
@$(MAKE) subdirs TARGET=deinstall.man VERB="Deinstalling man pages" FLAGS=
+ @echo "Back to $(CURRENT) for "deinstall.man...
sub_clean::
@$(MAKE) subdirs TARGET=clean VERB="Cleaning" FLAGS=
@@ -147,7 +161,7 @@ tag::
for i in $(SUBDIRS) ;\
do \
(cd $$i ; echo "Tagging" "in $(DIR)$$i..."; \
- $(MAKE) $(MFLAGS) tag); \
+ $(MAKE) $(MFLAGS) tag) || exit 1; \
done
Makefiles::
@@ -157,7 +171,7 @@ Makefiles::
echo "Making "Makefiles" in $(DIR)$$i..."; \
(cd $$i || exit 1; \
if test ! -f Makefile; then /bin/sh Makefile.SH; fi; \
- $(MAKE) $(MFLAGS) Makefiles) \
+ $(MAKE) $(MFLAGS) Makefiles) || exit 1;\
done
Makefiles.SH:: Makefile.SH
@@ -174,14 +188,23 @@ Makefiles.SH:: Makefile.SH
/*) newtop="$(TOP)" ;; \
esac; \
echo "Making Makefiles.SH in $(DIR)$$i..."; \
- (cd $$i || exit 1; $(MAKE) $(MFLAGS) -f ../Makefile \
- Makefile TOP=$$newtop CURRENT=$(DIR)$$i;\
- $(MAKE) $(MFLAGS) Makefiles.SH) \
+ (cd $$i || exit 1; \
+ if test -f Jmakefile; then \
+ $(MAKE) $(MFLAGS) -f ../Makefile \
+ Makefile TOP=$$newtop CURRENT=$(DIR)$$i && \
+ $(MAKE) $(MFLAGS) Makefiles.SH; \
+ fi; \
+ ) || exit 1; \
done
all::
@$(MAKE) subdirs TARGET=all VERB="Making all" FLAGS=
+local_install::
+local_deinstall::
+local_install.man::
+local_deinstall.man::
+
!NO!SUBS!
chmod 644 Makefile
$eunicefix Makefile