summaryrefslogtreecommitdiff
path: root/lib/Jmakefile
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Jmakefile')
-rw-r--r--lib/Jmakefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/lib/Jmakefile b/lib/Jmakefile
new file mode 100644
index 0000000..a44f86a
--- /dev/null
+++ b/lib/Jmakefile
@@ -0,0 +1,57 @@
+/*
+ * Jmakefile for lib subdirectory.
+ */
+
+;# $Id: Jmakefile,v 3.0.1.1 1994/01/24 13:43:31 ram Exp ram $
+;#
+;# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
+;#
+;# You may redistribute only under the terms of the Artistic Licence,
+;# as specified in the README file that comes with the distribution.
+;# You may reuse parts of this distribution only within the terms of
+;# that same Artistic Licence; a copy of which may be found at the root
+;# of the source tree for dist 4.0.
+;#
+;# $Log: Jmakefile,v $
+;# Revision 3.0.1.1 1994/01/24 13:43:31 ram
+;# patch16: added new directory for C code sources
+;#
+;# Revision 3.0 1993/08/18 12:04:34 ram
+;# Baseline for dist 3.0 netwide release.
+;#
+
+FILES = errnolist.a errnolist.mk
+FILES_SH = errnolist makedepend makedir
+
+INSTALLFLAGS = -m 444
+
+all:: /* So that default make does not default to install */
+
+>PRIVLIB /* Grrr.. Have to let jmake know I need this */
+
+MakeDirectories(install,$(PRIVLIB)/lib)
+InstallMultiple($(FILES),$(PRIVLIB)/lib)
+
+/*
+ * InstallSingleExt:
+ * This rule installs a single file whose basename is 'file' and
+ * extension is 'old' into 'file^^new'. This allows changing the
+ * dot extension of a file, for instance file.sh can be installed as
+ * file.SH.
+ */
+#define InstallSingleExt(step,file,dest,flags,old,new) @!\
+>INSTALL @!\
+>RM @!\
+step:: file^^old @@\
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \ @@\
+ (set -x; $(INSTALL) -c flags file^^old dest/file^^new) @@\
+ @!\
+de^^step:: @@\
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \ @@\
+ (set -x; $(RM) dest/file^^new)
+
+#define install_rule \
+ InstallSingleExt(install,!f,$(PRIVLIB)/lib,-m 444,.sh,.SH)
+
+Expand(install_rule,f!$(FILES_SH)!)
+SetSubdirs(C)