summaryrefslogtreecommitdiff
path: root/pat
diff options
context:
space:
mode:
Diffstat (limited to 'pat')
-rw-r--r--pat/Jmakefile5
-rwxr-xr-xpat/Makefile.SH20
-rwxr-xr-xpat/pat.SH4
-rwxr-xr-xpat/patbase.SH4
-rwxr-xr-xpat/patcil.SH4
-rwxr-xr-xpat/patclean.SH4
-rwxr-xr-xpat/patcol.SH4
-rwxr-xr-xpat/patdiff.SH4
-rwxr-xr-xpat/patftp.SH4
-rwxr-xr-xpat/patlog.SH4
-rwxr-xr-xpat/patmake.SH4
-rwxr-xr-xpat/patname.SH4
-rwxr-xr-xpat/patnotify.SH4
-rwxr-xr-xpat/patpost.SH4
-rwxr-xr-xpat/patsend.SH4
-rwxr-xr-xpat/patsnap.SH4
16 files changed, 46 insertions, 35 deletions
diff --git a/pat/Jmakefile b/pat/Jmakefile
index 1071c76..f4d8fc3 100644
--- a/pat/Jmakefile
+++ b/pat/Jmakefile
@@ -2,7 +2,7 @@
* Jmakefile for patching tools.
*/
-;# $Id: Jmakefile 9 2006-08-25 22:31:50Z rmanfredi $
+;# $Id: Jmakefile 48 2010-11-28 23:05:09Z rmanfredi $
;#
;# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
;#
@@ -50,7 +50,8 @@ PATSH = \
!f.SH \
-expand \\
-depend::
+depend:: local_depend
+local_depend::
($(SED) '/^# DO NOT DELETE/q' Makefile && \
grep '^\$$grep' $(PATSH) | \
$(SED) -e "s/^.*' \([^ ]*\) >>\([^ ]*\)/\2: \1/" \
diff --git a/pat/Makefile.SH b/pat/Makefile.SH
index d6a7a10..8fbb905 100755
--- a/pat/Makefile.SH
+++ b/pat/Makefile.SH
@@ -1,5 +1,5 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5 PL0]
-: $X-Id: Jmake.tmpl 8 2006-08-25 22:27:18Z rmanfredi $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5-43]
+: $X-Id: Jmake.tmpl 47 2010-11-28 22:23:13Z rmanfredi $
case $CONFIG in
'')
@@ -53,12 +53,12 @@ SED = $sed
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules 8 2006-08-25 22:27:18Z rmanfredi $
+# $X-Id: Jmake.rules 18 2006-12-27 10:35:09Z rmanfredi $
########################################################################
# Start of Jmakefile
-# $X-Id: Jmakefile 9 2006-08-25 22:31:50Z rmanfredi $
+# $X-Id: Jmakefile 48 2010-11-28 23:05:09Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
@@ -194,7 +194,8 @@ PATSH = \
patsnap.SH \
patlog.SH
-depend::
+depend:: local_depend
+local_depend::
($(SED) '/^# DO NOT DELETE/q' Makefile && \
grep '^\$$grep' $(PATSH) | \
$(SED) -e "s/^.*' \([^ ]*\) >>\([^ ]*\)/\2: \1/" \
@@ -262,6 +263,8 @@ tags::
local_clobber::
$(RM) tags
+depend::
+
########################################################################
# Empty rules for directories with no sub-directories -- do not edit
@@ -281,6 +284,13 @@ Makefiles::
Makefiles.SH::
+########################################################################
+# Dependencies generated by make depend
+# DO NOT DELETE THIS LINE -- make depend relies on it
+
+# Put nothing here or make depend will gobble it up
+.FORCE_DEPEND::
+ @echo "You must run 'make depend' in $(TOP) first."; exit 1
!NO!SUBS!
chmod 644 Makefile
$eunicefix Makefile
diff --git a/pat/pat.SH b/pat/pat.SH
index c38c998..ac4bc4d 100755
--- a/pat/pat.SH
+++ b/pat/pat.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/pat (with variable substitutions)"
cat >pat <<!GROK!THIS!
$startperl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: pat.SH 1 2006-08-24 12:32:52Z rmanfredi $
+# $Id: pat.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/pat/patbase.SH b/pat/patbase.SH
index a1dd222..5866e58 100755
--- a/pat/patbase.SH
+++ b/pat/patbase.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/patbase (with variable substitutions)"
cat >patbase <<!GROK!THIS!
$startperl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: patbase.SH 1 2006-08-24 12:32:52Z rmanfredi $
+# $Id: patbase.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/pat/patcil.SH b/pat/patcil.SH
index 7bdcbc7..d8d0511 100755
--- a/pat/patcil.SH
+++ b/pat/patcil.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/patcil (with variable substitutions)"
$cat >patcil <<!GROK!THIS!
$startperl
- eval "exec perl -i~ -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: patcil.SH 1 2006-08-24 12:32:52Z rmanfredi $
+# $Id: patcil.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/pat/patclean.SH b/pat/patclean.SH
index 51b4508..f4971d9 100755
--- a/pat/patclean.SH
+++ b/pat/patclean.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/patclean (with variable substitutions)"
cat >patclean <<!GROK!THIS!
$startperl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: patclean.SH 1 2006-08-24 12:32:52Z rmanfredi $
+# $Id: patclean.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/pat/patcol.SH b/pat/patcol.SH
index a825d7b..e582f69 100755
--- a/pat/patcol.SH
+++ b/pat/patcol.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/patcol (with variable substitutions)"
cat >patcol <<!GROK!THIS!
$startperl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: patcol.SH 1 2006-08-24 12:32:52Z rmanfredi $
+# $Id: patcol.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/pat/patdiff.SH b/pat/patdiff.SH
index e2e78f7..3ca1973 100755
--- a/pat/patdiff.SH
+++ b/pat/patdiff.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/patdiff (with variable substitutions)"
cat >patdiff <<!GROK!THIS!
$startperl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: patdiff.SH 1 2006-08-24 12:32:52Z rmanfredi $
+# $Id: patdiff.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/pat/patftp.SH b/pat/patftp.SH
index ceb12c0..4acef32 100755
--- a/pat/patftp.SH
+++ b/pat/patftp.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/patftp (with variable substitutions)"
cat >patftp <<!GROK!THIS!
$startperl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: patftp.SH 1 2006-08-24 12:32:52Z rmanfredi $
+# $Id: patftp.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/pat/patlog.SH b/pat/patlog.SH
index 0decc1a..325306e 100755
--- a/pat/patlog.SH
+++ b/pat/patlog.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/patlog (with variable substitutions)"
cat >patlog <<!GROK!THIS!
$startperl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: patlog.SH 20 2008-01-04 23:14:00Z rmanfredi $
+# $Id: patlog.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/pat/patmake.SH b/pat/patmake.SH
index ecc7d35..9b50be0 100755
--- a/pat/patmake.SH
+++ b/pat/patmake.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/patmake (with variable substitutions)"
cat >patmake <<!GROK!THIS!
$startperl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: patmake.SH 20 2008-01-04 23:14:00Z rmanfredi $
+# $Id: patmake.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/pat/patname.SH b/pat/patname.SH
index 2aea9f0..223cf95 100755
--- a/pat/patname.SH
+++ b/pat/patname.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/patname (with variable substitutions)"
cat >patname <<!GROK!THIS!
$startperl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: patname.SH 1 2006-08-24 12:32:52Z rmanfredi $
+# $Id: patname.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/pat/patnotify.SH b/pat/patnotify.SH
index 678577d..1895440 100755
--- a/pat/patnotify.SH
+++ b/pat/patnotify.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/patnotify (with variable substitutions)"
cat >patnotify <<!GROK!THIS!
$startperl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: patnotify.SH 1 2006-08-24 12:32:52Z rmanfredi $
+# $Id: patnotify.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/pat/patpost.SH b/pat/patpost.SH
index f365dee..f45ceaa 100755
--- a/pat/patpost.SH
+++ b/pat/patpost.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/patpost (with variable substitutions)"
cat >patpost <<!GROK!THIS!
$startperl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: patpost.SH 1 2006-08-24 12:32:52Z rmanfredi $
+# $Id: patpost.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/pat/patsend.SH b/pat/patsend.SH
index 6d3dce9..22d7004 100755
--- a/pat/patsend.SH
+++ b/pat/patsend.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/patsend (with variable substitutions)"
cat >patsend <<!GROK!THIS!
$startperl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: patsend.SH 1 2006-08-24 12:32:52Z rmanfredi $
+# $Id: patsend.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
diff --git a/pat/patsnap.SH b/pat/patsnap.SH
index 7961796..bf3f2dd 100755
--- a/pat/patsnap.SH
+++ b/pat/patsnap.SH
@@ -17,10 +17,10 @@ esac
echo "Extracting pat/patsnap (with variable substitutions)"
cat >patsnap <<!GROK!THIS!
$startperl
- eval "exec perl -S \$0 \$*"
+ eval 'exec perl -S \$0 \${1+"\$@"}'
if \$running_under_some_shell;
-# $Id: patsnap.SH 1 2006-08-24 12:32:52Z rmanfredi $
+# $Id: patsnap.SH 31 2010-03-06 20:15:24Z rmanfredi $
#
# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#