summaryrefslogtreecommitdiff
path: root/pat
diff options
context:
space:
mode:
Diffstat (limited to 'pat')
-rw-r--r--pat/Jmakefile13
-rwxr-xr-x[-rw-r--r--]pat/Makefile.SH106
-rwxr-xr-x[-rw-r--r--]pat/pat.SH6
-rw-r--r--pat/pat.man6
-rwxr-xr-x[-rw-r--r--]pat/patbase.SH6
-rw-r--r--pat/patchlevel.h13
-rwxr-xr-x[-rw-r--r--]pat/patcil.SH6
-rwxr-xr-x[-rw-r--r--]pat/patclean.SH6
-rwxr-xr-x[-rw-r--r--]pat/patcol.SH6
-rwxr-xr-x[-rw-r--r--]pat/patdiff.SH6
-rwxr-xr-x[-rw-r--r--]pat/patftp.SH6
-rwxr-xr-x[-rw-r--r--]pat/patindex.SH6
-rwxr-xr-x[-rw-r--r--]pat/patlog.SH14
-rwxr-xr-x[-rw-r--r--]pat/patmake.SH16
-rwxr-xr-x[-rw-r--r--]pat/patname.SH6
-rwxr-xr-x[-rw-r--r--]pat/patnotify.SH6
-rwxr-xr-x[-rw-r--r--]pat/patpost.SH6
-rwxr-xr-x[-rw-r--r--]pat/patsend.SH6
-rwxr-xr-x[-rw-r--r--]pat/patsnap.SH6
19 files changed, 128 insertions, 118 deletions
diff --git a/pat/Jmakefile b/pat/Jmakefile
index c9ab104..40f8ced 100644
--- a/pat/Jmakefile
+++ b/pat/Jmakefile
@@ -2,15 +2,15 @@
* Jmakefile for patching tools.
*/
-;# $Id: Jmakefile,v 3.0.1.3 1995/07/24 09:57:21 ram Exp $
+;# $Id$
;#
-;# Copyright (c) 1991-1993, Raphael Manfredi
+;# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
;#
;# You may redistribute only under the terms of the Artistic Licence,
;# as specified in the README file that comes with the distribution.
;# You may reuse parts of this distribution only within the terms of
;# that same Artistic Licence; a copy of which may be found at the root
-;# of the source tree for dist 3.0.
+;# of the source tree for dist 4.0.
;#
;# $Log: Jmakefile,v $
;# Revision 3.0.1.3 1995/07/24 09:57:21 ram
@@ -42,9 +42,6 @@ PAT = \
NoManPages() /* There is a single man page for all tools */
SimpleShellScriptTarget($(PAT))
->SCRIPTDIR /* Grrr... I have to find a nicer way!! */
->MANSRC /* Idem!! */
-
InstallMultipleFlags($(PAT),$(SCRIPTDIR),-m 555)
InstallManPage(pat,$(MANSRC))
@@ -53,10 +50,6 @@ PATSH = \
!f.SH \
-expand \\
->SED
->RM
->MKDEP
-
depend::
($(SED) '/^# DO NOT DELETE/q' Makefile && \
grep '^\$$grep' $(PATSH) | \
diff --git a/pat/Makefile.SH b/pat/Makefile.SH
index 1ae2c3d..d6a7a10 100644..100755
--- a/pat/Makefile.SH
+++ b/pat/Makefile.SH
@@ -1,5 +1,6 @@
-: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.0 PL55]
-: $X-Id: Jmake.tmpl,v 3.0.1.2 1995/01/11 14:50:21 ram Exp ram $
+: Makefile.SH generated from Jmake.tmpl and Jmakefile [jmake 3.5 PL0]
+: $X-Id: Jmake.tmpl 8 2006-08-25 22:27:18Z rmanfredi $
+
case $CONFIG in
'')
if test -f config.sh; then TOP=.;
@@ -21,6 +22,7 @@ DIR=`echo $CURRENT/ | sed -e 's/\.\///g'`
echo "Extracting ${DIR}Makefile (with variable substitutions)"
INSTALL=`echo $install | sed -e 's,\./i,\$(TOP)/i,'`
+INSTALLDIR=`echo $installdir | sed -e 's,\./i,\$(TOP)/i,'`
DATE=`date`
$spitshell >Makefile <<!GROK!THIS!
@@ -33,15 +35,15 @@ TOP = ..
CURRENT = $CURRENT
DIR = $DIR
INSTALL = $INSTALL
+INSTALLDIR = $INSTALLDIR
########################################################################
# Parameters set by Configure -- edit config.sh if changes are needed
CTAGS = ctags
+JCPPFLAGS = $cppflags
L = $manext
MANSRC = $installmansrc
-MAKE = make
-MKDEP = $mkdep \$(DPFLAGS) --
MV = $mv
RM = $rm -f
SCRIPTDIR = $installscript
@@ -51,26 +53,20 @@ SED = $sed
$spitshell >>Makefile <<'!NO!SUBS!'
########################################################################
# Jmake rules for building libraries, programs, scripts, and data files
-# $X-Id: Jmake.rules,v 3.0.1.3 1995/03/21 08:35:28 ram Exp ram $
-########################################################################
-# Force 'make depend' to be performed first -- do not edit
-
-.FORCE_DEPEND::
-
-all:: .FORCE_DEPEND
+# $X-Id: Jmake.rules 8 2006-08-25 22:27:18Z rmanfredi $
########################################################################
# Start of Jmakefile
-# $X-Id: Jmakefile,v 3.0.1.3 1995/07/24 09:57:21 ram Exp ram $
+# $X-Id: Jmakefile 9 2006-08-25 22:31:50Z rmanfredi $
+#
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
-# Copyright (c) 1991-1993, Raphael Manfredi
-#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# $X-Log: Jmakefile,v $
# Revision 3.0.1.3 1995/07/24 09:57:21 ram
@@ -157,23 +153,29 @@ patlog: patlog.SH
/bin/sh patlog.SH
-install:: $(PAT)
- @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+local_install:: $(PAT)
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ (set -x; test -d $(INSTALL_PREFIX)$(SCRIPTDIR) || \
+ $(INSTALLDIR) $(INSTALL_PREFIX)$(SCRIPTDIR)); \
for i in $(PAT); do \
- (set -x; $(INSTALL) -c -m 555 $$i $(SCRIPTDIR)); \
+ (set -x; $(INSTALL) -c -m 555 \
+ $$i $(INSTALL_PREFIX)$(SCRIPTDIR)) || exit 1;\
done
-deinstall::
+local_deinstall::
@case '${MFLAGS}' in *[i]*) set +e;; esac; \
for i in $(PAT); do \
- (set -x; $(RM) $(SCRIPTDIR)/$$i); \
+ (set -x; $(RM) $(INSTALL_PREFIX)$(SCRIPTDIR)/$$i); \
done
-install.man:: pat.man
- $(INSTALL) -c -m 444 pat.man $(MANSRC)/pat.$(L)
+local_install.man:: pat.man
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ (set -x; test -d $(INSTALL_PREFIX)$(MANSRC) || \
+ $(INSTALLDIR) $(INSTALL_PREFIX)$(MANSRC)); \
+ $(INSTALL) -c -m 444 pat.man $(INSTALL_PREFIX)$(MANSRC)/pat.$(L)
-deinstall.man::
- $(RM) $(MANSRC)/pat.$(L)
+local_deinstall.man::
+ $(RM) $(INSTALL_PREFIX)$(MANSRC)/pat.$(L)
PATSH = \
pat.SH \
@@ -204,29 +206,51 @@ depend::
########################################################################
# Common rules for all Makefiles -- do not edit
-emptyrule::
+all::
clean: local_clean
realclean: local_realclean
clobber: local_clobber
local_clean::
- $(RM) core *~ *.o
+ if test -f core; then $(RM) core; fi
+ $(RM) *~ *.o
local_realclean:: local_clean
local_clobber:: local_realclean
$(RM) Makefile config.sh
+install:: local_install
+install.man:: maybe_install.man
+deinstall:: local_deinstall
+deinstall.man:: maybe_deinstall.man
+
+install.man-yes: local_install.man
+install.man-no:
+deinstall.man-yes: local_deinstall.man
+deinstall.man-no:
+
+!NO!SUBS!
+case "$installmansrc" in
+'') man=no;;
+*) man=yes;;
+esac
+$spitshell >>Makefile <<!GROK!THIS!
+maybe_install.man: install.man-$man
+maybe_deinstall.man: deinstall.man-$man
+!GROK!THIS!
+$spitshell >>Makefile <<'!NO!SUBS!'
+
Makefile.SH: Jmakefile
-@if test -f $(TOP)/.package; then \
- if test -f Makefile.SH; then \
- echo " $(RM) Makefile.SH~; $(MV) Makefile.SH Makefile.SH~"; \
- $(RM) Makefile.SH~; $(MV) Makefile.SH Makefile.SH~; \
- fi; \
- echo " $(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT)" ; \
- $(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT) ; \
- else touch $@; exit 0; fi
+ if test -f Makefile.SH; then \
+ echo " $(RM) Makefile.SH~; $(MV) Makefile.SH Makefile.SH~"; \
+ $(RM) Makefile.SH~; $(MV) Makefile.SH Makefile.SH~; \
+ fi; \
+ echo " $(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT)" ; \
+ $(JMAKE) -DTOPDIR=$(TOP) -DCURDIR=$(CURRENT) ; \
+ else touch $@; fi
Makefile: Makefile.SH
/bin/sh Makefile.SH
@@ -241,28 +265,22 @@ local_clobber::
########################################################################
# Empty rules for directories with no sub-directories -- do not edit
-install::
+local_install::
@echo "install in $(CURRENT) done."
-deinstall::
+local_deinstall::
@echo "deinstall in $(CURRENT) done."
-install.man::
+local_install.man::
@echo "install.man in $(CURRENT) done."
-deinstall.man::
+local_deinstall.man::
@echo "deinstall.man in $(CURRENT) done."
+
Makefiles::
Makefiles.SH::
-########################################################################
-# Dependencies generated by make depend
-# DO NOT DELETE THIS LINE -- make depend relies on it
-
-# Put nothing here or make depend will gobble it up
-.FORCE_DEPEND::
- @echo "You must run 'make depend' in $(TOP) first."; exit 1
!NO!SUBS!
chmod 644 Makefile
$eunicefix Makefile
diff --git a/pat/pat.SH b/pat/pat.SH
index 946bf9d..6b7d52d 100644..100755
--- a/pat/pat.SH
+++ b/pat/pat.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: pat.SH,v 3.0.1.5 1994/10/29 16:37:53 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# Original Author: Larry Wall <lwall@netlabs.com>
#
diff --git a/pat/pat.man b/pat/pat.man
index 05e9ac0..e950620 100644
--- a/pat/pat.man
+++ b/pat/pat.man
@@ -1,13 +1,13 @@
.rn '' }`
-''' $Id: pat.man,v 3.0.1.7 1997/02/28 16:32:45 ram Exp $
+''' $Id$
'''
-''' Copyright (c) 1991-1993, Raphael Manfredi
+''' Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
'''
''' You may redistribute only under the terms of the Artistic Licence,
''' as specified in the README file that comes with the distribution.
''' You may reuse parts of this distribution only within the terms of
''' that same Artistic Licence; a copy of which may be found at the root
-''' of the source tree for dist 3.0.
+''' of the source tree for dist 4.0.
'''
''' $Log: pat.man,v $
''' Revision 3.0.1.7 1997/02/28 16:32:45 ram
diff --git a/pat/patbase.SH b/pat/patbase.SH
index 7d67206..d5d67ad 100644..100755
--- a/pat/patbase.SH
+++ b/pat/patbase.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: patbase.SH,v 3.0.1.3 1994/01/24 14:29:24 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# Original Author: Larry Wall <lwall@netlabs.com>
#
diff --git a/pat/patchlevel.h b/pat/patchlevel.h
index 7d282bb..66b289a 100644
--- a/pat/patchlevel.h
+++ b/pat/patchlevel.h
@@ -14,12 +14,15 @@
*/
/*
- * $Id: patchlevel.h,v 3.0 1993/08/18 12:10:39 ram Exp $
+ * $Id$
*
- * Copyright (c) 1991, Raphael Manfredi
- *
- * You may redistribute only under the terms of the GNU General Public
- * Licence as specified in the README file that comes with dist.
+ * Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
+ *
+ * You may redistribute only under the terms of the Artistic Licence,
+ * as specified in the README file that comes with the distribution.
+ * You may reuse parts of this distribution only within the terms of
+ * that same Artistic Licence; a copy of which may be found at the root
+ * of the source tree for dist 4.0.
*
* $Log: patchlevel.h,v $
* Revision 3.0 1993/08/18 12:10:39 ram
diff --git a/pat/patcil.SH b/pat/patcil.SH
index ffcc069..6e181d3 100644..100755
--- a/pat/patcil.SH
+++ b/pat/patcil.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -i~ -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: patcil.SH,v 3.0.1.4 1994/10/29 16:42:12 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# Original Author: Larry Wall <lwall@netlabs.com>
#
diff --git a/pat/patclean.SH b/pat/patclean.SH
index 16947f1..8c5f522 100644..100755
--- a/pat/patclean.SH
+++ b/pat/patclean.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: patclean.SH,v 3.0.1.2 1994/01/24 14:30:17 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# $Log: patclean.SH,v $
# Revision 3.0.1.2 1994/01/24 14:30:17 ram
diff --git a/pat/patcol.SH b/pat/patcol.SH
index 8cd0090..15fcc6f 100644..100755
--- a/pat/patcol.SH
+++ b/pat/patcol.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: patcol.SH,v 3.0.1.3 1994/01/24 14:30:25 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# $Log: patcol.SH,v $
# Revision 3.0.1.3 1994/01/24 14:30:25 ram
diff --git a/pat/patdiff.SH b/pat/patdiff.SH
index a013aed..33ba90c 100644..100755
--- a/pat/patdiff.SH
+++ b/pat/patdiff.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: patdiff.SH,v 3.0.1.2 1994/01/24 14:30:36 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# Original Author: Larry Wall <lwall@netlabs.com>
#
diff --git a/pat/patftp.SH b/pat/patftp.SH
index 73bd01e..c35aad6 100644..100755
--- a/pat/patftp.SH
+++ b/pat/patftp.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: patftp.SH,v 3.0.1.3 1994/01/24 14:30:43 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# Original Author: Larry Wall <lwall@netlabs.com>
#
diff --git a/pat/patindex.SH b/pat/patindex.SH
index 754d20e..83e175b 100644..100755
--- a/pat/patindex.SH
+++ b/pat/patindex.SH
@@ -18,15 +18,15 @@ echo "Extracting pat/patindex (with variable substitutions)"
$spitshell >patindex <<!GROK!THIS!
$startsh
-# $Id: patindex.SH,v 3.0.1.1 1993/08/19 06:42:37 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# Original Author: Larry Wall <lwall@netlabs.com>
#
diff --git a/pat/patlog.SH b/pat/patlog.SH
index 45059f6..ad3fbd3 100644..100755
--- a/pat/patlog.SH
+++ b/pat/patlog.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: patlog.SH,v 3.0.1.2 1997/02/28 16:33:03 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# $Log: patlog.SH,v $
# Revision 3.0.1.2 1997/02/28 16:33:03 ram
@@ -103,12 +103,10 @@ if (-s ".logs$bnum") {
}
}
close LOGS;
- $* = 1;
$subj = $logs;
- $logs =~ s/^patch\d+:\s*/\t/g;
- $logs =~ s/\n/\n\n/g;
- $subj =~ s/^patch\d+:\s*/Subject: /g;
- $* = 0;
+ $logs =~ s/^patch\d+:\s*/\t/gm;
+ $logs =~ s/\n/\n\n/gm;
+ $subj =~ s/^patch\d+:\s*/Subject: /gm;
} else {
$subj = "Subject: \n";
}
diff --git a/pat/patmake.SH b/pat/patmake.SH
index c85f729..3d476f1 100644..100755
--- a/pat/patmake.SH
+++ b/pat/patmake.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: patmake.SH,v 3.0.1.5 1995/09/25 09:21:19 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# Original Author: Larry Wall <lwall@netlabs.com>
# Contribution by: Graham Stoney <greyham@research.canon.oz.au>
@@ -107,15 +107,13 @@ if ($#ARGV > 0) {
$mf .= $_ if /^[a-z.]+\s*:/; # Rules in makefile
}
}
-$* = 1;
$after = '';
$after .= "\t\tConfigure -ders\n" if -f 'Configure';
-$after .= "\t\tmake depend\n" if $mf =~ /^depend:/;
+$after .= "\t\tmake depend\n" if $mf =~ /^depend:/m;
$after .= "\t\tmake\n" if $mf;
-$after .= "\t\tmake test\n" if $mf =~ /^test:/;
-$after .= "\t\tmake install\n" if $mf =~ /^install:/;
-$after .= "\t\tmake install.man\n" if $mf =~ /^install\.man:/;
-$* = 0;
+$after .= "\t\tmake test\n" if $mf =~ /^test:/m;
+$after .= "\t\tmake install\n" if $mf =~ /^install:/m;
+$after .= "\t\tmake install.man\n" if $mf =~ /^install\.man:/m;
chdir 'bugs' if -d 'bugs';
die "$progname: patch #$bnum already exists.\n" if -f "patch$bnum";
diff --git a/pat/patname.SH b/pat/patname.SH
index c22696d..9397329 100644..100755
--- a/pat/patname.SH
+++ b/pat/patname.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: patname.SH,v 3.0.1.2 1994/01/24 14:31:02 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# $Log: patname.SH,v $
# Revision 3.0.1.2 1994/01/24 14:31:02 ram
diff --git a/pat/patnotify.SH b/pat/patnotify.SH
index 7fc27e9..1ee93f6 100644..100755
--- a/pat/patnotify.SH
+++ b/pat/patnotify.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: patnotify.SH,v 3.0.1.9 1997/02/28 16:33:35 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# $Log: patnotify.SH,v $
# Revision 3.0.1.9 1997/02/28 16:33:35 ram
diff --git a/pat/patpost.SH b/pat/patpost.SH
index 8f245bd..7a8ec54 100644..100755
--- a/pat/patpost.SH
+++ b/pat/patpost.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: patpost.SH,v 3.0.1.4 1995/05/12 12:25:58 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# Original Author: Larry Wall <lwall@netlabs.com>
#
diff --git a/pat/patsend.SH b/pat/patsend.SH
index 6a5b4aa..61797be 100644..100755
--- a/pat/patsend.SH
+++ b/pat/patsend.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: patsend.SH,v 3.0.1.6 1995/09/25 09:22:02 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# Original Author: Larry Wall <lwall@netlabs.com>
#
diff --git a/pat/patsnap.SH b/pat/patsnap.SH
index 87274b8..a5e8754 100644..100755
--- a/pat/patsnap.SH
+++ b/pat/patsnap.SH
@@ -20,15 +20,15 @@ $startperl
eval "exec perl -S \$0 \$*"
if \$running_under_some_shell;
-# $Id: patsnap.SH,v 3.0.1.2 1994/01/24 14:33:08 ram Exp $
+# $Id$
#
-# Copyright (c) 1991-1993, Raphael Manfredi
+# Copyright (c) 1991-1997, 2004-2006, Raphael Manfredi
#
# You may redistribute only under the terms of the Artistic Licence,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
# that same Artistic Licence; a copy of which may be found at the root
-# of the source tree for dist 3.0.
+# of the source tree for dist 4.0.
#
# $Log: patsnap.SH,v $
# Revision 3.0.1.2 1994/01/24 14:33:08 ram