summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlysses Souza <ulysses.souza@docker.com>2019-08-06 15:28:46 +0200
committerUlysses Souza <ulysses.souza@docker.com>2019-08-06 15:28:46 +0200
commit661ac20e5d0a926fbca015133eda0574a9e4a1bd (patch)
treed40a414ae0d354703f06fe976b2e7519a937a1a1
parentab93b87f04a25d9397371bd0e78326e8fe631107 (diff)
"Bump 1.25.0-rc2"
Signed-off-by: Ulysses Souza <ulysses.souza@docker.com>
-rw-r--r--CHANGELOG.md71
-rw-r--r--compose/__init__.py2
-rwxr-xr-xscript/run/run.sh2
3 files changed, 73 insertions, 2 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 7a3ad8bf..89f02881 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,77 @@
Change log
==========
+1.25.0-rc2 (2019-08-06)
+-------------------
+
+### Features
+
+- Add tag `docker-compose:latest`
+
+- Add `docker-compose:<version>-alpine` image/tag
+
+- Add `docker-compose:<version>-debian` image/tag
+
+- Bumped `docker-py` 4.0.1
+
+- Supports `requests` up to 2.22.0 version
+
+- Drops empty tag on `build:cache_from`
+
+- `Dockerfile` now generates `libmusl` binaries for alpine
+
+- Only pull images that can't be built
+
+- Attribute `scale` can now accept `0` as a value
+
+- Added `--quiet` build flag
+
+- Added `--no-interpolate` to `docker-compose config`
+
+- Bump OpenSSL for macOS build (`1.1.0j` to `1.1.1a`)
+
+- Added `--no-rm` to `build` command
+
+- Added support for `credential_spec`
+
+- Resolve digests without pulling image
+
+- Upgrade `pyyaml` to `4.2b1`
+
+- Lowered severity to `warning` if `down` tries to remove nonexisting image
+
+- Use improved API fields for project events when possible
+
+- Update `setup.py` for modern `pypi/setuptools` and remove `pandoc` dependencies
+
+- Removed `Dockerfile.armhf` which is no longer needed
+
+### Bugfixes
+
+- Fixed stdin_open
+
+- Fixed `--remove-orphans` when used with `up --no-start`
+
+- Fixed `docker-compose ps --all`
+
+- Fixed `depends_on` dependency recreation behavior
+
+- Fixed bash completion for `build --memory`
+
+- Fixed misleading warning concerning env vars when performing an `exec` command
+
+- Fixed failure check in parallel_execute_watch
+
+- Fixed race condition after pulling image
+
+- Fixed error on duplicate mount points.
+
+- Fixed merge on networks section
+
+- Always connect Compose container to `stdin`
+
+- Fixed the presentation of failed services on 'docker-compose start' when containers are not available
+
1.24.0 (2019-03-28)
-------------------
diff --git a/compose/__init__.py b/compose/__init__.py
index 0042896b..df0fd3fb 100644
--- a/compose/__init__.py
+++ b/compose/__init__.py
@@ -1,4 +1,4 @@
from __future__ import absolute_import
from __future__ import unicode_literals
-__version__ = '1.25.0dev'
+__version__ = '1.25.0-rc2'
diff --git a/script/run/run.sh b/script/run/run.sh
index f3456720..8756ae34 100755
--- a/script/run/run.sh
+++ b/script/run/run.sh
@@ -15,7 +15,7 @@
set -e
-VERSION="1.24.0"
+VERSION="1.25.0-rc2"
IMAGE="docker/compose:$VERSION"