summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2018-10-18 21:28:47 -0300
committerDavid Bremner <david@tethera.net>2018-10-18 21:47:11 -0300
commit0040624f17048fe922c00c4582f6690fcc684692 (patch)
tree5ff8820f52b54df677690553e48b466fc1b3bed9
parentd71044e6dc199d4e9865c167f59b8ee8b1f7c8f3 (diff)
use defface to define debian-changelog-warning-facedebian/37.5archive/debian/37.5
-rw-r--r--debian-changelog-mode.el7
-rw-r--r--debian/changelog4
2 files changed, 8 insertions, 3 deletions
diff --git a/debian-changelog-mode.el b/debian-changelog-mode.el
index d835d4a..d7f94a2 100644
--- a/debian-changelog-mode.el
+++ b/debian-changelog-mode.el
@@ -488,6 +488,7 @@ Pass ARGS to `replace-regexp-in-string' (GNU Emacs) or to
(defvar debian-bug-open-alist)
(require 'faces)
+(require 'custom)
(require 'add-log)
(require 'easymenu)
(eval-when-compile
@@ -1404,9 +1405,11 @@ interface to set it, or simply set the variable
"Face to use for important keywords.")
(cond
- ((and (fboundp 'facep)
+ ((and (fboundp 'defface)
(facep 'font-lock-warning-face))
- (copy-face 'font-lock-warning-face 'debian-changelog-warning-face))
+ (defface debian-changelog-warning-face '((t :inherit font-lock-warning-face))
+ "Face for debian-changelog important strings."
+ :group 'debian-changelog-faces))
((fboundp 'defface)
(defface debian-changelog-warning-face
'((((class grayscale)(background light))(:foreground "DimGray" :bold t))
diff --git a/debian/changelog b/debian/changelog
index c65a8fa..d906fcb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,8 +3,10 @@ dpkg-dev-el (37.5) unstable; urgency=medium
* debian-changelog-mode: (require 'faces). Bug fix:
"debian-changelog-warning-face not defined in Emacs 23", thanks to
Trent W. Buck (Closes: #592195).
+ * debian-changelog-mode: use defface to define
+ debian-changelog-warning-face (Closes: #500642)
- -- David Bremner <bremner@debian.org> Thu, 18 Oct 2018 21:15:53 -0300
+ -- David Bremner <bremner@debian.org> Thu, 18 Oct 2018 21:28:20 -0300
dpkg-dev-el (37.4) unstable; urgency=medium