summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMirek Kratochvil <exa.exa@gmail.com>2019-09-30 17:12:39 +0200
committerMirek Kratochvil <exa.exa@gmail.com>2019-09-30 17:12:39 +0200
commit12064dd2106d252290ac480cf55d889f97ccd571 (patch)
treed541fbdcf580956817def0fcd3fb191aed1c7f40
parent2c12f05f923d2075af2f7d4fe93935277b2fa645 (diff)
parent1f55051f365616ed5d7a4c669221511c538f6887 (diff)
Update upstream source from tag 'upstream/1.9.1'
Update to upstream version '1.9.1' with Debian dir c49f6f6097f4cd670111f5e446ccac8b5b97c3ab
-rw-r--r--.editorconfig17
-rw-r--r--CHANGELOG.md18
-rw-r--r--README.md6
-rw-r--r--config/binding/default12
-rw-r--r--mk/build.mk2
-rwxr-xr-xmk/version.sh6
-rw-r--r--src/screen-tabbar.c16
-rw-r--r--src/screen.h24
8 files changed, 54 insertions, 47 deletions
diff --git a/.editorconfig b/.editorconfig
deleted file mode 100644
index e2d179d..0000000
--- a/.editorconfig
+++ /dev/null
@@ -1,17 +0,0 @@
-root = true
-
-[*]
-indent_style = space
-indent_size = 4
-tab_width = 8
-
-[{GNUmakefile,makefile,*.mk}]
-indent_style = tab
-indent_size = 8
-
-[docs/*.html]
-indent_style = space
-indent_size = 2
-
-[.git/COMMIT_EDITMSG]
-max_line_length = 72
diff --git a/CHANGELOG.md b/CHANGELOG.md
index b631103..6e3b1a0 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,8 +1,22 @@
Releases
========
-v1.9 (latest release)
----------------------
+v1.9.1 (latest release)
+-----------------------
+
+Released on 2019-09-29.
+
+**Changes:**
+
+* Fixed `make check` when running from a release tarball.
+
+**Downloads:**
+
+* [dte-1.9.1.tar.gz](https://craigbarnes.gitlab.io/dist/dte/dte-1.9.1.tar.gz)
+* [dte-1.9.1.tar.gz.sig](https://craigbarnes.gitlab.io/dist/dte/dte-1.9.1.tar.gz.sig)
+
+v1.9
+----
Released on 2019-09-21.
diff --git a/README.md b/README.md
index 32dcc97..b71e05b 100644
--- a/README.md
+++ b/README.md
@@ -40,9 +40,9 @@ Installation
To build `dte` from source, first install the requirements listed above,
then use the following commands:
- curl -LO https://craigbarnes.gitlab.io/dist/dte/dte-1.9.tar.gz
- tar -xzf dte-1.9.tar.gz
- cd dte-1.9
+ curl -LO https://craigbarnes.gitlab.io/dist/dte/dte-1.9.1.tar.gz
+ tar -xzf dte-1.9.1.tar.gz
+ cd dte-1.9.1
make -j8 && sudo make install
Documentation
diff --git a/config/binding/default b/config/binding/default
index fedcbd6..66a55c1 100644
--- a/config/binding/default
+++ b/config/binding/default
@@ -30,15 +30,23 @@ bind C-S-left 'word-bwd -cs'
bind C-S-right 'word-fwd -cs'
bind C-S-up 'up -l'
bind C-S-down 'down -l'
+bind C-S-pgup 'pgup -l'
+bind C-S-pgdown 'pgdown -l'
+bind C-S-delete 'delete-eol'
+
bind M-S-left 'bol -c'
bind M-S-right 'eol -c'
bind M-S-up 'pgup -c'
bind M-S-down 'pgdown -c'
+bind M-S-delete 'delete-eol'
+bind C-M-S-left 'bol -c'
+bind C-M-S-right 'eol -c'
bind C-M-S-up 'pgup -l'
bind C-M-S-down 'pgdown -l'
-bind C-S-pgup 'pgup -l'
-bind C-S-pgdown 'pgdown -l'
+bind C-M-S-pgup 'pgup -l'
+bind C-M-S-pgdown 'pgdown -l'
+bind C-M-S-delete 'delete-eol'
# Either of these 2 may be equivalent to Backspace, depending on the
# terminal, so they're both bound to erase by default for portability.
diff --git a/mk/build.mk b/mk/build.mk
index 293952a..5106d53 100644
--- a/mk/build.mk
+++ b/mk/build.mk
@@ -2,7 +2,7 @@ CC ?= gcc
CFLAGS ?= -O2
LDFLAGS ?=
AWK = awk
-VERSION = 1.9
+VERSION = 1.9.1
WARNINGS = \
-Wall -Wextra -Wformat -Wformat-security \
diff --git a/mk/version.sh b/mk/version.sh
index 8eb0ec7..766230c 100755
--- a/mk/version.sh
+++ b/mk/version.sh
@@ -7,9 +7,9 @@ export VPREFIX="$1"
# These values are filled automatically for git-archive(1) tarballs.
# See: "export-subst" in gitattributes(5).
-distinfo_commit_full='966ba93ec1b38da4e7ee97b7207d55bcbd01e84e'
-distinfo_commit_short='966ba93e'
-distinfo_author_date='2019-09-29 17:37:07 +0200'
+distinfo_commit_full='cae7c45ea5a563c022001a54d1eee71c268f62b4'
+distinfo_commit_short='cae7c45e'
+distinfo_author_date='2019-09-29 16:51:55 +0100'
if expr "$distinfo_commit_short" : '[0-9a-f]\{7,40\}$' >/dev/null; then
echo "${VPREFIX}-g${distinfo_commit_short}-dist"
exit 0
diff --git a/src/screen-tabbar.c b/src/screen-tabbar.c
index bf93342..dde6043 100644
--- a/src/screen-tabbar.c
+++ b/src/screen-tabbar.c
@@ -23,7 +23,7 @@ static void update_first_tab_idx(Window *win)
{
size_t max_first_idx = win->views.count;
for (size_t w = 0; max_first_idx > 0; max_first_idx--) {
- View *v = win->views.ptrs[max_first_idx - 1];
+ const View *v = win->views.ptrs[max_first_idx - 1];
w += v->tt_truncated_width;
if (w > win->w) {
break;
@@ -32,7 +32,7 @@ static void update_first_tab_idx(Window *win)
size_t min_first_idx = win->views.count;
for (size_t w = 0; min_first_idx > 0; min_first_idx--) {
- View *v = win->views.ptrs[min_first_idx - 1];
+ const View *v = win->views.ptrs[min_first_idx - 1];
if (w || v == win->view) {
w += v->tt_truncated_width;
}
@@ -54,7 +54,6 @@ static void calculate_tabbar(Window *win)
int total_w = 0;
for (size_t i = 0, n = win->views.count; i < n; i++) {
View *v = win->views.ptrs[i];
-
if (v == win->view) {
// Make sure current tab is visible
if (win->first_tab_idx > i) {
@@ -77,7 +76,6 @@ static void calculate_tabbar(Window *win)
for (size_t i = 0, n = win->views.count; i < n; i++) {
View *v = win->views.ptrs[i];
int truncated_w = 20;
-
if (v->tt_width > truncated_w) {
v->tt_truncated_width = truncated_w;
total_w += truncated_w;
@@ -105,13 +103,11 @@ static void calculate_tabbar(Window *win)
for (size_t i = 0, n = win->views.count; i < n; i++) {
View *v = win->views.ptrs[i];
int add = v->tt_width - v->tt_truncated_width;
- int avail;
-
if (add == 0) {
continue;
}
- avail = extra_avg;
+ int avail = extra_avg;
if (extra_mod) {
// This is needed for equal divide
if (extra_avg == 0) {
@@ -137,7 +133,6 @@ static void print_horizontal_tab_title(const View *v, size_t idx)
{
int skip = v->tt_width - v->tt_truncated_width;
const char *filename = buffer_filename(v->buffer);
-
if (skip > 0) {
filename += u_skip_chars(filename, &skip);
}
@@ -176,7 +171,7 @@ static void print_horizontal_tabbar(Window *win)
calculate_tabbar(win);
size_t i;
for (i = win->first_tab_idx; i < win->views.count; i++) {
- View *v = win->views.ptrs[i];
+ const View *v = win->views.ptrs[i];
if (obuf.x + v->tt_truncated_width > win->w) {
break;
}
@@ -201,7 +196,6 @@ static void print_vertical_tab_title(const View *v, int idx, int width)
const char *filename = orig_filename;
unsigned int max = editor.options.tab_bar_max_components;
char buf[16];
- int skip;
xsnprintf (
buf,
@@ -234,7 +228,7 @@ static void print_vertical_tab_title(const View *v, int idx, int width)
filename += i;
}
} else {
- skip = strlen(buf) + u_str_width(filename) - width + 1;
+ int skip = strlen(buf) + u_str_width(filename) - width + 1;
if (skip > 0) {
filename += u_skip_chars(filename, &skip);
}
diff --git a/src/screen.h b/src/screen.h
index 252444e..c3fec86 100644
--- a/src/screen.h
+++ b/src/screen.h
@@ -8,20 +8,28 @@
#include "view.h"
#include "window.h"
+// screen.c
+void update_term_title(const Buffer *b);
+void update_separators(void);
+void update_window_sizes(void);
+void update_line_numbers(Window *win, bool force);
+void update_screen_size(void);
void set_color(const TermColor *color);
void set_builtin_color(enum builtin_color c);
void mask_color(TermColor *color, const TermColor *over);
-void print_tabbar(Window *w);
+// screen-cmdline.c
+void update_command_line(void);
size_t print_command(char prefix);
void show_message(const char *msg, bool is_error);
-void update_command_line(void);
-void update_term_title(const Buffer *b);
-void update_range(const View *v, long y1, long y2);
-void update_separators(void);
+
+// screen-tabbar.c
+void print_tabbar(Window *w);
+
+// screen-status.c
void update_status_line(const Window *win);
-void update_window_sizes(void);
-void update_line_numbers(Window *win, bool force);
-void update_screen_size(void);
+
+// screen-view.c
+void update_range(const View *v, long y1, long y2);
#endif