summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control22
-rw-r--r--debian/copyright17
-rw-r--r--debian/docs2
-rw-r--r--debian/dtrx.1106
-rw-r--r--debian/manpages1
-rwxr-xr-xdebian/rules31
-rw-r--r--debian/watch2
9 files changed, 187 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..3ddb306
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+dtrx (6.4-1) unstable; urgency=low
+
+ * Initial release. (Closes: #491288)
+
+ -- Miguelangel Jose Freitas Loreto <miguelangel.freitas@gmail.com> Mon, 09 Feb 2009 13:17:13 -0430
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..20131c8
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,22 @@
+Source: dtrx
+Section: utils
+Priority: optional
+Maintainer: Miguelangel Jose Freitas Loreto <miguelangel.freitas@gmail.com>
+Build-Depends: debhelper (>= 7), python (>= 2.4 )
+Build-Depends-Indep: python-syck, python-central, python-support, bzip2, unzip, cpio, rpm, binutils, p7zip-full, cabextract, unshield, lzma
+Standards-Version: 3.8.0
+Homepage: http://brettcsmith.org/2007/dtrx/
+XS-Python-Version: >= 2.4
+
+Package: dtrx
+Architecture: all
+Depends: python (${python:Versions}), ${python:Depends}, bzip2, unzip, cpio, rpm, binutils, p7zip-full, cabextract, unshield, lzma, ${misc:Depends}
+XB-Python-Version: ${python:Versions}
+Description: intelligently extract multiple archive types
+ dtrx is basically the same as tar -zxf or tar -xjf except you don't have
+ to remember the flags for each file. But there's more to it than that.
+ You know those really annoying files that don't put everything in a
+ dedicated directory, and have the permissions all wrong? dtrx takes care
+ of all those problems for you, too. dtrx is simple and powerful. Just
+ use the same command for all your archive files, and they'll never
+ frustrate you again.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..2cf153f
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,17 @@
+Format-Specification: http://wiki.debian.org/Proposals/CopyrightFormat?action=recall&rev=196
+Upstream-Name: dtrx: Intelligent archive extraction
+Upstream-Maintainer: Brett Smith <brettcsmith@brettcsmith.org>
+Upstream-Source: http://brettcsmith.org/2007/dtrx/
+
+Files: *
+Copyright: Copyright 2006, 2007, 2008 Brett Smith <brettcsmith@brettcsmith.org>
+ Copyright 2008 Peter Kelemen <Peter.Kelemen@gmail.com>
+License: GPL-3+
+ On Debian GNU systems, the complete text of GNU General Public License
+ (GPL) version 3 can be found at "/usr/share/common-licenses/GPL-3".
+
+Files: debian/*
+Copyright: Copyright (C) 2009, Miguelangel Jose Freitas Loreto <miguelangel.freitas@gmail.com>
+License: GPL-2+
+ On Debian GNU systems, the complete text of GNU General Public License
+ (GPL) version 2 can be found at "/usr/share/common-licenses/GPL-2".
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..50bd824
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,2 @@
+NEWS
+README
diff --git a/debian/dtrx.1 b/debian/dtrx.1
new file mode 100644
index 0000000..b7bb9ba
--- /dev/null
+++ b/debian/dtrx.1
@@ -0,0 +1,106 @@
+.TH "DTRX" "" "Version 6.4" "" ""
+.SH "NAME"
+dtrx - Intelligent archive extraction
+.SH "SYNOPSIS"
+.B dtrx [ " -ltmrnofvq " ]
+.I archive [ archive ] ...
+.SH "DESCRIPTION"
+dtrx stands for Do The Right Extraction. It's a tool for Unix-like systems that takes all the hassle out of extracting archives. Here's an example of how you use it:
+.P
+.RS
+.B dtrx linux-2.6.10.tar.bz2
+.RE
+.P
+That's basically the same thing as:
+.P
+.RS
+.B tar -jxf linux-2.6.10.tar.bz2
+.RE
+.P
+But there's more to it than that. You know those really annoying files that don't put everything in a dedicated directory, and have the permissions all wrong?
+.P
+.PD 0.4
+.RS
+.B tar -zvxf random-tarball.tar.gz
+.P
+.B foo
+.P
+.B bar
+.P
+.B data/
+.P
+.B data/text
+.P
+.B cd data/
+.P
+.B cd: permission denied: data
+.P
+.RE
+.PD
+.P
+dtrx takes care of all those problems for you, too:
+.P
+.PD 0.4
+.RS
+.B dtrx random-tarball.tar.gz
+.P
+.B cd random-tarball/data
+.P
+.B cat text
+.RE
+.PD
+.P
+This all works properly.
+.P
+dtrx is simple and powerful. Just use the same command for all your archive files, and they'll never frustrate you again.
+.SH "OPTIONS"
+.TP
+.B -r, --recursive
+With this option, dtrx will search inside the archives you specify to see if any of the contents are themselves archives, and extract those as well.
+.TP
+.B --one, --one-entry
+Normally, if an archive only contains one file or directory with a name that doesn't match the archive's, dtrx will ask you how to handle it. With this option, you can specify ahead of time what should happen. Possible values are:
+.IP
+.I inside:
+Extract the file/directory inside another directory named after the archive. This is the default.
+.IP
+.I rename:
+Extract the file/directory in the current directory, and then rename it to match the name of the archive.
+.IP
+.I here:
+Extract the file/directory in the current directory.
+.TP
+.B -o, --overwrite
+Normally, dtrx will avoid extracting into a directory that already exists, and instead try to find an alternative name to use. If this option is listed, dtrx will use the default directory name no matter what.
+.TP
+.B -f, --flat
+Extract all archive contents into the current directory, instead of their own dedicated directory. This is handy if you have multiple archive files which all need to be extracted into the same directory structure. Note that existing files may be overwritten with this option.
+.TP
+.B -n, --noninteractive
+dtrx will normally ask the user how to handle certain corner cases, such as how to handle an archive that only contains one file. This option suppresses those questions; dtrx will instead use sane, conservative defaults.
+.TP
+.B -l, -t, --list, --table
+Don't extract the archives; just list their contents on standard output.
+.TP
+.B -m, --metadata
+Extract the metadata from .deb and .gem archives, instead of their normal contents.
+.TP
+.B -q, --quiet
+Suppress warning messages. Listing this option twice will cause dtrx to be silent.
+.TP
+.B -v, --verbose
+Show the files that are being extracted. Listing this option twice will cause dtrx to print debugging information.
+.TP
+.B --help
+Display basic help.
+.TP
+.B --version
+Display dtrx's version, copyright, and license information.
+.SH "COPYRIGHT"
+Copyright 2006, 2007, 2008 Brett Smith <brettcsmith@brettcsmith.org>
+.P
+Copyright 2008 Peter Kelemen <Peter.Kelemen@gmail.com>
+.P
+This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 3 of the License, or (at your option) any later version.
+.P
+This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.s
diff --git a/debian/manpages b/debian/manpages
new file mode 100644
index 0000000..78684c8
--- /dev/null
+++ b/debian/manpages
@@ -0,0 +1 @@
+debian/dtrx.1
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1ef510d
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+#export DH_VERBOSE=1
+
+build: build-indep
+
+build-indep:
+ dh build --before auto_build
+ /usr/bin/python setup.py build
+ /usr/bin/python tests/compare.py
+ dh build --after auto_build
+ touch $@
+
+clean:
+ dh clean --with python_central
+ rm -rf $(CURDIR)/tests/testscript.sh $(CURDIR)/tests/unreadable-file.*
+ /usr/bin/python setup.py clean
+
+install: build
+ dh install --with python_central --before auto_install
+ /usr/bin/python setup.py install --root $(CURDIR)/debian/dtrx
+ dh install --with python_central --after auto_install
+
+binary: binary-arch binary-indep
+
+binary-arch:
+
+binary-indep: build install
+ dh binary-indep --with python_central
+
+.PHONY: build clean binary-arch binary-indep binary install
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..be2898a
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,2 @@
+version=3
+http://brettcsmith.org/2007/dtrx/dtrx-(.*)\.tar\.gz