summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules37
1 files changed, 6 insertions, 31 deletions
diff --git a/debian/rules b/debian/rules
index de9c241..851c7d0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,35 +1,10 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-#export DH_VERBOSE=1
+#! /usr/bin/make -f
--include /usr/share/python/python.mk
+#export DH_VERBOSE = 1
-build: build-indep
+%:
+ dh $@ --with python2
-build-indep:
- dh build --before auto_build
- /usr/bin/python setup.py build
- /usr/bin/python tests/compare.py
- dh build --after auto_build
+override_dh_auto_build:
+ dh_auto_build
rst2man -q README debian/dtrx.1
- touch $@
-
-clean:
- dh clean --with python2
- rm -rf $(CURDIR)/tests/testscript.sh $(CURDIR)/tests/unreadable-file.*
- /usr/bin/python setup.py clean
- rm -f debian/dtrx.1 build-indep
-
-install: build
- dh install --with python2 --before auto_install
- /usr/bin/python setup.py install --root $(CURDIR)/debian/dtrx $(py_setup_install_args)
- dh install --with python2 --after auto_install
-
-binary: binary-arch binary-indep
-
-binary-arch:
-
-binary-indep: build install
- dh binary-indep --with python2
-
-.PHONY: build clean binary-arch binary-indep binary install