summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 1ef510d..110c9ea 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,8 @@
# -*- makefile -*-
#export DH_VERBOSE=1
+-include /usr/share/python/python.mk
+
build: build-indep
build-indep:
@@ -9,16 +11,18 @@ build-indep:
/usr/bin/python setup.py build
/usr/bin/python tests/compare.py
dh build --after auto_build
+ rst2man -q README debian/dtrx.1
touch $@
clean:
dh clean --with python_central
rm -rf $(CURDIR)/tests/testscript.sh $(CURDIR)/tests/unreadable-file.*
/usr/bin/python setup.py clean
+ rm -f debian/dtrx.1 build-indep
install: build
dh install --with python_central --before auto_install
- /usr/bin/python setup.py install --root $(CURDIR)/debian/dtrx
+ /usr/bin/python setup.py install --root $(CURDIR)/debian/dtrx $(py_setup_install_args)
dh install --with python_central --after auto_install
binary: binary-arch binary-indep