summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control9
-rwxr-xr-xdebian/rules8
3 files changed, 16 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index a14a75c..ba9089e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+dtrx (6.6-1.2) unstable; urgency=low
+
+ * Non-maintainer upload.
+ * Convert to dh_python2 (Closes: #616796).
+ * Drop python (${python:Versions}) dependency (Closes: #673068).
+
+ -- Luca Falavigna <dktrkranz@debian.org> Mon, 27 May 2013 09:41:09 +0200
+
dtrx (6.6-1.1) unstable; urgency=low
* Non-maintainer upload.
diff --git a/debian/control b/debian/control
index c5c40c9..9f7381c 100644
--- a/debian/control
+++ b/debian/control
@@ -2,16 +2,15 @@ Source: dtrx
Section: utils
Priority: optional
Maintainer: Miguelangel Jose Freitas Loreto <miguelangel.freitas@gmail.com>
-Build-Depends: debhelper (>= 7), python (>= 2.4 )
-Build-Depends-Indep: python-yaml, python-central, python-support, bzip2, unzip, cpio, rpm, binutils, p7zip-full, cabextract, unshield, lzma, python-docutils (>= 0.6), xz-utils
+Build-Depends: debhelper (>= 7), python (>= 2.6.6-3~)
+Build-Depends-Indep: python-yaml, bzip2, unzip, cpio, rpm, binutils, p7zip-full, cabextract, unshield, lzma, python-docutils (>= 0.6), xz-utils
Standards-Version: 3.8.4
Homepage: http://brettcsmith.org/2007/dtrx/
-XS-Python-Version: >= 2.4
+X-Python-Version: >= 2.4
Package: dtrx
Architecture: all
-Depends: python (${python:Versions}), ${python:Depends}, bzip2, unzip, cpio, rpm, binutils, p7zip-full, cabextract, unshield, lzma, xz-utils, ${misc:Depends}
-XB-Python-Version: ${python:Versions}
+Depends: ${python:Depends}, bzip2, unzip, cpio, rpm, binutils, p7zip-full, cabextract, unshield, lzma, xz-utils, ${misc:Depends}
Description: intelligently extract multiple archive types
dtrx is basically the same as tar -zxf or tar -xjf except you don't have
to remember the flags for each file. But there's more to it than that.
diff --git a/debian/rules b/debian/rules
index 110c9ea..de9c241 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,21 +15,21 @@ build-indep:
touch $@
clean:
- dh clean --with python_central
+ dh clean --with python2
rm -rf $(CURDIR)/tests/testscript.sh $(CURDIR)/tests/unreadable-file.*
/usr/bin/python setup.py clean
rm -f debian/dtrx.1 build-indep
install: build
- dh install --with python_central --before auto_install
+ dh install --with python2 --before auto_install
/usr/bin/python setup.py install --root $(CURDIR)/debian/dtrx $(py_setup_install_args)
- dh install --with python_central --after auto_install
+ dh install --with python2 --after auto_install
binary: binary-arch binary-indep
binary-arch:
binary-indep: build install
- dh binary-indep --with python_central
+ dh binary-indep --with python2
.PHONY: build clean binary-arch binary-indep binary install