summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2018-08-18 22:14:11 -0400
committerTheodore Ts'o <tytso@mit.edu>2018-08-18 22:26:58 -0400
commitf0b597444d45d7bfcca9d3d39b6a2bbfb2c3b11b (patch)
treec628119b91798f4cb19cff98db2bcd088a3b1df9 /debian
parente80915ea6e51858bed10eb32a904cf241043f3ab (diff)
debian: fix where docs are installed in the comerr-dev and ss-dev packages
Signed-off-by: Theodore Ts'o <tytso@mit.edu>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules16
1 files changed, 8 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 5449f2bc..41aa202e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -390,24 +390,24 @@ binary-arch: install $(INSTALL_UDEB)
$(INSTALL) -d ${debdir}/libext2fs-dev/usr/share/doc/libext2fs/html-info/
$(INSTALL) -p -m 0644 ${stdbuilddir}/doc/*.html \
${debdir}/libext2fs-dev/usr/share/doc/libext2fs/html-info/
- $(INSTALL) -d ${debdir}/comerr-dev/usr/share/doc/libcom-err${COMERR_SOVERSION}/html-info/
+ $(INSTALL) -d ${debdir}/comerr-dev/usr/share/doc/comerr-dev/html-info/
$(INSTALL) -p -m 0644 ${stdbuilddir}/lib/et/*.html \
- ${debdir}/comerr-dev/usr/share/doc/libcom-err${COMERR_SOVERSION}/html-info/
+ ${debdir}/comerr-dev/usr/share/doc/comerr-dev/html-info/
# texinfo docs
- mkdir -p ${debdir}/comerr-dev/usr/share/doc/libcom-err${COMERR_SOVERSION}
+ mkdir -p ${debdir}/comerr-dev/usr/share/doc/comerr-dev
$(INSTALL) -p -m 0644 ${topdir}/doc/libext2fs.texinfo \
${debdir}/libext2fs-dev/usr/share/doc/libext2fs/libext2fs.texi
$(INSTALL) -p -m 0644 ${topdir}/lib/et/com_err.texinfo \
- ${debdir}/comerr-dev/usr/share/doc/libcom-err${COMERR_SOVERSION}/com_err.texi
+ ${debdir}/comerr-dev/usr/share/doc/comerr-dev/com_err.texi
- $(INSTALL) -d ${debdir}/comerr-dev/usr/share/doc/libcom-err${COMERR_SOVERSION}/examples
+ $(INSTALL) -d ${debdir}/comerr-dev/usr/share/doc/comerr-dev/examples
$(INSTALL) -p -m 0644 lib/ss/ss_err.et \
${stdbuilddir}/lib/ext2fs/ext2_err.et \
- ${debdir}/comerr-dev/usr/share/doc/libcom-err${COMERR_SOVERSION}/examples
- $(INSTALL) -d ${debdir}/ss-dev/usr/share/doc/libss${SS_SOVERSION}/examples
+ ${debdir}/comerr-dev/usr/share/doc/comerr-dev/examples
+ $(INSTALL) -d ${debdir}/ss-dev/usr/share/doc/ss-dev/examples
$(INSTALL) -p -m 0644 debugfs/debug_cmds.ct \
- ${debdir}/ss-dev/usr/share/doc/libss${SS_SOVERSION}/examples
+ ${debdir}/ss-dev/usr/share/doc/ss-dev/examples
dh_installinfo -pcomerr-dev ${stdbuilddir}/lib/et/com_err.info
dh_installinfo -plibext2fs-dev ${stdbuilddir}/doc/libext2fs.info