summaryrefslogtreecommitdiff
path: root/ext2ed
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2004-04-03 13:53:46 -0500
committerTheodore Ts'o <tytso@mit.edu>2004-04-03 13:53:46 -0500
commitdd60705665b916c9f67c3bbf86aa6bb620a14ecd (patch)
tree7422ed18d06e7d17f7b71c828cc05b6b9033efa2 /ext2ed
parent9dd97ae37dc664f877296db80e1d6c1ebe33e28b (diff)
Refine the build process to avoid re-running subst all the time on
some generated files, by having subst update the modtime on these files even when the generated file hasn't changed. We do this with generated files that do not have any downstream dependencies.
Diffstat (limited to 'ext2ed')
-rw-r--r--ext2ed/ChangeLog7
-rw-r--r--ext2ed/Makefile.in4
2 files changed, 9 insertions, 2 deletions
diff --git a/ext2ed/ChangeLog b/ext2ed/ChangeLog
index 150871d0..c233a754 100644
--- a/ext2ed/ChangeLog
+++ b/ext2ed/ChangeLog
@@ -1,3 +1,10 @@
+2004-04-03 Theodore Ts'o <tytso@mit.edu>
+
+ * Makefile.in: Update the modtime even if subst doesn't need to
+ update the ext2ed man page and conbfiguration, to avoid
+ always re-running subst, especially since there are no
+ dependencies on these generated files.
+
2004-02-28 Theodore Ts'o <tytso@mit.edu>
* Release of E2fsprogs 1.35
diff --git a/ext2ed/Makefile.in b/ext2ed/Makefile.in
index a581ee3f..610635a0 100644
--- a/ext2ed/Makefile.in
+++ b/ext2ed/Makefile.in
@@ -60,10 +60,10 @@ ext2ed: $(OBJS)
$(CC) $(ALL_LDFLAGS) -o ext2ed $(OBJS) $(LIBS)
ext2ed.8: $(DEP_SUBSTITUTE) $(srcdir)/ext2ed.8.in
- $(SUBSTITUTE) $(srcdir)/ext2ed.8.in ext2ed.8
+ $(SUBSTITUTE_UPTIME) $(srcdir)/ext2ed.8.in ext2ed.8
ext2ed.conf: $(DEP_SUBSTITUTE) $(srcdir)/ext2ed.conf.in
- $(SUBSTITUTE) $(srcdir)/ext2ed.conf.in ext2ed.conf
+ $(SUBSTITUTE_UPTIME) $(srcdir)/ext2ed.conf.in ext2ed.conf
clean:
$(RM) -f ext2ed $(OBJS) $(DOCS) ext2ed.conf ext2ed.8