summaryrefslogtreecommitdiff
path: root/intl
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2014-01-04 20:44:29 -0500
committerTheodore Ts'o <tytso@mit.edu>2014-01-05 22:58:16 -0500
commit6c59a665da13d6a2acbf3fc01a3fb4338fb46a6e (patch)
treed3a1cda19cc2f7f7092fb5e4341ac9080f770cad /intl
parent9a3938918545b831b215b2befc2454f7b1a2dd84 (diff)
configure: fix --with-diet-libc
Newer versions of autoconf pull in AC_PROG_GCC as part of AC_CANONICAL_HOST. So we need check for WITH_DIET_LIBC earlier in configure.in. Also, e2fsprogs now needs functions which are found in diet libc's compat library. So add support for autoconf's LIBS function, and automatically set libs to include -lcompat. Finally, disable compiling e4defrag by deault if --with-diet-libc is specified because the program has too many glibc dependencies. Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'intl')
-rw-r--r--intl/Makefile.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/intl/Makefile.in b/intl/Makefile.in
index bf24f63f..49989e89 100644
--- a/intl/Makefile.in
+++ b/intl/Makefile.in
@@ -59,6 +59,20 @@ mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
@ifNotGNUmake@ E = @E@
@ifNotGNUmake@ Q = @Q@
+@ifGNUmake@ CHECK=sparse
+@ifGNUmake@ CHECK_OPTS=-Wsparse-all -Wno-transparent-union -Wno-return-void -Wno-undef -Wno-non-pointer-null
+@ifGNUmake@ ifeq ("$(C)", "2")
+@ifGNUmake@ CHECK_CMD=$(CHECK) $(CHECK_OPTS) -Wbitwise -D__CHECK_ENDIAN__
+@ifGNUmake@ else
+@ifGNUmake@ ifeq ("$(C)", "1")
+@ifGNUmake@ CHECK_CMD=$(CHECK) $(CHECK_OPTS)
+@ifGNUmake@ else
+@ifGNUmake@ CHECK_CMD=@true
+@ifGNUmake@ endif
+@ifGNUmake@ endif
+
+@ifNotGNUmake@ CHECK_CMD=@true
+
l = @INTL_LIBTOOL_SUFFIX_PREFIX@
AR = ar