summaryrefslogtreecommitdiff
path: root/intl
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2011-09-18 17:34:37 -0400
committerTheodore Ts'o <tytso@mit.edu>2011-09-18 17:34:37 -0400
commitd1154eb460efe588eaed3d439c1caaca149fa362 (patch)
tree2c7330818b40f9341003bf7cbe1dd5a3f622af0d /intl
parent30295f16a95b873965d1650b24fb6f5b82bde675 (diff)
Shorten compile commands run by the build system
The DEFS line in MCONFIG had gotten so long that it exceeded 4k, and this was starting to cause some tools heartburn. It also made "make V=1" almost useless, since trying to following the individual commands run by make was lost in the noise of all of the defines. So fix this by putting the configure-generated defines in lib/config.h and the directory pathnames to lib/dirpaths.h. In addition, clean up some vestigal defines in configure.in and in the Makefiles to further shorten the cc command lines. Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'intl')
-rw-r--r--intl/Makefile.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/intl/Makefile.in b/intl/Makefile.in
index 47f6f629..9dbc84e9 100644
--- a/intl/Makefile.in
+++ b/intl/Makefile.in
@@ -73,7 +73,7 @@ DEFS = -DLOCALEDIR=\"$(localedir)\" -DLOCALE_ALIAS_PATH=\"$(aliaspath)\" \
-DENABLE_RELOCATABLE=1 -DIN_LIBRARY -DINSTALLDIR=\"$(libdir)\" -DNO_XMALLOC \
-Dset_relocation_prefix=libintl_set_relocation_prefix \
-Drelocate=libintl_relocate \
--DDEPENDS_ON_LIBICONV=1 @DEFS@
+-DDEPENDS_ON_LIBICONV=1 -DHAVE_CONFIG_H
CPPFLAGS = @CPPFLAGS@
CFLAGS = @CFLAGS@
LDFLAGS = @LDFLAGS@
@@ -252,7 +252,7 @@ ref-del.sed: $(srcdir)/ref-del.sin
$(Q) sed -e '/^#/d' -e 's/@''PACKAGE''@/@PACKAGE@/g' $(srcdir)/ref-del.sin > t-ref-del.sed
$(Q) mv t-ref-del.sed ref-del.sed
-INCLUDES = -I. -I$(srcdir) -I..
+INCLUDES = -I. -I$(srcdir) -I.. -I$(top_builddir)/lib
libgnuintl.h: $(srcdir)/libgnuintl.h.in
$(E) " SED libgnuintl.h "