summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-05-18 00:28:39 +0200
committerLennart Poettering <lennart@poettering.net>2010-05-18 00:28:39 +0200
commit42e39f0b326d27f6392a81a7400f9af7cf0af3ab (patch)
treeadd3721ae2fe419a5f0c5f76246007c8039384d4
parent53f7d807bff9c39e9e565ad2fb20f29b4306af40 (diff)
build-sys: remove vala generated sources only when valac is around
-rw-r--r--Makefile.am10
-rw-r--r--README2
-rw-r--r--configure.ac1
3 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 65ab1339a..e6366dd00 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -335,9 +335,6 @@ units/session/%: units/%.m4 Makefile
$(M4_PROCESS_SESSION)
CLEANFILES = \
- src/systemd-interfaces.c \
- src/systemctl.c \
- src/systemadm.c \
units/systemd-initctl.service \
units/systemd-logger.service \
units/syslog.target \
@@ -350,6 +347,13 @@ CLEANFILES = \
man/systemd.special.7 \
man/systemd.special.html
+if HAVE_VALAC
+CLEANFILES += \
+ src/systemd-interfaces.c \
+ src/systemctl.c \
+ src/systemadm.c
+endif
+
if HAVE_XSLTPROC
XSLTPROC_PROCESS_MAN = \
$(AM_V_GEN)$(MKDIR_P) $(dir $@) && \
diff --git a/README b/README
index 57373c3c7..492e37454 100644
--- a/README
+++ b/README
@@ -27,7 +27,7 @@ AUTHOR:
Lennart Poettering with major support from Kay Sievers
REQUIREMENTS:
- Linux kernel >= 2.6.30 (with autofs4, devtmpfs and the debug cgroup controller)
+ Linux kernel >= 2.6.30 (with autofs4, devtmpfs, cgroups)
libudev >= 151
libcgroup >= 0.35
vala >= 0.80
diff --git a/configure.ac b/configure.ac
index 20024e68a..5e505365d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,6 +123,7 @@ AM_CONDITIONAL(HAVE_GTK, [test "$have_gtk" = "yes"])
AM_PROG_VALAC([0.8])
AC_SUBST(VAPIDIR)
+AM_CONDITIONAL(HAVE_VALAC, test x"$VALAC" != x)
AC_PATH_PROG([XSLTPROC], [xsltproc])
AM_CONDITIONAL(HAVE_XSLTPROC, test x"$XSLTPROC" != x)