summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-03-04 12:57:12 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-03-04 13:06:43 -0500
commit4fe52119233710903f9b52e1e608889fe5036837 (patch)
tree82db2af6261ff6d9fe97826193a3e9ae1001f101
parent8ab85e2d2d9bf049e8f9a4c598ba32ff3cf19b6d (diff)
build-sys: do not install logind manpages when disabled
The condition was wrong: HAVE_PAM -> ENABLE_LOGIND.
-rw-r--r--Makefile-man.am13
-rw-r--r--man/logind.conf.xml2
-rw-r--r--man/systemd-logind.service.xml2
3 files changed, 11 insertions, 6 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index d02fff05e..58271d28d 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -322,6 +322,15 @@ MANPAGES_ALIAS += \
man/systemd-localed.8: man/systemd-localed.service.8
endif
+if ENABLE_LOGIND
+MANPAGES += \
+ man/logind.conf.5 \
+ man/systemd-logind.service.8
+MANPAGES_ALIAS += \
+ man/systemd-logind.8
+man/systemd-logind.8: man/systemd-logind.service.8
+endif
+
if ENABLE_QUOTACHECK
MANPAGES += \
man/systemd-quotacheck.service.8
@@ -414,7 +423,6 @@ endif
if HAVE_PAM
MANPAGES += \
man/loginctl.1 \
- man/logind.conf.5 \
man/sd-login.3 \
man/sd_get_seats.3 \
man/sd_login_monitor_new.3 \
@@ -422,7 +430,6 @@ MANPAGES += \
man/sd_seat_get_active.3 \
man/sd_session_is_active.3 \
man/sd_uid_get_state.3 \
- man/systemd-logind.service.8 \
man/systemd-user-sessions.service.8
MANPAGES_ALIAS += \
man/sd_get_sessions.3 \
@@ -446,7 +453,6 @@ MANPAGES_ALIAS += \
man/sd_uid_get_seats.3 \
man/sd_uid_get_sessions.3 \
man/sd_uid_is_on_seat.3 \
- man/systemd-logind.8 \
man/systemd-user-sessions.8
man/sd_get_sessions.3: man/sd_get_seats.3
man/sd_get_uids.3: man/sd_get_seats.3
@@ -469,7 +475,6 @@ man/sd_session_get_uid.3: man/sd_session_is_active.3
man/sd_uid_get_seats.3: man/sd_uid_get_state.3
man/sd_uid_get_sessions.3: man/sd_uid_get_state.3
man/sd_uid_is_on_seat.3: man/sd_uid_get_state.3
-man/systemd-logind.8: man/systemd-logind.service.8
man/systemd-user-sessions.8: man/systemd-user-sessions.service.8
endif
diff --git a/man/logind.conf.xml b/man/logind.conf.xml
index 362a4f610..b0dd20f2a 100644
--- a/man/logind.conf.xml
+++ b/man/logind.conf.xml
@@ -22,7 +22,7 @@
along with systemd; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="logind.conf" conditional='HAVE_PAM'>
+<refentry id="logind.conf" conditional='ENABLE_LOGIND'>
<refentryinfo>
<title>logind.conf</title>
<productname>systemd</productname>
diff --git a/man/systemd-logind.service.xml b/man/systemd-logind.service.xml
index 523a63b4f..09bcfac43 100644
--- a/man/systemd-logind.service.xml
+++ b/man/systemd-logind.service.xml
@@ -21,7 +21,7 @@
along with systemd; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="systemd-logind.service" conditional='HAVE_PAM'>
+<refentry id="systemd-logind.service" conditional='ENABLE_LOGIND'>
<refentryinfo>
<title>systemd-logind.service</title>