summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-03-29 13:09:52 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-03-29 20:30:21 -0400
commitaa0bb9c2c4500696530957f715e097c00bd9e8c4 (patch)
treed563d3977ae3af8df94fb0c0dfa98426ef2c41e2
parenta696dbef3474f3586b0f189245804b355a700795 (diff)
Revert "build-sys: substitute strings in systemd.unit(5)"
This reverts commits c78ab91132aab9193f3c17a9a206f8825ff4be84 and 185c3be03cec26023acc11b49553753aa7330a1d. It is simpler to just use includes...
-rw-r--r--Makefile-man.am3
-rw-r--r--Makefile.am2
-rw-r--r--make-man-rules.py20
-rw-r--r--man/.gitignore1
-rw-r--r--man/systemd.unit.xml (renamed from man/systemd.unit.xml.in)0
5 files changed, 5 insertions, 21 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index 6e6313575..bc2f9b469 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -896,6 +896,3 @@ MANPAGES_ALIAS += \
endif
-
-CLEANFILES += \
- man/systemd.unit.xml
diff --git a/Makefile.am b/Makefile.am
index 86ad16888..0d572cd7b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -558,7 +558,7 @@ CLEANFILES += \
NON_INDEX_XML_FILES = $(filter-out man/systemd.index.xml,$(XML_FILES))
-XML_GLOB = $(wildcard $(top_srcdir)/man/*.xml $(top_srcdir)/man/*.xml.in $(top_builddir)/man/*.xml)
+XML_GLOB = $(wildcard $(top_srcdir)/man/*.xml)
update-man-list: make-man-rules.py $(XML_GLOB)
$(AM_V_GEN)$(PYTHON) $^ > $(top_srcdir)/Makefile-man.tmp
$(AM_V_at)mv $(top_srcdir)/Makefile-man.tmp $(top_srcdir)/Makefile-man.am
diff --git a/make-man-rules.py b/make-man-rules.py
index 9f53b55bb..46a586374 100644
--- a/make-man-rules.py
+++ b/make-man-rules.py
@@ -21,7 +21,6 @@ from __future__ import print_function
import xml.etree.ElementTree as tree
import collections
import sys
-import os
SECTION = '''\
MANPAGES += \\
@@ -46,12 +45,6 @@ HEADER = '''\
'''
-CLEANFILES = '''\
-
-CLEANFILES += \\
- {cleanfiles}
-'''
-
HTML_ALIAS_RULE = '''\
{}.html: {}.html
$(html-alias)
@@ -89,7 +82,7 @@ def create_rules(*xml_files):
def mjoin(files):
return ' \\\n\t'.join(sorted(files) or '#')
-def make_makefile(rules, cleanfiles):
+def make_makefile(rules):
return HEADER + '\n'.join(
(CONDITIONAL if conditional else SECTION).format(
manpages=mjoin(set(rulegroup.values())),
@@ -101,13 +94,8 @@ def make_makefile(rules, cleanfiles):
for k,v in sorted(rulegroup.items())
if k != v),
conditional=conditional)
- for conditional,rulegroup in sorted(rules.items())) + \
- CLEANFILES.format(cleanfiles=mjoin(cleanfiles))
+ for conditional,rulegroup in sorted(rules.items()))
if __name__ == '__main__':
- sources = set(sys.argv[1:])
- basenames = [os.path.basename(source) for source in sources]
- spares = set([source for source in sources
- if os.path.basename(source) + '.in' in basenames])
- rules = create_rules(*(sources - spares))
- print(make_makefile(rules, spares), end='')
+ rules = create_rules(*sys.argv[1:])
+ print(make_makefile(rules), end='')
diff --git a/man/.gitignore b/man/.gitignore
index fcf4dabd2..3798c75f1 100644
--- a/man/.gitignore
+++ b/man/.gitignore
@@ -1,5 +1,4 @@
/systemd.directives.xml
/systemd.index.xml
-/systemd.unit.xml
/*.[13578]
/python-systemd/
diff --git a/man/systemd.unit.xml.in b/man/systemd.unit.xml
index 2196e73bb..2196e73bb 100644
--- a/man/systemd.unit.xml.in
+++ b/man/systemd.unit.xml