summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2014-08-30 11:34:20 +0200
committerKay Sievers <kay@vrfy.org>2014-08-30 11:34:20 +0200
commitbe2ea723b1d023b3d385d3b791ee4607cbfb20ca (patch)
tree4376a79b88812755c6e922e653f74f77fef0fce7
parentec15977a3cd82eff6c94bb13db72195f7cd512e8 (diff)
udev: remove userspace firmware loading support
-rw-r--r--Makefile.am12
-rw-r--r--README9
-rw-r--r--TODO1
-rw-r--r--configure.ac20
-rw-r--r--src/udev/udev-builtin-firmware.c154
-rw-r--r--src/udev/udev-builtin.c3
-rw-r--r--src/udev/udev.h6
-rw-r--r--src/udev/udevd.c13
8 files changed, 4 insertions, 214 deletions
diff --git a/Makefile.am b/Makefile.am
index 1facb8da4..b37ed4155 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3284,18 +3284,6 @@ libudev_core_la_LIBADD = \
$(BLKID_LIBS) \
$(KMOD_LIBS)
-libudev_core_la_CPPFLAGS = \
- $(AM_CPPFLAGS) \
- -DFIRMWARE_PATH="$(FIRMWARE_PATH)"
-
-if ENABLE_FIRMWARE
-libudev_core_la_SOURCES += \
- src/udev/udev-builtin-firmware.c
-
-dist_udevrules_DATA += \
- rules/50-firmware.rules
-endif
-
if HAVE_KMOD
libudev_core_la_SOURCES += \
src/udev/udev-builtin-kmod.c
diff --git a/README b/README
index d47ea4567..e0edd41f1 100644
--- a/README
+++ b/README
@@ -37,8 +37,7 @@ LICENSE:
- except src/udev/* which is (currently still) GPLv2, GPLv2+
REQUIREMENTS:
- Linux kernel >= 3.0
- Linux kernel >= 3.3 for loop device partition support features with nspawn
+ Linux kernel >= 3.7
Linux kernel >= 3.8 for Smack support
Kernel Config Options:
@@ -53,14 +52,14 @@ REQUIREMENTS:
CONFIG_PROC_FS
CONFIG_FHANDLE (libudev, mount and bind mount handling)
- Udev will fail to work with the legacy layout:
+ udev will fail to work with the legacy sysfs layout:
CONFIG_SYSFS_DEPRECATED=n
Legacy hotplug slows down the system and confuses udev:
CONFIG_UEVENT_HELPER_PATH=""
- Userspace firmware loading is deprecated, will go away, and
- sometimes causes problems:
+ Userspace firmware loading is not supported and should
+ be disabled in the kernel:
CONFIG_FW_LOADER_USER_HELPER=n
Some udev rules and virtualization detection relies on it:
diff --git a/TODO b/TODO
index 59555e6cb..221b39f1a 100644
--- a/TODO
+++ b/TODO
@@ -547,7 +547,6 @@ Features:
* ExecOnFailure=/usr/bin/foo
* udev:
- - remove src/udev/udev-builtin-firmware.c (CONFIG_FW_LOADER_USER_HELPER=n)
- move to LGPL
- kill scsi_id
- add trigger --subsystem-match=usb/usb_device device
diff --git a/configure.ac b/configure.ac
index a25ad3f2e..543828c40 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1154,25 +1154,6 @@ fi
AM_CONDITIONAL(HAVE_MYHOSTNAME, [test "$have_myhostname" = "yes"])
# ------------------------------------------------------------------------------
-AC_ARG_WITH(firmware-path,
- AS_HELP_STRING([--with-firmware-path=DIR[[[:DIR[...]]]]],
- [Firmware search path (default="")]),
- [], [with_firmware_path=""])
-OLD_IFS=$IFS
-IFS=:
-for i in $with_firmware_path; do
- if test "x${FIRMWARE_PATH}" = "x"; then
- FIRMWARE_PATH="\\\"${i}/\\\""
- else
- FIRMWARE_PATH="${FIRMWARE_PATH}, \\\"${i}/\\\""
- fi
-done
-IFS=$OLD_IFS
-AC_SUBST(FIRMWARE_PATH)
-AS_IF([test "x${FIRMWARE_PATH}" != "x"], [ AC_DEFINE(HAVE_FIRMWARE, 1, [Define if FIRMWARE is available]) ])
-AM_CONDITIONAL(ENABLE_FIRMWARE, [test "x${FIRMWARE_PATH}" != "x"])
-
-# ------------------------------------------------------------------------------
AC_ARG_ENABLE([gudev],
AS_HELP_STRING([--disable-gudev], [disable Gobject libudev support @<:@default=enabled@:>@]),
[], [enable_gudev=yes])
@@ -1409,7 +1390,6 @@ AC_MSG_RESULT([
Build Python: ${PYTHON}
Installation Python: ${PYTHON_BINARY}
sphinx binary: ${SPHINX_BUILD}
- firmware path: ${FIRMWARE_PATH}
PAM modules dir: ${with_pamlibdir}
PAM configuration dir: ${with_pamconfdir}
D-Bus policy dir: ${with_dbuspolicydir}
diff --git a/src/udev/udev-builtin-firmware.c b/src/udev/udev-builtin-firmware.c
deleted file mode 100644
index bd8c2fb96..000000000
--- a/src/udev/udev-builtin-firmware.c
+++ /dev/null
@@ -1,154 +0,0 @@
-/*
- * firmware - Kernel firmware loader
- *
- * Copyright (C) 2009 Piter Punk <piterpunk@slackware.com>
- * Copyright (C) 2009-2011 Kay Sievers <kay@vrfy.org>
- *
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License as
- * published by the Free Software Foundation; either version 2 of the
- * License, or (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful, but
- * WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- * General Public License for more details:*
- */
-
-#include <unistd.h>
-#include <stdlib.h>
-#include <string.h>
-#include <stdio.h>
-#include <getopt.h>
-#include <errno.h>
-#include <stdbool.h>
-#include <sys/utsname.h>
-#include <sys/stat.h>
-
-#include "udev.h"
-
-static bool set_loading(struct udev *udev, char *loadpath, const char *state) {
- FILE *ldfile;
-
- ldfile = fopen(loadpath, "we");
- if (ldfile == NULL) {
- log_error("error: can not open '%s'", loadpath);
- return false;
- };
- fprintf(ldfile, "%s\n", state);
- fclose(ldfile);
- return true;
-}
-
-static bool copy_firmware(struct udev *udev, const char *source, const char *target, size_t size) {
- char *buf;
- FILE *fsource = NULL, *ftarget = NULL;
- bool ret = false;
-
- buf = malloc(size);
- if (buf == NULL) {
- log_error("No memory available to load firmware file");
- return false;
- }
-
- log_debug("writing '%s' (%zi) to '%s'", source, size, target);
-
- fsource = fopen(source, "re");
- if (fsource == NULL)
- goto exit;
- ftarget = fopen(target, "we");
- if (ftarget == NULL)
- goto exit;
- if (fread(buf, size, 1, fsource) != 1)
- goto exit;
- if (fwrite(buf, size, 1, ftarget) == 1)
- ret = true;
-exit:
- if (ftarget != NULL)
- fclose(ftarget);
- if (fsource != NULL)
- fclose(fsource);
- free(buf);
- return ret;
-}
-
-static int builtin_firmware(struct udev_device *dev, int argc, char *argv[], bool test) {
- struct udev *udev = udev_device_get_udev(dev);
- static const char *searchpath[] = { FIRMWARE_PATH };
- char loadpath[UTIL_PATH_SIZE];
- char datapath[UTIL_PATH_SIZE];
- char fwpath[UTIL_PATH_SIZE];
- const char *firmware;
- FILE *fwfile = NULL;
- struct utsname kernel;
- struct stat statbuf;
- unsigned int i;
- int rc = EXIT_SUCCESS;
-
- firmware = udev_device_get_property_value(dev, "FIRMWARE");
- if (firmware == NULL) {
- log_error("firmware parameter missing");
- rc = EXIT_FAILURE;
- goto exit;
- }
-
- /* lookup firmware file */
- uname(&kernel);
- for (i = 0; i < ELEMENTSOF(searchpath); i++) {
- strscpyl(fwpath, sizeof(fwpath), searchpath[i], kernel.release, "/", firmware, NULL);
- fwfile = fopen(fwpath, "re");
- if (fwfile != NULL)
- break;
-
- strscpyl(fwpath, sizeof(fwpath), searchpath[i], firmware, NULL);
- fwfile = fopen(fwpath, "re");
- if (fwfile != NULL)
- break;
- }
-
- strscpyl(loadpath, sizeof(loadpath), udev_device_get_syspath(dev), "/loading", NULL);
-
- if (fwfile == NULL) {
- log_debug("did not find firmware file '%s'", firmware);
- rc = EXIT_FAILURE;
- /*
- * Do not cancel the request in the initrd, the real root might have
- * the firmware file and the 'coldplug' run in the real root will find
- * this pending request and fulfill or cancel it.
- * */
- if (!in_initrd())
- set_loading(udev, loadpath, "-1");
- goto exit;
- }
-
- if (stat(fwpath, &statbuf) < 0 || statbuf.st_size == 0) {
- if (!in_initrd())
- set_loading(udev, loadpath, "-1");
- rc = EXIT_FAILURE;
- goto exit;
- }
-
- if (!set_loading(udev, loadpath, "1"))
- goto exit;
-
- strscpyl(datapath, sizeof(datapath), udev_device_get_syspath(dev), "/data", NULL);
- if (!copy_firmware(udev, fwpath, datapath, statbuf.st_size)) {
- log_error("error sending firmware '%s' to device", firmware);
- set_loading(udev, loadpath, "-1");
- rc = EXIT_FAILURE;
- goto exit;
- };
-
- set_loading(udev, loadpath, "0");
-exit:
- if (fwfile)
- fclose(fwfile);
- return rc;
-}
-
-const struct udev_builtin udev_builtin_firmware = {
- .name = "firmware",
- .cmd = builtin_firmware,
- .help = "kernel firmware loader",
- .run_once = true,
-};
diff --git a/src/udev/udev-builtin.c b/src/udev/udev-builtin.c
index 05a272646..3bcbd6e82 100644
--- a/src/udev/udev-builtin.c
+++ b/src/udev/udev-builtin.c
@@ -34,9 +34,6 @@ static const struct udev_builtin *builtins[] = {
[UDEV_BUILTIN_BLKID] = &udev_builtin_blkid,
#endif
[UDEV_BUILTIN_BTRFS] = &udev_builtin_btrfs,
-#ifdef HAVE_FIRMWARE
- [UDEV_BUILTIN_FIRMWARE] = &udev_builtin_firmware,
-#endif
[UDEV_BUILTIN_HWDB] = &udev_builtin_hwdb,
[UDEV_BUILTIN_INPUT_ID] = &udev_builtin_input_id,
[UDEV_BUILTIN_KEYBOARD] = &udev_builtin_keyboard,
diff --git a/src/udev/udev.h b/src/udev/udev.h
index 4aca70bef..faa8f566c 100644
--- a/src/udev/udev.h
+++ b/src/udev/udev.h
@@ -141,9 +141,6 @@ enum udev_builtin_cmd {
UDEV_BUILTIN_BLKID,
#endif
UDEV_BUILTIN_BTRFS,
-#ifdef HAVE_FIRMWARE
- UDEV_BUILTIN_FIRMWARE,
-#endif
UDEV_BUILTIN_HWDB,
UDEV_BUILTIN_INPUT_ID,
UDEV_BUILTIN_KEYBOARD,
@@ -172,9 +169,6 @@ struct udev_builtin {
extern const struct udev_builtin udev_builtin_blkid;
#endif
extern const struct udev_builtin udev_builtin_btrfs;
-#ifdef HAVE_FIRMWARE
-extern const struct udev_builtin udev_builtin_firmware;
-#endif
extern const struct udev_builtin udev_builtin_hwdb;
extern const struct udev_builtin udev_builtin_input_id;
extern const struct udev_builtin udev_builtin_keyboard;
diff --git a/src/udev/udevd.c b/src/udev/udevd.c
index f882cfb3a..9c2b0d522 100644
--- a/src/udev/udevd.c
+++ b/src/udev/udevd.c
@@ -100,9 +100,6 @@ struct event {
dev_t devnum;
int ifindex;
bool is_block;
-#ifdef HAVE_FIRMWARE
- bool nodelay;
-#endif
};
static inline struct event *node_to_event(struct udev_list_node *node) {
@@ -458,10 +455,6 @@ static int event_queue_insert(struct udev_device *dev) {
event->devnum = udev_device_get_devnum(dev);
event->is_block = streq("block", udev_device_get_subsystem(dev));
event->ifindex = udev_device_get_ifindex(dev);
-#ifdef HAVE_FIRMWARE
- if (streq(udev_device_get_subsystem(dev), "firmware"))
- event->nodelay = true;
-#endif
log_debug("seq %llu queued, '%s' '%s'", udev_device_get_seqnum(dev),
udev_device_get_action(dev), udev_device_get_subsystem(dev));
@@ -538,12 +531,6 @@ static bool is_devpath_busy(struct event *event) {
return true;
}
-#ifdef HAVE_FIRMWARE
- /* allow to bypass the dependency tracking */
- if (event->nodelay)
- continue;
-#endif
-
/* parent device event found */
if (event->devpath[common] == '/') {
event->delaying_seqnum = loop_event->seqnum;