summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorŁukasz Stelmach <l.stelmach@samsung.com>2014-11-26 09:17:50 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-11-27 00:24:52 -0500
commitbedd083aaedb3bbb14ef579a047bf4b4fed56d9b (patch)
tree1b01e4047b16cf1a7b33bd46b138b379a23f43a6
parent7b6288914b3b57e1c33c740eb705c5a6dd2655ca (diff)
build-sys: do not install tmpfiles and sysusers files by default
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index ddd0df137..65bb176bf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2039,7 +2039,6 @@ nodist_tmpfiles_DATA = \
dist_tmpfiles_DATA = \
tmpfiles.d/systemd.conf \
tmpfiles.d/systemd-nologin.conf \
- tmpfiles.d/systemd-remote.conf \
tmpfiles.d/tmp.conf \
tmpfiles.d/x11.conf \
tmpfiles.d/var.conf
@@ -2094,8 +2093,7 @@ SYSINIT_TARGET_WANTS += \
systemd-sysusers.service
dist_sysusers_DATA = \
- sysusers.d/systemd.conf \
- sysusers.d/systemd-remote.conf
+ sysusers.d/systemd.conf
nodist_sysusers_DATA = \
sysusers.d/basic.conf
@@ -3839,6 +3837,16 @@ systemd_journal_remote_CFLAGS = \
systemd_journal_remote_LDADD += \
$(MICROHTTPD_LIBS)
+if ENABLE_SYSUSERS
+dist_sysusers_DATA += \
+ sysusers.d/systemd-remote.conf
+endif
+
+if ENABLE_TMPFILES
+dist_tmpfiles_DATA += \
+ tmpfiles.d/systemd-remote.conf
+endif
+
if HAVE_GNUTLS
systemd_journal_remote_LDADD += \
$(GNUTLS_LIBS)