summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-02-07 09:56:44 +0100
committerSven Eden <yamakuzure@gmx.net>2017-03-14 10:23:13 +0100
commit044519161f469050bbae99d7ef16804688b446ab (patch)
tree8a4589bbd5ef27715fc94229b0af6a1879b2b9fb
parent09e75d32a30c7527df7dace0f80327817cc23bb6 (diff)
PKTTYAGENT make variable
* Makefile.am (PKTTYAGENT): Define as a variable so that users can make PKTTYAGENT=/whatever to select a specific pkttyagent path.
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fb59c77f7..fe421287a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,6 +55,8 @@ zshcompletiondir=@zshcompletiondir@
systemsleepdir=$(pkglibexecdir)/sleep.d
systemshutdowndir=$(pkglibexecdir)/shutdown.d
+PKTTYAGENT=$(bindir)/pkttyagent
+
# Our own, non-special dirs
pkgsysconfdir=$(sysconfdir)/elogind
pkgincludedir=$(includedir)/elogind
@@ -120,7 +122,7 @@ AM_CPPFLAGS = \
-DELOGIND_CGROUP_AGENT_PATH=\"$(rootlibexecdir)/elogind-cgroups-agent\" \
-DROOTPREFIX=\"$(rootprefix)\" \
-DUDEVLIBEXECDIR=\"$(udevlibexecdir)\" \
- -DPOLKIT_AGENT_BINARY_PATH=\"$(bindir)/pkttyagent\" \
+ -DPOLKIT_AGENT_BINARY_PATH=\"$(PKTTYAGENT)\" \
-DSYSTEM_SLEEP_PATH=\"$(systemsleepdir)\" \
-DSYSTEM_SHUTDOWN_PATH=\"$(systemshutdowndir)\" \
-DHALT=\"$(HALT)\" \