summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUmut Tezduyar Lindskog <umut.tezduyar@axis.com>2014-08-05 12:17:09 +0200
committerLennart Poettering <lennart@poettering.net>2014-08-14 01:01:43 +0200
commit12e34d9d58ed4d97e7bdf8c23494c51ee5ec388e (patch)
tree140176eac9856e44e0aa23086dc80f41dbb34dda
parent438ca2bbd4dc1de6193ec61f3c12e19cded7921d (diff)
ldconfig: add configure option to disable
-rw-r--r--Makefile.am16
-rw-r--r--configure.ac5
-rw-r--r--units/ldconfig.service1
3 files changed, 17 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index fa6fd7d54..513c85265 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -490,8 +490,7 @@ dist_systemunit_DATA = \
units/systemd-udevd-control.socket \
units/systemd-udevd-kernel.socket \
units/system-update.target \
- units/initrd-switch-root.target \
- units/ldconfig.service
+ units/initrd-switch-root.target
nodist_systemunit_DATA = \
units/getty@.service \
@@ -919,6 +918,16 @@ libsystemd_label_la_CFLAGS = \
libsystemd_label_la_LIBADD = \
$(SELINUX_LIBS)
+# -----------------------------------------------------------------------------
+
+if ENABLE_LDCONFIG
+dist_systemunit_DATA += \
+ units/ldconfig.service
+
+SYSINIT_TARGET_WANTS += \
+ ldconfig.service
+endif
+
# ------------------------------------------------------------------------------
if HAVE_SECCOMP
@@ -5789,8 +5798,7 @@ endif
SYSINIT_TARGET_WANTS += \
systemd-update-utmp.service \
- systemd-update-done.service \
- ldconfig.service
+ systemd-update-done.service
LOCAL_FS_TARGET_WANTS += \
systemd-remount-fs.service \
diff --git a/configure.ac b/configure.ac
index 6d5536b59..d95a34894 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1182,7 +1182,12 @@ AS_IF([test "x$enable_manpages" != xno], [have_manpages=yes])
AM_CONDITIONAL(ENABLE_MANPAGES, [test "x$have_manpages" = "xyes"])
# ------------------------------------------------------------------------------
+AC_ARG_ENABLE(ldconfig,
+ [AC_HELP_STRING([--disable-ldconfig], [disable ldconfig])],
+ enable_ldconfig=$enableval, enable_ldconfig=yes)
+AM_CONDITIONAL(ENABLE_LDCONFIG, [test x$enable_ldconfig = xyes])
+# ------------------------------------------------------------------------------
# Location of the init scripts as mandated by LSB
SYSTEM_SYSVINIT_PATH=/etc/init.d
SYSTEM_SYSVRCND_PATH=/etc/rc.d
diff --git a/units/ldconfig.service b/units/ldconfig.service
index 09a2b7458..43c145b72 100644
--- a/units/ldconfig.service
+++ b/units/ldconfig.service
@@ -13,7 +13,6 @@ Conflicts=shutdown.target
After=systemd-readahead-collect.service systemd-readahead-replay.service systemd-remount-fs.service
Before=sysinit.target shutdown.target systemd-update-done.service
ConditionNeedsUpdate=/etc
-ConditionFileIsExecutable=/sbin/ldconfig
[Service]
Type=oneshot