summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2014-01-22 11:44:54 +0100
committerLennart Poettering <lennart@poettering.net>2014-01-22 11:44:54 +0100
commit3736955368e8a3a24962f5fdd25cce3281885c30 (patch)
tree76e93358d4f228e058e059f474ce511cb83f47c6
parent1fedcf59e0959b5e20bcd5a0ee9073e1185af315 (diff)
man: document message timestamping/sequence number API
-rw-r--r--Makefile-man.am12
-rw-r--r--man/sd_bus_message_get_monotonic_usec.xml183
2 files changed, 195 insertions, 0 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index 288d3da53..fca842daa 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -26,6 +26,7 @@ MANPAGES += \
man/sd_bus_error.3 \
man/sd_bus_label_escape.3 \
man/sd_bus_message_get_cookie.3 \
+ man/sd_bus_message_get_monotonic_usec.3 \
man/sd_bus_new.3 \
man/sd_bus_open_user.3 \
man/sd_bus_request_name.3 \
@@ -180,7 +181,9 @@ MANPAGES_ALIAS += \
man/sd_bus_error_set_errno.3 \
man/sd_bus_error_set_errnof.3 \
man/sd_bus_label_unescape.3 \
+ man/sd_bus_message_get_realtime_usec.3 \
man/sd_bus_message_get_reply_cookie.3 \
+ man/sd_bus_message_get_seqnum.3 \
man/sd_bus_open_system.3 \
man/sd_bus_open_system_container.3 \
man/sd_bus_open_system_remote.3 \
@@ -327,7 +330,9 @@ man/sd_bus_error_set_const.3: man/sd_bus_error.3
man/sd_bus_error_set_errno.3: man/sd_bus_error.3
man/sd_bus_error_set_errnof.3: man/sd_bus_error.3
man/sd_bus_label_unescape.3: man/sd_bus_label_escape.3
+man/sd_bus_message_get_realtime_usec.3: man/sd_bus_message_get_monotonic_usec.3
man/sd_bus_message_get_reply_cookie.3: man/sd_bus_message_get_cookie.3
+man/sd_bus_message_get_seqnum.3: man/sd_bus_message_get_monotonic_usec.3
man/sd_bus_open_system.3: man/sd_bus_open_user.3
man/sd_bus_open_system_container.3: man/sd_bus_open_user.3
man/sd_bus_open_system_remote.3: man/sd_bus_open_user.3
@@ -606,9 +611,15 @@ man/sd_bus_error_set_errnof.html: man/sd_bus_error.html
man/sd_bus_label_unescape.html: man/sd_bus_label_escape.html
$(html-alias)
+man/sd_bus_message_get_realtime_usec.html: man/sd_bus_message_get_monotonic_usec.html
+ $(html-alias)
+
man/sd_bus_message_get_reply_cookie.html: man/sd_bus_message_get_cookie.html
$(html-alias)
+man/sd_bus_message_get_seqnum.html: man/sd_bus_message_get_monotonic_usec.html
+ $(html-alias)
+
man/sd_bus_open_system.html: man/sd_bus_open_user.html
$(html-alias)
@@ -1340,6 +1351,7 @@ EXTRA_DIST += \
man/sd_bus_error.xml \
man/sd_bus_label_escape.xml \
man/sd_bus_message_get_cookie.xml \
+ man/sd_bus_message_get_monotonic_usec.xml \
man/sd_bus_new.xml \
man/sd_bus_open_user.xml \
man/sd_bus_request_name.xml \
diff --git a/man/sd_bus_message_get_monotonic_usec.xml b/man/sd_bus_message_get_monotonic_usec.xml
new file mode 100644
index 000000000..57b115c63
--- /dev/null
+++ b/man/sd_bus_message_get_monotonic_usec.xml
@@ -0,0 +1,183 @@
+<?xml version='1.0'?> <!--*-nxml-*-->
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+ "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
+
+<!--
+ This file is part of systemd.
+
+ Copyright 2013 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+-->
+
+<refentry id="sd_bus_message_get_monotonic_usec">
+
+ <refentryinfo>
+ <title>sd_bus_message_get_monotonic_usec</title>
+ <productname>systemd</productname>
+
+ <authorgroup>
+ <author>
+ <contrib>Developer</contrib>
+ <firstname>Lennart</firstname>
+ <surname>Poettering</surname>
+ <email>lennart@poettering.net</email>
+ </author>
+ </authorgroup>
+ </refentryinfo>
+
+ <refmeta>
+ <refentrytitle>sd_bus_message_get_monotonic_usec</refentrytitle>
+ <manvolnum>3</manvolnum>
+ </refmeta>
+
+ <refnamediv>
+ <refname>sd_bus_message_get_monotonic_usec</refname>
+ <refname>sd_bus_message_get_realtime_usec</refname>
+ <refname>sd_bus_message_get_seqnum</refname>
+ <refpurpose>Retrieve the sender timestamps and sequence number of a message</refpurpose>
+ </refnamediv>
+
+ <refsynopsisdiv>
+ <funcsynopsis>
+ <funcsynopsisinfo>#include &lt;systemd/sd-bus.h&gt;</funcsynopsisinfo>
+
+ <funcprototype>
+ <funcdef>int <function>sd_bus_message_get_monotonic_usec</function></funcdef>
+ <paramdef>sd_bus_message* <parameter>message</parameter></paramdef>
+ <paramdef>uint64_t* <parameter>usec</parameter></paramdef>
+ </funcprototype>
+
+ <funcprototype>
+ <funcdef>int <function>sd_bus_message_get_realtime_usec</function></funcdef>
+ <paramdef>sd_bus_message* <parameter>message</parameter></paramdef>
+ <paramdef>uint64_t* <parameter>usec</parameter></paramdef>
+ </funcprototype>
+
+ <funcprototype>
+ <funcdef>int <function>sd_bus_message_get_seqnum</function></funcdef>
+ <paramdef>sd_bus_message* <parameter>message</parameter></paramdef>
+ <paramdef>uint64_t* <parameter>seqnum</parameter></paramdef>
+ </funcprototype>
+ </funcsynopsis>
+ </refsynopsisdiv>
+
+ <refsect1>
+ <title>Description</title>
+
+ <para><function>sd_bus_message_get_monotonic_usec()</function>
+ returns the monotonic timestamp of the time the
+ message was sent. This value is in microseconds since
+ the <literal>CLOCK_MONOTONIC</literal> epoch, see
+ <citerefentry><refentrytitle>clock_gettime</refentrytitle><manvolnum>2</manvolnum></citerefentry>
+ for details.</para>
+
+ <para>Similar,
+ <function>sd_bus_message_get_realtime_usec()</function>
+ returns the realtime (wallclock) timestamp of the time
+ the message was sent. This value is in microseconds
+ since Jan 1st, 1970, i.e. in the
+ <literal>CLOCK_REALTIME</literal> clock.</para>
+
+ <para><function>sd_bus_message_get_seqnum()</function>
+ returns the kernel-assigned sequence number of the
+ message. The kernel assigns a global monotonically increasing
+ sequence number to all messages sent on the local
+ system. This sequence number is useful for determining
+ message send order, even across different busses of
+ the local system. The sequence number combined with
+ the boot ID of the system (as returned by
+ <citerefentry><refentrytitle>sd_id128_get_boot</refentrytitle><manvolnum>3</manvolnum></citerefentry>)
+ is a suitable globally unique identifier for bus
+ messages.</para>
+
+ <para>These timestamps and the sequence number are
+ attached to each message by the kernel and cannot be
+ manipulated by the sending userspace.</para>
+
+ <para>Note that these timestamps are only available on
+ some bus transports, and only after support for them
+ has been negotiated with the
+ <citerefentry><refentrytitle>sd_bus_negotiate_timestamp</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ call.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>Return Value</title>
+
+ <para>On success, these calls return 0 or a positive
+ integer. On failure, these calls return a negative
+ errno-style error code.</para>
+
+ <para>On success, the timestamp or sequence number is
+ returned in the specified 64-bit unsigned integer
+ variable.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>Errors</title>
+
+ <para>Returned errors may indicate the following problems:</para>
+
+ <variablelist>
+ <varlistentry>
+ <term><varname>-EINVAL</varname></term>
+
+ <listitem><para>A specified parameter
+ is invalid.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+ <term><varname>-ENODATA</varname></term>
+
+ <listitem><para>No timestamp or
+ sequence number information is
+ attached to the passed message. This
+ error is returned if the underlying
+ transport does not support
+ timestamping or assigning of sequence
+ numbers, or if this feature has not
+ been negotiated with
+ <citerefentry><refentrytitle>sd_bus_negotiate_timestamp</refentrytitle><manvolnum>3</manvolnum></citerefentry>.</para></listitem>
+ </varlistentry>
+ </variablelist>
+ </refsect1>
+
+ <refsect1>
+ <title>Notes</title>
+
+ <para>The
+ <function>sd_bus_message_get_monotonic_usec()</function>,
+ <function>sd_bus_message_get_realtime_usec()</function>,
+ and <function>sd_bus_message_get_seqnum()</function>
+ interfaces are available as a shared library, which
+ can be compiled and linked to with the
+ <constant>libsystemd</constant> <citerefentry><refentrytitle>pkg-config</refentrytitle><manvolnum>1</manvolnum></citerefentry>
+ file.</para>
+ </refsect1>
+
+ <refsect1>
+ <title>See Also</title>
+
+ <para>
+ <citerefentry><refentrytitle>systemd</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd-bus</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_bus_new</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_bus_negotiate_timestamp</refentrytitle><manvolnum>3</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>clock_gettime</refentrytitle><manvolnum>2</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>sd_id128_get_boot</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ </para>
+ </refsect1>
+
+</refentry>