summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Triplett <josh@joshtriplett.org>2014-11-29 01:06:41 -0800
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-11-29 13:55:32 -0500
commit396f9e2b327d702ea9502b80febf836283e19350 (patch)
treef749cbfe9b5d1dc01c64ad7445051e7d06590071
parent778b6a3f8888ec9496143c92c8cbf95f5c891df9 (diff)
bootchart: Support bootchart.conf.d directories in the usual search paths
-rw-r--r--Makefile-man.am6
-rw-r--r--man/bootchart.conf.xml21
-rw-r--r--src/bootchart/bootchart.c7
-rw-r--r--src/bootchart/bootchart.conf3
4 files changed, 25 insertions, 12 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index 2a0d73e05..593dc4063 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -701,8 +701,10 @@ MANPAGES += \
man/bootchart.conf.5 \
man/systemd-bootchart.1
MANPAGES_ALIAS += \
- #
-
+ man/bootchart.conf.d.5
+man/bootchart.conf.d.5: man/bootchart.conf.5
+man/bootchart.conf.d.html: man/bootchart.conf.html
+ $(html-alias)
endif
diff --git a/man/bootchart.conf.xml b/man/bootchart.conf.xml
index 68834c73b..a364826bb 100644
--- a/man/bootchart.conf.xml
+++ b/man/bootchart.conf.xml
@@ -25,7 +25,8 @@
along with systemd; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="bootchart.conf" conditional='ENABLE_BOOTCHART'>
+<refentry id="bootchart.conf" conditional='ENABLE_BOOTCHART'
+ xmlns:xi="http://www.w3.org/2001/XInclude">
<refentryinfo>
<title>bootchart.conf</title>
<productname>systemd</productname>
@@ -47,23 +48,31 @@
<refnamediv>
<refname>bootchart.conf</refname>
- <refpurpose>Boot performance analysis graphing tool configuration file</refpurpose>
+ <refname>bootchart.conf.d</refname>
+ <refpurpose>Boot performance analysis graphing tool configuration files</refpurpose>
</refnamediv>
<refsynopsisdiv>
<para><filename>/etc/systemd/bootchart.conf</filename></para>
+ <para><filename>/etc/systemd/bootchart.conf.d/*.conf</filename></para>
+ <para><filename>/run/systemd/bootchart.conf.d/*.conf</filename></para>
+ <para><filename>/usr/lib/systemd/bootchart.conf.d/*.conf</filename></para>
</refsynopsisdiv>
<refsect1>
<title>Description</title>
<para>When starting, systemd-bootchart will read the
- configuration file <filename>bootchart.conf</filename>.
- This configuration file determines logging parameters and
- graph output.</para>
-
+ configuration file
+ <filename>/etc/systemd/bootchart.conf</filename>, followed by
+ the files in the <filename>bootchart.conf.d</filename>
+ directories. These configuration files determine logging
+ parameters and graph output.</para>
</refsect1>
+ <xi:include href="standard-conf.xml" xpointer="confd" />
+ <xi:include href="standard-conf.xml" xpointer="conf" />
+
<refsect1>
<title>Options</title>
diff --git a/src/bootchart/bootchart.c b/src/bootchart/bootchart.c
index 5bb4247c8..0808ba44e 100644
--- a/src/bootchart/bootchart.c
+++ b/src/bootchart/bootchart.c
@@ -125,10 +125,9 @@ static void parse_conf(void) {
{ NULL, NULL, NULL, 0, NULL }
};
- config_parse(NULL, BOOTCHART_CONF, NULL,
- NULL,
- config_item_table_lookup, items,
- true, false, true, NULL);
+ config_parse_many(BOOTCHART_CONF,
+ CONF_DIRS_NULSTR("systemd/bootchart.conf"),
+ NULL, config_item_table_lookup, items, true, NULL);
if (init != NULL)
strscpy(arg_init_path, sizeof(arg_init_path), init);
diff --git a/src/bootchart/bootchart.conf b/src/bootchart/bootchart.conf
index d7e0dabe0..c73328fde 100644
--- a/src/bootchart/bootchart.conf
+++ b/src/bootchart/bootchart.conf
@@ -5,6 +5,9 @@
# the Free Software Foundation; either version 2.1 of the License, or
# (at your option) any later version.
#
+# You can override the directives in this file by creating files in
+# /etc/systemd/bootchart.conf.d/*.conf.
+#
# See bootchart.conf(5) for details
[Bootchart]