summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2013-11-12 15:43:17 -0500
committerTom Gundersen <teg@jklm.no>2013-11-12 22:38:08 +0100
commit3c9317d2d93248f3f0b0feaaa113485aee415d8a (patch)
tree14d174df35b3f12b988a1a8275bcb0f4e723b684
parent735e5d83ee3391f8ab0e18218278302c2e87e5f3 (diff)
build-sys: Add --disable-networkd option
For GNOME (Continuous), we are unlikely to require or want systemd-networkd in the near term future; all of the tools and code are targeting NetworkManager. The long term story is still an open question of course, but for now, there's no reason for gnome-continuous to build or ship this.
-rw-r--r--Makefile.am2
-rw-r--r--configure.ac8
2 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8710462aa..ce47171b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3812,6 +3812,7 @@ EXTRA_DIST += \
endif
# ------------------------------------------------------------------------------
+if ENABLE_NETWORKD
rootlibexec_PROGRAMS += \
systemd-networkd
@@ -3863,6 +3864,7 @@ EXTRA_DIST += \
CLEANFILES += \
src/network/networkd-gperf.c
+endif
# ------------------------------------------------------------------------------
if ENABLE_LOGIND
diff --git a/configure.ac b/configure.ac
index bb0840777..d0bfcb823 100644
--- a/configure.ac
+++ b/configure.ac
@@ -773,6 +773,14 @@ fi
AM_CONDITIONAL(ENABLE_POLKIT, [test "x$have_polkit" = "xyes"])
# ------------------------------------------------------------------------------
+AC_ARG_ENABLE(networkd, AS_HELP_STRING([--disable-networkd], [disable networkd]))
+if test "x$enable_networkd" != "xno"; then
+ AC_DEFINE(ENABLE_NETWORKD, 1, [Define if networkd support is to be enabled])
+ have_networkd=yes
+fi
+AM_CONDITIONAL(ENABLE_NETWORKD, [test "x$have_networkd" = "xyes"])
+
+# ------------------------------------------------------------------------------
have_efi=no
AC_ARG_ENABLE(efi, AS_HELP_STRING([--disable-efi], [disable EFI support]))
if test "x$enable_efi" != "xno"; then