summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2014-10-18 16:20:36 +0200
committerLennart Poettering <lennart@poettering.net>2014-10-20 19:23:13 +0200
commit5c20a8bca1dd16d64b2dd959a2552f6452448932 (patch)
treeaa66901699d99273a623c9df6ebc57d488682aff
parentb7ea3f3ed6204dca31f8f2a84b667c1783259c5b (diff)
man: document sd_bus_creds_get_connection_name()
-rw-r--r--Makefile-man.am5
-rw-r--r--man/sd_bus_creds_get_pid.xml14
2 files changed, 19 insertions, 0 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index 6a74abdb0..bdbc54f4a 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -750,6 +750,7 @@ MANPAGES_ALIAS += \
man/sd_bus_creds_get_cgroup.3 \
man/sd_bus_creds_get_cmdline.3 \
man/sd_bus_creds_get_comm.3 \
+ man/sd_bus_creds_get_connection_name.3 \
man/sd_bus_creds_get_exe.3 \
man/sd_bus_creds_get_gid.3 \
man/sd_bus_creds_get_mask.3 \
@@ -818,6 +819,7 @@ man/sd_bus_creds_get_audit_session_id.3: man/sd_bus_creds_get_pid.3
man/sd_bus_creds_get_cgroup.3: man/sd_bus_creds_get_pid.3
man/sd_bus_creds_get_cmdline.3: man/sd_bus_creds_get_pid.3
man/sd_bus_creds_get_comm.3: man/sd_bus_creds_get_pid.3
+man/sd_bus_creds_get_connection_name.3: man/sd_bus_creds_get_pid.3
man/sd_bus_creds_get_exe.3: man/sd_bus_creds_get_pid.3
man/sd_bus_creds_get_gid.3: man/sd_bus_creds_get_pid.3
man/sd_bus_creds_get_mask.3: man/sd_bus_creds_new_from_pid.3
@@ -896,6 +898,9 @@ man/sd_bus_creds_get_cmdline.html: man/sd_bus_creds_get_pid.html
man/sd_bus_creds_get_comm.html: man/sd_bus_creds_get_pid.html
$(html-alias)
+man/sd_bus_creds_get_connection_name.html: man/sd_bus_creds_get_pid.html
+ $(html-alias)
+
man/sd_bus_creds_get_exe.html: man/sd_bus_creds_get_pid.html
$(html-alias)
diff --git a/man/sd_bus_creds_get_pid.xml b/man/sd_bus_creds_get_pid.xml
index fcc555716..cc8603cac 100644
--- a/man/sd_bus_creds_get_pid.xml
+++ b/man/sd_bus_creds_get_pid.xml
@@ -67,6 +67,7 @@ along with systemd; If not, see <http://www.gnu.org/licenses/>.
<refname>sd_bus_creds_get_audit_login_uid</refname>
<refname>sd_bus_creds_get_unique_name</refname>
<refname>sd_bus_creds_get_well_known_names</refname>
+ <refname>sd_bus_creds_get_connection_name</refname>
<refpurpose>Retrieve fields from a credentials object</refpurpose>
</refnamediv>
@@ -219,6 +220,12 @@ along with systemd; If not, see <http://www.gnu.org/licenses/>.
<paramdef>char ***<parameter>name</parameter></paramdef>
</funcprototype>
+ <funcprototype>
+ <funcdef>int <function>sd_bus_creds_get_connection_name</function></funcdef>
+ <paramdef>sd_bus_creds *<parameter>c</parameter></paramdef>
+ <paramdef>const char **<parameter>name</parameter></paramdef>
+ </funcprototype>
+
</funcsynopsis>
</refsynopsisdiv>
@@ -352,6 +359,13 @@ along with systemd; If not, see <http://www.gnu.org/licenses/>.
url="http://dbus.freedesktop.org/doc/dbus-specification.html#message-protocol-names-bus">The
D-Bus specification</ulink>.</para>
+ <para><function>sd_bus_creds_get_connection_name()</function> will
+ retrieve a descriptive name of the bus connection of the
+ peer. This name is useful to discern multiple bus connections by
+ the same peer, and may be altered by the peer with the
+ <citerefentry><refentrytitle>sd_bus_set_name()</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ call.</para>
+
<para>All functions that take a <parameter>const
char**</parameter> parameter will store the answer there as an
address of a NUL-terminated string. It will be valid as long as