summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Triplett <josh@joshtriplett.org>2014-11-29 01:07:11 -0800
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-11-29 13:55:32 -0500
commitf2dacc96b25528ca1b0caca6364a69d656cf1569 (patch)
tree9830f1b716a73f6c3845032e019d3384e6f57fba
parent301af7e4853ad0281402f8d86f5a77c6cb7ce9f4 (diff)
resolved: Support resolved.conf.d directories in the usual search paths
-rw-r--r--Makefile-man.am5
-rw-r--r--man/resolved.conf.xml16
-rw-r--r--src/resolve/resolved-conf.c9
-rw-r--r--src/resolve/resolved.conf.in3
4 files changed, 24 insertions, 9 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index 01d34087b..36e0ebbb6 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -1204,8 +1204,13 @@ MANPAGES += \
man/resolved.conf.5 \
man/systemd-resolved.service.8
MANPAGES_ALIAS += \
+ man/resolved.conf.d.5 \
man/systemd-resolved.8
+man/resolved.conf.d.5: man/resolved.conf.5
man/systemd-resolved.8: man/systemd-resolved.service.8
+man/resolved.conf.d.html: man/resolved.conf.html
+ $(html-alias)
+
man/systemd-resolved.html: man/systemd-resolved.service.html
$(html-alias)
diff --git a/man/resolved.conf.xml b/man/resolved.conf.xml
index c58236856..36013a5e3 100644
--- a/man/resolved.conf.xml
+++ b/man/resolved.conf.xml
@@ -22,7 +22,8 @@
along with systemd; If not, see <http://www.gnu.org/licenses/>.
-->
-<refentry id="resolved.conf" conditional='ENABLE_RESOLVED'>
+<refentry id="resolved.conf" conditional='ENABLE_RESOLVED'
+ xmlns:xi="http://www.w3.org/2001/XInclude">
<refentryinfo>
<title>resolved.conf</title>
<productname>systemd</productname>
@@ -44,23 +45,28 @@
<refnamediv>
<refname>resolved.conf</refname>
- <refpurpose>Network Name Resolution configuration file</refpurpose>
+ <refname>resolved.conf.d</refname>
+ <refpurpose>Network Name Resolution configuration files</refpurpose>
</refnamediv>
<refsynopsisdiv>
<para><filename>/etc/systemd/resolved.conf</filename></para>
+ <para><filename>/etc/systemd/resolved.conf.d/*.conf</filename></para>
+ <para><filename>/run/systemd/resolved.conf.d/*.conf</filename></para>
+ <para><filename>/usr/lib/systemd/resolved.conf.d/*.conf</filename></para>
</refsynopsisdiv>
<refsect1>
<title>Description</title>
- <para>When starting, systemd-resolved will read the
- configuration file <filename>resolved.conf</filename>.
- This configuration file controls local DNS and LLMNR
+ <para>These configuration files control local DNS and LLMNR
name resolving.</para>
</refsect1>
+ <xi:include href="standard-conf.xml" xpointer="confd" />
+ <xi:include href="standard-conf.xml" xpointer="conf" />
+
<refsect1>
<title>Options</title>
diff --git a/src/resolve/resolved-conf.c b/src/resolve/resolved-conf.c
index 63e87f8df..81b9d3438 100644
--- a/src/resolve/resolved-conf.c
+++ b/src/resolve/resolved-conf.c
@@ -147,8 +147,9 @@ int config_parse_support(
int manager_parse_config_file(Manager *m) {
assert(m);
- return config_parse(NULL, "/etc/systemd/resolved.conf", NULL,
- "Resolve\0",
- config_item_perf_lookup, resolved_gperf_lookup,
- false, false, true, m);
+ return config_parse_many("/etc/systemd/resolved.conf",
+ CONF_DIRS_NULSTR("systemd/resolved.conf"),
+ "Resolve\0",
+ config_item_perf_lookup, resolved_gperf_lookup,
+ false, m);
}
diff --git a/src/resolve/resolved.conf.in b/src/resolve/resolved.conf.in
index c8263d67f..e5a19ee47 100644
--- a/src/resolve/resolved.conf.in
+++ b/src/resolve/resolved.conf.in
@@ -5,6 +5,9 @@
# the Free Software Foundation; either version 2.1 of the License, or
# (at your option) any later version.
#
+# You can override the directives in this file by creating files in
+# /etc/systemd/resolved.conf.d/*.conf.
+#
# See resolved.conf(5) for details
[Resolve]