summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUmut Tezduyar Lindskog <umut.tezduyar@axis.com>2014-12-19 11:47:30 +0100
committerTom Gundersen <teg@jklm.no>2014-12-20 00:23:37 +0100
commitfe659612e40e6a0cf91a73b10aa45eea958b747e (patch)
treec6d5acfa333689257dadebc95ab21f0265dded38
parent7a6f1457462840ed52f2a332e2bd56ca210cff2d (diff)
build: add option to disable hwdb
[tomegun: fix Makefile-man.am, based on fix from Michael Biebl]
-rw-r--r--Makefile-man.am8
-rw-r--r--Makefile.am2
-rw-r--r--configure.ac6
3 files changed, 14 insertions, 2 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index 45b8238ad..68e7483e7 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -14,7 +14,6 @@ MANPAGES += \
man/file-hierarchy.7 \
man/halt.8 \
man/hostname.5 \
- man/hwdb.7 \
man/journalctl.1 \
man/journald.conf.5 \
man/kernel-command-line.7 \
@@ -73,7 +72,6 @@ MANPAGES += \
man/systemd-halt.service.8 \
man/systemd-hibernate-resume-generator.8 \
man/systemd-hibernate-resume@.service.8 \
- man/systemd-hwdb.8 \
man/systemd-inhibit.1 \
man/systemd-initctl.service.8 \
man/systemd-journald.service.8 \
@@ -676,6 +674,12 @@ man/systemd-user.conf.html: man/systemd-system.conf.html
man/user.conf.d.html: man/systemd-system.conf.html
$(html-alias)
+if ENABLE_HWDB
+MANPAGES += \
+ man/hwdb.7 \
+ man/systemd-hwdb.8
+
+endif
if ENABLE_BACKLIGHT
MANPAGES += \
diff --git a/Makefile.am b/Makefile.am
index 86bcfdfd8..baa1398a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3608,6 +3608,7 @@ udevadm_LDADD = \
libudev-core.la
# ------------------------------------------------------------------------------
+if ENABLE_HWDB
INSTALL_DIRS += \
$(sysconfdir)/udev/hwdb.d
@@ -3656,6 +3657,7 @@ INSTALL_DATA_HOOKS += \
hwdb-remove-hook:
-test -n "$(DESTDIR)" || rm -f /etc/udev/hwdb.bin
+endif
# ------------------------------------------------------------------------------
TESTS += \
diff --git a/configure.ac b/configure.ac
index 90aa3ccf5..9296c25db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1191,6 +1191,11 @@ AM_CONDITIONAL([ENABLE_GUDEV], [test "x$enable_gudev" = "xyes"])
AS_IF([test "x$enable_gudev" = "xyes"], [ AC_DEFINE(HAVE_GLIB, 1, [Define if glib is available]) ])
# ------------------------------------------------------------------------------
+AC_ARG_ENABLE(hwdb, [AC_HELP_STRING([--disable-hwdb], [disable hardware database support])],
+ enable_hwdb=$enableval, enable_hwdb=yes)
+AM_CONDITIONAL(ENABLE_HWDB, [test x$enable_hwdb = xyes])
+
+# ------------------------------------------------------------------------------
have_manpages=no
AC_ARG_ENABLE(manpages, AS_HELP_STRING([--disable-manpages], [disable manpages]))
AS_IF([test "x$enable_manpages" != xno], [have_manpages=yes])
@@ -1430,6 +1435,7 @@ AC_MSG_RESULT([
dbus: ${have_dbus}
nss-myhostname: ${have_myhostname}
gudev: ${enable_gudev}
+ hwdb: ${enable_hwdb}
gintrospection: ${enable_introspection}
terminal: ${have_terminal}
kdbus: ${have_kdbus}