summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-05-17 01:44:03 +0200
committerLennart Poettering <lennart@poettering.net>2010-05-17 01:44:03 +0200
commit340d89e06e503836de9c124d650845f4889f8c2c (patch)
tree712f66290993674d4f58e1e867b1275a65e700ac
parenteb10a76494542fb560efd09c16b40826fc37bc5f (diff)
build-sys: add small redirecting Makefiles to simplify compilation from within emacs
l---------man/Makefile1
-rw-r--r--src/Makefile28
l---------units/Makefile1
3 files changed, 30 insertions, 0 deletions
diff --git a/man/Makefile b/man/Makefile
new file mode 120000
index 000000000..bd1047548
--- /dev/null
+++ b/man/Makefile
@@ -0,0 +1 @@
+../src/Makefile \ No newline at end of file
diff --git a/src/Makefile b/src/Makefile
new file mode 100644
index 000000000..bc7e9fa36
--- /dev/null
+++ b/src/Makefile
@@ -0,0 +1,28 @@
+# This file is part of systemd.
+#
+# Copyright 2010 Lennart Poettering
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
+# This file is a dirty trick to simplify compilation from within
+# emacs. This file is not intended to be distributed. So, don't touch
+# it, even better ignore it!
+
+all:
+ $(MAKE) -C ..
+
+clean:
+ $(MAKE) -C .. clean
+
+.PHONY: all clean
diff --git a/units/Makefile b/units/Makefile
new file mode 120000
index 000000000..bd1047548
--- /dev/null
+++ b/units/Makefile
@@ -0,0 +1 @@
+../src/Makefile \ No newline at end of file