summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-01-26 08:14:54 +0100
committerSven Eden <yamakuzure@gmx.net>2017-03-14 10:23:02 +0100
commit35ed426f81eb72dc23ce2dcc625ea88be1c95990 (patch)
tree3beface5e488f1d3acc0dbd78be8c1fbc8e13c02
parentc40fa3382a1b90aa5bccf2b36276e717461b11b0 (diff)
[Patch 1/3] Add cgroups initialization and handling
Re-add elogind-cgroups-agent. elogind will not be able to support the new unified hierarchy, and the agent is needed for the classical hierarchy.
-rw-r--r--Makefile.am11
l---------src/cgroups-agent/Makefile1
-rw-r--r--src/cgroups-agent/cgroups-agent.c66
3 files changed, 78 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 636924caf..2f9ec71f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -115,6 +115,7 @@ CLEANFILES = $(BUILT_SOURCES) \
AM_CPPFLAGS = \
-include $(top_builddir)/config.h \
-DPKGSYSCONFDIR=\"$(pkgsysconfdir)\" \
+ -DELOGIND_CGROUP_AGENT_PATH=\"$(rootlibexecdir)/elogind-cgroups-agent\" \
-DROOTPREFIX=\"$(rootprefix)\" \
-DUDEVLIBEXECDIR=\"$(udevlibexecdir)\" \
-DPOLKIT_AGENT_BINARY_PATH=\"$(bindir)/pkttyagent\" \
@@ -457,6 +458,16 @@ dist_factory_pam_DATA = \
endif
# ------------------------------------------------------------------------------
+rootlibexec_PROGRAMS += \
+ elogind-cgroups-agent
+
+elogind_cgroups_agent_SOURCES = \
+ src/cgroups-agent/cgroups-agent.c
+
+elogind_cgroups_agent_LDADD = \
+ libshared.la
+
+# ------------------------------------------------------------------------------
libelogind_internal_la_SOURCES = \
src/systemd/sd-bus.h \
src/systemd/sd-bus-protocol.h \
diff --git a/src/cgroups-agent/Makefile b/src/cgroups-agent/Makefile
new file mode 120000
index 000000000..d0b0e8e00
--- /dev/null
+++ b/src/cgroups-agent/Makefile
@@ -0,0 +1 @@
+../Makefile \ No newline at end of file
diff --git a/src/cgroups-agent/cgroups-agent.c b/src/cgroups-agent/cgroups-agent.c
new file mode 100644
index 000000000..612bc8fde
--- /dev/null
+++ b/src/cgroups-agent/cgroups-agent.c
@@ -0,0 +1,66 @@
+/*-*- Mode: C; c-basic-offset: 8; indent-tabs-mode: nil -*-*/
+
+/***
+ This file is part of systemd.
+
+ Copyright 2010 Lennart Poettering
+
+ systemd is free software; you can redistribute it and/or modify it
+ under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; either version 2.1 of the License, or
+ (at your option) any later version.
+
+ systemd is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with systemd; If not, see <http://www.gnu.org/licenses/>.
+***/
+
+#include <stdlib.h>
+
+#include "sd-bus.h"
+#include "log.h"
+#include "bus-util.h"
+
+int main(int argc, char *argv[]) {
+ _cleanup_bus_flush_close_unref_ sd_bus *bus = NULL;
+ int r;
+
+ if (argc != 2) {
+ log_error("Incorrect number of arguments.");
+ return EXIT_FAILURE;
+ }
+
+ log_set_target(LOG_TARGET_AUTO);
+ log_parse_environment();
+ log_open();
+
+ /* We send this event to the private D-Bus socket and then the
+ * system instance will forward this to the system bus. We do
+ * this to avoid an activation loop when we start dbus when we
+ * are called when the dbus service is shut down. */
+
+ r = bus_open_system_systemd(&bus);
+ if (r < 0) {
+ /* If we couldn't connect we assume this was triggered
+ * while systemd got restarted/transitioned from
+ * initrd to the system, so let's ignore this */
+ log_debug_errno(r, "Failed to get D-Bus connection: %m");
+ return EXIT_FAILURE;
+ }
+
+ r = sd_bus_emit_signal(bus,
+ "/org/freedesktop/systemd1/agent",
+ "org.freedesktop.systemd1.Agent",
+ "Released",
+ "s", argv[1]);
+ if (r < 0) {
+ log_debug_errno(r, "Failed to send signal message on private connection: %m");
+ return EXIT_FAILURE;
+ }
+
+ return EXIT_SUCCESS;
+}