summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-03-27 17:11:00 +0200
committerLennart Poettering <lennart@poettering.net>2012-03-27 17:11:00 +0200
commit55d029addf7d97b15faacea597a4ff65542aaf0e (patch)
treeb55ac277712b3dc89355cbae511338a520c58661
parent231931ffba1bca9d8759bbd6f797e56f8c6971fa (diff)
units: get rid of var-run.mount and var-lock.mount
Since a number of distribitions don't need this compat glue anymore drop it from systemd upstream. Distributions which still haven't converted to /run can steal these unit files from the git history if they need to.
-rw-r--r--Makefile.am18
-rw-r--r--units/var-lock.mount19
-rw-r--r--units/var-run.mount19
3 files changed, 2 insertions, 54 deletions
diff --git a/Makefile.am b/Makefile.am
index 0fa38d8cc..72bbcc27c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -289,7 +289,6 @@ dist_systemunit_DATA = \
units/sys-kernel-config.mount \
units/sys-kernel-debug.mount \
units/sys-fs-fuse-connections.mount \
- units/var-run.mount \
units/remount-rootfs.service \
units/printer.target \
units/sound.target \
@@ -301,11 +300,6 @@ dist_systemunit_DATA = \
units/systemd-ask-password-console.path \
units/syslog.target
-if HAVE_SYSV_COMPAT
-dist_systemunit_DATA += \
- units/var-lock.mount
-endif
-
nodist_systemunit_DATA = \
units/getty@.service \
units/serial-getty@.service \
@@ -2281,12 +2275,10 @@ systemd-install-data-hook:
( cd $(DESTDIR)$(systemunitdir)/local-fs.target.wants && \
rm -f systemd-remount-api-vfs.service \
fsck-root.service \
- remount-rootfs.service \
- var-run.mount && \
+ remount-rootfs.service && \
$(LN_S) ../systemd-remount-api-vfs.service systemd-remount-api-vfs.service && \
$(LN_S) ../fsck-root.service fsck-root.service && \
- $(LN_S) ../remount-rootfs.service remount-rootfs.service && \
- $(LN_S) ../var-run.mount var-run.mount )
+ $(LN_S) ../remount-rootfs.service remount-rootfs.service )
( cd $(DESTDIR)$(userunitdir) && \
rm -f shutdown.target sockets.target bluetooth.target printer.target sound.target && \
$(LN_S) $(systemunitdir)/shutdown.target shutdown.target && \
@@ -2445,12 +2437,6 @@ if TARGET_MAGEIA
$(LN_S) $(systemunitdir)/display-manager.service display-manager.service )
endif
-if HAVE_SYSV_COMPAT
- ( cd $(DESTDIR)$(systemunitdir)/local-fs.target.wants && \
- rm -f var-lock.mount && \
- $(LN_S) ../var-lock.mount var-lock.mount )
-endif
-
install-exec-hook: $(INSTALL_EXEC_HOOKS)
uninstall-hook: $(UNINSTALL_EXEC_HOOKS)
diff --git a/units/var-lock.mount b/units/var-lock.mount
deleted file mode 100644
index 07277adac..000000000
--- a/units/var-lock.mount
+++ /dev/null
@@ -1,19 +0,0 @@
-# This file is part of systemd.
-#
-# systemd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-
-[Unit]
-Description=Lock Directory
-Before=local-fs.target
-# skip mounting if the directory does not exist or is a symlink
-ConditionPathIsDirectory=/var/lock
-ConditionPathIsSymbolicLink=!/var/lock
-
-[Mount]
-What=/run/lock
-Where=/var/lock
-Type=bind
-Options=bind
diff --git a/units/var-run.mount b/units/var-run.mount
deleted file mode 100644
index ab4da424c..000000000
--- a/units/var-run.mount
+++ /dev/null
@@ -1,19 +0,0 @@
-# This file is part of systemd.
-#
-# systemd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-
-[Unit]
-Description=Runtime Directory
-Before=local-fs.target
-# skip mounting if the directory does not exist or is a symlink
-ConditionPathIsDirectory=/var/run
-ConditionPathIsSymbolicLink=!/var/run
-
-[Mount]
-What=/run
-Where=/var/run
-Type=bind
-Options=bind