summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-04-11 16:50:48 +0200
committerSven Eden <yamakuzure@gmx.net>2018-08-24 16:47:08 +0200
commita37ab83d0da89ef55905edfe838a5c05891a989f (patch)
treef673bed2422997df90657a1c54f850e00bdcc5a3
parent4bdb280770447021cecff5e3d95dcf7e46139ce2 (diff)
test-execute: make find invocation a bit more efficent, increase timeout
We go through the whole file system, so this test can take arbitrary time. But this test is still quite useful, so let's at least try to make it more efficent by not descending at all into the directories we would filter out later on anyway. Also increase the timeout, in case the previous step doesn't help enough.
-rw-r--r--src/test/meson.build16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/test/meson.build b/src/test/meson.build
index 9cede5ad1..2585bb3fa 100644
--- a/src/test/meson.build
+++ b/src/test/meson.build
@@ -1,6 +1,19 @@
# SPDX-License-Identifier: LGPL-2.1+
#
# Copyright 2017 Zbigniew Jędrzejewski-Szmek
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
awkscript = 'test-hashmap-ordered.awk'
test_hashmap_ordered_c = custom_target(
@@ -601,8 +614,9 @@ tests += [
# libseccomp,
# libselinux,
# libmount,
-# libblkid]],
#endif // 0
+ libblkid],
+ '', 'timeout=360'],
[['src/test/test-siphash24.c'],
[],