summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-08-14 08:49:45 +0200
committerSven Eden <yamakuzure@gmx.net>2017-08-14 09:18:40 +0200
commitb0e04dbdadd4376fc76192d44afe3c753c92678d (patch)
tree7fb7a197e378a0f18ace74437fb889d45fca1684
parent52d6b2568f4ff9cb8159d0802d03756afd9336aa (diff)
Prep v235: Apply upstream fixes (1/10) [root]
-rw-r--r--cb/elogind.cbp1
-rw-r--r--meson.build21
-rw-r--r--meson_options.txt5
-rw-r--r--tools/gdb-sd_dump_hashmaps.py1
4 files changed, 20 insertions, 8 deletions
diff --git a/cb/elogind.cbp b/cb/elogind.cbp
index 818c48570..6cb494480 100644
--- a/cb/elogind.cbp
+++ b/cb/elogind.cbp
@@ -377,7 +377,6 @@
<Option compilerVar="CC" />
</Unit>
<Unit filename="../src/libelogind/sd-bus/bus-type.h" />
- <Unit filename="../src/libelogind/sd-bus/kdbus.h" />
<Unit filename="../src/libelogind/sd-bus/sd-bus.c">
<Option compilerVar="CC" />
</Unit>
diff --git a/meson.build b/meson.build
index 61e1a51ab..1d1082d54 100644
--- a/meson.build
+++ b/meson.build
@@ -38,6 +38,7 @@ m4_defines = []
# manipulates commits to not take those masks out. Therefore
# it can be used to add commits updating the meson files, too.
#endif // 0
+
#####################################################################
rootprefixdir = get_option('rootprefix')
@@ -95,6 +96,7 @@ varlogdir = join_paths(localstatedir, 'log')
#if 0 /// UNNEEDED by elogind
# xinitrcdir = join_paths(sysconfdir, 'X11/xinit/xinitrc.d')
# rpmmacrosdir = get_option('rpmmacrosdir')
+# modprobedir = join_paths(prefixdir, 'lib/modprobe.d')
#endif // 0
# Our own paths
@@ -607,6 +609,10 @@ endforeach
############################################################
conf.set_quoted('FALLBACK_HOSTNAME', get_option('fallback-hostname'))
+#if 0 /// UNNEEDED by elogind
+# conf.set10('ENABLE_COMPAT_GATEWAY_HOSTNAME', get_option('compat-gateway-hostname'))
+# gateway_hostnames = ['_gateway'] + (conf.get('ENABLE_COMPAT_GATEWAY_HOSTNAME') == 1 ? ['gateway'] : [])
+#endif // 0
default_hierarchy = get_option('default-hierarchy')
conf.set_quoted('DEFAULT_HIERARCHY_NAME', default_hierarchy,
@@ -1686,9 +1692,7 @@ if conf.get('HAVE_PAM', false)
install_dir : pamlibdir)
endif
#endif // 0
-
#if 0 /// UNNEEDED by elogind
-# if conf.get('HAVE_PAM', false)
# executable('systemd-user-sessions',
# 'src/user-sessions/user-sessions.c',
# include_directories : includes,
@@ -2571,11 +2575,14 @@ subdir('shell-completion/zsh')
install_subdir('factory/etc',
install_dir : factorydir)
+
#if 0 /// UNNEEDED by elogind
# install_data('xorg/50-systemd-user.sh',
# install_dir : xinitrcdir)
# install_data('system-preset/90-systemd.preset',
# install_dir : systempresetdir)
+# install_data('modprobe.d/systemd.conf',
+# install_dir : modprobedir)
#endif // 0
install_data('README',
'NEWS',
@@ -2613,13 +2620,13 @@ if git.found()
':/*.[ch]'])
all_files = files(all_files.stdout().split())
- run_target(
+ custom_target(
'tags',
- input : all_files,
+ output : 'tags',
command : ['env', 'etags', '-o', '@0@/TAGS'.format(meson.source_root())] + all_files)
- run_target(
+ custom_target(
'ctags',
- input : all_files,
+ output : 'ctags',
command : ['env', 'ctags', '-o', '@0@/tags'.format(meson.source_root())] + all_files)
endif
@@ -2668,6 +2675,7 @@ status = [
'PAM configuration dir: @0@'.format(pamconfdir),
#if 0 /// UNSUPPORTED by elogind
# 'RPM macros dir: @0@'.format(rpmmacrosdir),
+# 'modprobe.d dir: @0@'.format(modprobedir),
#endif // 0
'D-Bus policy dir: @0@'.format(dbuspolicydir),
'D-Bus session dir: @0@'.format(dbussessionservicedir),
@@ -2690,6 +2698,7 @@ status = [
# 'nobody user name: @0@'.format(get_option('nobody-user')),
# 'nobody group name: @0@'.format(get_option('nobody-group')),
# 'fallback hostname: @0@'.format(get_option('fallback-hostname')),
+# 'symbolic gateway hostnames: @0@'.format(', '.join(gateway_hostnames)),
#
# 'default DNSSEC mode: @0@'.format(default_dnssec),
# 'default cgroup hierarchy: @0@'.format(default_hierarchy),
diff --git a/meson_options.txt b/meson_options.txt
index 3ec87540b..d4d944806 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -150,10 +150,13 @@ option('pamconfdir', type : 'string',
option('fallback-hostname', type : 'string', value : 'localhost',
description : 'the hostname used if none configured')
+#if 0 /// UNNEEDED by elogind
+# option('compat-gateway-hostname', type : 'boolean', value : 'false',
+# description : 'allow "gateway" as the symbolic name for default gateway')
+#endif // 0
option('default-hierarchy', type : 'combo',
choices : ['legacy', 'hybrid', 'unified'], value : 'hybrid',
description : 'default cgroup hierarchy')
-
#if 0 /// UNNEEDED by elogind
# option('time-epoch', type : 'string',
# description : 'time epoch for time clients')
diff --git a/tools/gdb-sd_dump_hashmaps.py b/tools/gdb-sd_dump_hashmaps.py
index 9ee81fb05..62ce8006f 100644
--- a/tools/gdb-sd_dump_hashmaps.py
+++ b/tools/gdb-sd_dump_hashmaps.py
@@ -1,3 +1,4 @@
+#!/usr/bin/env python3
# -*- Mode: python; coding: utf-8; indent-tabs-mode: nil -*- */
#
# This file is part of systemd.