summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Messer <andi@bastelmap.de>2018-01-27 14:01:59 +0100
committerAndreas Messer <andi@bastelmap.de>2018-01-27 14:06:58 +0100
commitbddf69b0a61a952942505824d1b00aa5803139bb (patch)
treef0853204c614cff210842aa06485474c4895de5d
parent3524faafde46d4fb9bc14e7ac9fab030ec923650 (diff)
Introduce patch to to fix daemonizin
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/fix-forking.diff15
-rw-r--r--debian/patches/series1
3 files changed, 24 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 54b990457..8fe507f65 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+elogind (234.4-1+devuan1.3) experimental; urgency=medium
+
+ * debian/patches/fix-forking.diff
+ - Fix startpar not erminating due to open file descriptors after
+ forking
+
+ -- Andreas Messer <andi@bastelmap.de> Sat, 27 Jan 2018 12:44:32 +0100
+
elogind (234.4-1+devuan1.2) experimental; urgency=medium
* debian/rules
diff --git a/debian/patches/fix-forking.diff b/debian/patches/fix-forking.diff
new file mode 100644
index 000000000..1edb276c5
--- /dev/null
+++ b/debian/patches/fix-forking.diff
@@ -0,0 +1,15 @@
+--- a/src/login/elogind.c
++++ b/src/login/elogind.c
+@@ -125,6 +125,12 @@
+
+ /* The first child has to become a new session leader. */
+ close_all_fds(NULL, 0);
++
++ /* close_all_fds() does not close 0,1,2 */
++ close(0);
++ close(1);
++ close(2);
++
+ SID = setsid();
+ if ((pid_t)-1 == SID)
+ return log_error_errno(errno, "Failed to create new SID: %m");
diff --git a/debian/patches/series b/debian/patches/series
index de8e2036d..ad9672c1f 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
fix-udev-rules.diff
+fix-forking.diff