summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-01-12 09:34:38 +0100
committerSven Eden <yamakuzure@gmx.net>2017-03-14 10:22:32 +0100
commitfb047e8edd9fc19b4a65f2656df494a12add1d31 (patch)
tree23fb8fc5ce3be4d679a863b21c832eb20bf931fe
parentd733c8628fed28abe166faa9e7fca7a3fb904f05 (diff)
Remove SysV compat
-rw-r--r--Makefile.am4
-rw-r--r--src/basic/build.h7
-rw-r--r--src/shared/path-lookup.h4
3 files changed, 0 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 10770ff71..67b5df055 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -939,10 +939,6 @@ DISTCHECK_CONFIGURE_FLAGS = \
--with-rootprefix=$$dc_install_base \
--enable-compat-libs
-DISTCHECK_CONFIGURE_FLAGS += \
- --with-sysvinit-path= \
- --with-sysvrcnd-path=
-
if ENABLE_SPLIT_USR
DISTCHECK_CONFIGURE_FLAGS += \
--enable-split-usr
diff --git a/src/basic/build.h b/src/basic/build.h
index 8b82ede29..653a505e6 100644
--- a/src/basic/build.h
+++ b/src/basic/build.h
@@ -57,12 +57,6 @@
#define _SMACK_FEATURE_ "-SMACK"
#endif
-#ifdef HAVE_SYSV_COMPAT
-#define _SYSVINIT_FEATURE_ "+SYSVINIT"
-#else
-#define _SYSVINIT_FEATURE_ "-SYSVINIT"
-#endif
-
#ifdef HAVE_LIBCRYPTSETUP
#define _LIBCRYPTSETUP_FEATURE_ "+LIBCRYPTSETUP"
#else
@@ -136,7 +130,6 @@
_IMA_FEATURE_ " " \
_APPARMOR_FEATURE_ " " \
_SMACK_FEATURE_ " " \
- _SYSVINIT_FEATURE_ " " \
_LIBCRYPTSETUP_FEATURE_ " " \
_GCRYPT_FEATURE_ " " \
_GNUTLS_FEATURE_ " " \
diff --git a/src/shared/path-lookup.h b/src/shared/path-lookup.h
index e35c8d3c0..f4f9895bb 100644
--- a/src/shared/path-lookup.h
+++ b/src/shared/path-lookup.h
@@ -25,10 +25,6 @@
typedef struct LookupPaths {
char **unit_path;
-#ifdef HAVE_SYSV_COMPAT
- char **sysvinit_path;
- char **sysvrcnd_path;
-#endif
} LookupPaths;
typedef enum ManagerRunningAs {