summaryrefslogtreecommitdiff
path: root/Makefile-man.am
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2014-04-23 17:42:55 +0200
committerTom Gundersen <teg@jklm.no>2014-04-24 00:23:07 +0200
commit3a67e927e3be7efb8edf314a31aa4f8f5cba4f53 (patch)
tree5736719c730b85db89f6be3135290c565a02d046 /Makefile-man.am
parentfa4f8f9bc1fbef6a658cff39ac185bbedea6caf4 (diff)
networkd-wait-online: improve interoptability and enable by default
To make sure we don't delay boot on systems where (some) network links are managed by someone else we don't block if something else has successfully brought up a link. We will still block until all links we are aware of that are managed by networkd have been configured, but if no such links exist, and someone else have configured a link sufficiently that it has a carrier, it may be that the link is ready so we should no longer block. Note that in all likelyhood the link is not ready (no addresses/routes configured), so whatever network managment daemon configured it should provide a similar wait-online service to block network-online.target until it is ready. The aim is to block as long as we know networking is not fully configured, but no longer. This will allow systemd-networkd-wait-online.service to be enabled on any system, even if we don't know whether networkd is the main/only network manager. Even in the case networking is fully configured by networkd, the default behavior may not be sufficient: if two links need to be configured, but the first is fully configured before the second one appears we will assume the network is up. To work around that, we allow specifying specific devices to wait for before considering the network up. This unit is enabled by default, just like systemd-networkd, but will only be pulled in if anyone pulls in network-online.target.
Diffstat (limited to 'Makefile-man.am')
-rw-r--r--Makefile-man.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index 90d32c521..db66e020c 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -1039,12 +1039,17 @@ endif
if ENABLE_NETWORKD
MANPAGES += \
man/systemd-networkd.service.8 \
+ man/systemd-networkd-wait-online.service.8 \
+ man/networkd-wait-online.conf.5 \
man/systemd.netdev.5 \
man/systemd.network.5
MANPAGES_ALIAS += \
- man/systemd-networkd.8
+ man/systemd-networkd.8 \
+ man/systemd-networkd-wait-online.8
man/systemd-networkd.8: man/systemd-networkd.service.8
man/systemd-networkd.html: man/systemd-networkd.service.html
+man/systemd-networkd-wait-online.8: man/systemd-networkd-wait-online.service.8
+man/systemd-networkd-wait-online.html: man/systemd-networkd-wait-online.service.html
$(html-alias)
endif