summaryrefslogtreecommitdiff
path: root/Makefile-man.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-06-05 19:39:26 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-06-10 10:10:07 -0400
commit5302ebe15ff3a11eceb75e095e5a09d2a676de2b (patch)
treeaf3fe38ff0e433d824684e77840cbf00af7cf211 /Makefile-man.am
parent6eb7a9a0010d035e5bdbbf70227088ce02b2120e (diff)
journal: add sd_journal_open_files
This allows the caller to explicitly specify which journal files should be opened. The same functionality could be achieved before by creating a directory and playing around with symlinks. It is useful to debug stuff and explore the journal, and has been requested before. Waiting is supported, the journal will notice modifications on the files supplied when opening the journal, but will not add any new files.
Diffstat (limited to 'Makefile-man.am')
-rw-r--r--Makefile-man.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index a31427e9b..807ad783f 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -148,6 +148,7 @@ MANPAGES_ALIAS += \
man/sd_journal_get_timeout.3 \
man/sd_journal_next_skip.3 \
man/sd_journal_open_directory.3 \
+ man/sd_journal_open_files.3 \
man/sd_journal_perror.3 \
man/sd_journal_previous.3 \
man/sd_journal_previous_skip.3 \
@@ -248,6 +249,7 @@ man/sd_journal_get_monotonic_usec.3: man/sd_journal_get_realtime_usec.3
man/sd_journal_get_timeout.3: man/sd_journal_get_fd.3
man/sd_journal_next_skip.3: man/sd_journal_next.3
man/sd_journal_open_directory.3: man/sd_journal_open.3
+man/sd_journal_open_files.3: man/sd_journal_open.3
man/sd_journal_perror.3: man/sd_journal_print.3
man/sd_journal_previous.3: man/sd_journal_next.3
man/sd_journal_previous_skip.3: man/sd_journal_next.3
@@ -452,6 +454,9 @@ man/sd_journal_next_skip.html: man/sd_journal_next.html
man/sd_journal_open_directory.html: man/sd_journal_open.html
$(html-alias)
+man/sd_journal_open_files.html: man/sd_journal_open.html
+ $(html-alias)
+
man/sd_journal_perror.html: man/sd_journal_print.html
$(html-alias)