summaryrefslogtreecommitdiff
path: root/Makefile-man.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2014-03-17 18:14:26 +0100
committerLennart Poettering <lennart@poettering.net>2014-03-17 18:15:57 +0100
commitbf34ab149f3038686bc75e1592179abac1700322 (patch)
tree42a953b9e17ef1614a890f699f245c84bd6a831b /Makefile-man.am
parent7366b080b324caf66e2ca1671f8ce7f57ace7553 (diff)
sd-login: add calls that retrieve credentials of peers connected to AF_UNIX peers
This is supposed to be an extension of SO_PEERCRED and SO_PEERSEC, except for cgroup information.
Diffstat (limited to 'Makefile-man.am')
-rw-r--r--Makefile-man.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index 8a4ee9d17..079ba63e7 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -1179,6 +1179,12 @@ MANPAGES_ALIAS += \
man/sd_login_monitor_get_fd.3 \
man/sd_login_monitor_get_timeout.3 \
man/sd_login_monitor_unref.3 \
+ man/sd_peer_get_machine_name.3 \
+ man/sd_peer_get_owner_uid.3 \
+ man/sd_peer_get_session.3 \
+ man/sd_peer_get_slice.3 \
+ man/sd_peer_get_unit.3 \
+ man/sd_peer_get_user_unit.3 \
man/sd_pid_get_machine_name.3 \
man/sd_pid_get_owner_uid.3 \
man/sd_pid_get_slice.3 \
@@ -1213,6 +1219,12 @@ man/sd_login_monitor_get_events.3: man/sd_login_monitor_new.3
man/sd_login_monitor_get_fd.3: man/sd_login_monitor_new.3
man/sd_login_monitor_get_timeout.3: man/sd_login_monitor_new.3
man/sd_login_monitor_unref.3: man/sd_login_monitor_new.3
+man/sd_peer_get_machine_name.3: man/sd_pid_get_session.3
+man/sd_peer_get_owner_uid.3: man/sd_pid_get_session.3
+man/sd_peer_get_session.3: man/sd_pid_get_session.3
+man/sd_peer_get_slice.3: man/sd_pid_get_session.3
+man/sd_peer_get_unit.3: man/sd_pid_get_session.3
+man/sd_peer_get_user_unit.3: man/sd_pid_get_session.3
man/sd_pid_get_machine_name.3: man/sd_pid_get_session.3
man/sd_pid_get_owner_uid.3: man/sd_pid_get_session.3
man/sd_pid_get_slice.3: man/sd_pid_get_session.3
@@ -1265,6 +1277,24 @@ man/sd_login_monitor_get_timeout.html: man/sd_login_monitor_new.html
man/sd_login_monitor_unref.html: man/sd_login_monitor_new.html
$(html-alias)
+man/sd_peer_get_machine_name.html: man/sd_pid_get_session.html
+ $(html-alias)
+
+man/sd_peer_get_owner_uid.html: man/sd_pid_get_session.html
+ $(html-alias)
+
+man/sd_peer_get_session.html: man/sd_pid_get_session.html
+ $(html-alias)
+
+man/sd_peer_get_slice.html: man/sd_pid_get_session.html
+ $(html-alias)
+
+man/sd_peer_get_unit.html: man/sd_pid_get_session.html
+ $(html-alias)
+
+man/sd_peer_get_user_unit.html: man/sd_pid_get_session.html
+ $(html-alias)
+
man/sd_pid_get_machine_name.html: man/sd_pid_get_session.html
$(html-alias)