summaryrefslogtreecommitdiff
path: root/Makefile-man.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-03-15 15:58:03 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-03-17 01:55:48 -0400
commitcc64d0175a3c2c974709e9962c00fbe04d74c43f (patch)
treeb03dc9591925761c583a8b14c101c1052f1ace0d /Makefile-man.am
parentfdfccdbc985944a57017a25f44dd6acc1a937bab (diff)
journal-remote: HTTP(s) support
The whole tool is made dependent on µhttpd availability. It should be easy to make the µhttpd parts conditional, but since transfer over HTTP seems to be the primary use case, currently this is not done. Current implementation uses nested epoll loops: sd-event is used for the external event loop, and µhttpd uses epoll in its own loop. Unfortunately µhttpd does not expose enough information to add the descriptors it uses to the external event loop. This means that starvation of other events is possible, if one of the inner µhttpd loops is constantly busy. This means that µhttpd servers should not be mixed with other sources. The TLS authentication parts haven't been really tested properly, and should not be take too seriously.
Diffstat (limited to 'Makefile-man.am')
-rw-r--r--Makefile-man.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile-man.am b/Makefile-man.am
index eefd5eaa1..8a4ee9d17 100644
--- a/Makefile-man.am
+++ b/Makefile-man.am
@@ -68,7 +68,6 @@ MANPAGES += \
man/systemd-halt.service.8 \
man/systemd-inhibit.1 \
man/systemd-initctl.service.8 \
- man/systemd-journal-remote.8 \
man/systemd-journald.service.8 \
man/systemd-machine-id-setup.1 \
man/systemd-notify.1 \
@@ -1135,7 +1134,8 @@ endif
if HAVE_MICROHTTPD
MANPAGES += \
- man/systemd-journal-gatewayd.service.8
+ man/systemd-journal-gatewayd.service.8 \
+ man/systemd-journal-remote.8
MANPAGES_ALIAS += \
man/systemd-journal-gatewayd.8 \
man/systemd-journal-gatewayd.socket.8