summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2014-02-21 02:06:04 +0100
committerLennart Poettering <lennart@poettering.net>2014-02-21 02:43:14 +0100
commit099524d7b0df690e3361ffc3fe3c6aed0558b4fc (patch)
tree9983d7ff3452ce44a2a8150e124d01e998f8dbd9 /Makefile.am
parenta03c5fd2d86c4e3f758a5ca0d98638e5c8bd8d8d (diff)
core: add new ConditionArchitecture() that checks the architecture returned by uname()'s machine field.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ac90c1890..85d51b4a9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -674,6 +674,8 @@ libsystemd_shared_la_SOURCES = \
src/shared/util.h \
src/shared/virt.c \
src/shared/virt.h \
+ src/shared/architecture.c \
+ src/shared/architecture.h \
src/shared/efivars.c \
src/shared/efivars.h \
src/shared/path-util.c \
@@ -1150,7 +1152,8 @@ tests += \
test-list \
test-tables \
test-device-nodes \
- test-xml
+ test-xml \
+ test-architecture
EXTRA_DIST += \
test/sched_idle_bad.service \
@@ -1298,6 +1301,12 @@ test_time_SOURCES = \
test_time_LDADD = \
libsystemd-core.la
+test_architecture_SOURCES = \
+ src/test/test-architecture.c
+
+test_architecture_LDADD = \
+ libsystemd-shared.la
+
test_log_SOURCES = \
src/test/test-log.c