summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-01-07 08:41:24 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-07-20 19:48:16 -0400
commit0d8c31ff7237149b505290652864b4e7e866b2a7 (patch)
tree2a1497d3b0384fb7ab20c6010276be0e166619eb /Makefile.am
parentf0ea29eaeb3449822bfbdfa839b00e323dfc523e (diff)
test-engine: fix access to unit load path
Also add a bit of debugging output to help diagnose problems, add missing units, and simplify cppflags. Move test-engine to normal tests from manual tests, it should now work without destroying the system.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c6853e46e..585786398 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -189,6 +189,7 @@ AM_CPPFLAGS = \
-DKEXEC=\"$(KEXEC)\" \
-DLIBDIR=\"$(libdir)\" \
-DROOTLIBDIR=\"$(rootlibdir)\" \
+ -DTEST_DIR=\"$(abs_top_srcdir)/test\" \
-I $(top_srcdir)/src \
-I $(top_builddir)/src/shared \
-I $(top_srcdir)/src/shared \
@@ -1224,7 +1225,6 @@ CLEANFILES += \
# ------------------------------------------------------------------------------
manual_tests += \
- test-engine \
test-ns \
test-loopback \
test-hostname \
@@ -1242,6 +1242,7 @@ manual_tests += \
endif
tests += \
+ test-engine \
test-job-type \
test-env-replace \
test-strbuf \