summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-02-12 00:55:38 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-02-12 01:10:31 -0500
commit21ac6ff143cc8bebfbd1818af28e8c6f82cd5265 (patch)
treea61fe8976bb0253d567db8621f3cb7de6d378aa2 /Makefile.am
parentf366d58dc1fe51b300167446597750d29687c3c5 (diff)
man: use xinclude to de-deduplicate common text
I only tested with python-lxml. I'm not sure if xml.etree should be deprecated.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6a3fd4853..09547d32d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4645,7 +4645,7 @@ if ENABLE_MANPAGES
man/custom-entities.ent:
$(AM_V_GEN)$(MKDIR_P) $(dir $@)
$(AM_V_GEN)(echo '<?xml version="1.0" encoding="utf-8" ?>' && \
- echo '$(subst '|,<!ENTITY ,$(subst =, ",$(subst |',">,$(substitutions))))') \
+ printf '$(subst '|,<!ENTITY ,$(subst =, ",$(subst |',">\n,$(substitutions))))') \
> $@ # '
DISTCLEANFILES += \
@@ -4653,6 +4653,7 @@ DISTCLEANFILES += \
XSLTPROC_FLAGS = \
--nonet \
+ --xinclude \
--stringparam man.output.quietly 1 \
--stringparam funcsynopsis.style ansi \
--stringparam man.authors.section.enabled 0 \